summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-03-08 21:36:20 +0100
committerSam James <sam@gentoo.org>2022-07-15 03:11:57 +0100
commit199dd6a3fe469909a0aab1ffc9fb51f0c369b62c (patch)
tree7df2e0fd2fb90a298901c4d55ed9d5483ecef8e4 /dev-python/python-constraint
parentdev-python/pylatexenc: new package (diff)
downloadgentoo-199dd6a3fe469909a0aab1ffc9fb51f0c369b62c.tar.gz
gentoo-199dd6a3fe469909a0aab1ffc9fb51f0c369b62c.tar.bz2
gentoo-199dd6a3fe469909a0aab1ffc9fb51f0c369b62c.zip
dev-python/python-constraint: new package
Closes: https://bugs.gentoo.org/834768 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Gábor Oszkár Dénes <gaboroszkar@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/python-constraint')
-rw-r--r--dev-python/python-constraint/Manifest1
-rw-r--r--dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch11
-rw-r--r--dev-python/python-constraint/metadata.xml20
-rw-r--r--dev-python/python-constraint/python-constraint-1.4.0.ebuild23
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-constraint/Manifest b/dev-python/python-constraint/Manifest
new file mode 100644
index 000000000000..8ba24b510129
--- /dev/null
+++ b/dev-python/python-constraint/Manifest
@@ -0,0 +1 @@
+DIST python-constraint-1.4.0.gh.tar.gz 24966 BLAKE2B 5ada7926f226536a1384bf9a082da41824e46d683ee71a278c50e1e5ca0a21eb3acbde4c0b47d6b48c53864ab4ea47d602fc9acb976423035aee74b0c6f3ed85 SHA512 fbc65ba5854e227e62469290e2d8362ed3247931592e2ac7eb5bcd5d3f9f720bbab8a984a8f7cf9dce989663f13965c5401286a1bdc673c2c076c8b22e19f0cd
diff --git a/dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch b/dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch
new file mode 100644
index 000000000000..797b8e18cff5
--- /dev/null
+++ b/dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch
@@ -0,0 +1,11 @@
+--- a/setup.py 2022-02-27 15:57:35.035889587 +0100
++++ b/setup.py 2022-02-27 15:58:04.049889476 +0100
+@@ -70,7 +70,7 @@
+ keywords="csp constraint solving problems problem solver",
+ # You can just specify the packages manually here if your project is
+ # simple. Or you can use find_packages().
+- packages=find_packages(exclude=["contrib", "docs", "tests*"]),
++ packages=find_packages(exclude=["contrib", "docs", "tests*", "examples*"]),
+ # List run-time dependencies here. These will be installed by pip when your
+ # project is installed. For an analysis of "install_requires" vs pip's
+ # requirements files see:
diff --git a/dev-python/python-constraint/metadata.xml b/dev-python/python-constraint/metadata.xml
new file mode 100644
index 000000000000..a8c024c1f192
--- /dev/null
+++ b/dev-python/python-constraint/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Python constraint module offers solvers for Constraint Satisfaction Problems (CSPs) over finite domains in simple and pure Python. CSP is class of problems which may be represented in terms of variables (a, b, ...), domains (a in [1, 2, 3], ...), and constraints (a &lt; b, ...).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">python-constraint/python-constraint</remote-id>
+ <remote-id type="pypi">python-constraint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-constraint/python-constraint-1.4.0.ebuild b/dev-python/python-constraint/python-constraint-1.4.0.ebuild
new file mode 100644
index 000000000000..e7a17dd7f275
--- /dev/null
+++ b/dev-python/python-constraint/python-constraint-1.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Constraint Solving Problem resolver for Python"
+HOMEPAGE="https://github.com/python-constraint/python-constraint"
+SRC_URI="https://github.com/python-constraint/python-constraint/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/python-constraint-1.4.0-exclude-examples.patch"
+)
+
+distutils_enable_tests pytest