summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tablib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tablib')
-rw-r--r--dev-python/tablib/Manifest2
-rw-r--r--dev-python/tablib/metadata.xml8
-rw-r--r--dev-python/tablib/tablib-0.10.0.ebuild21
-rw-r--r--dev-python/tablib/tablib-0.9.11.ebuild21
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tablib/Manifest b/dev-python/tablib/Manifest
new file mode 100644
index 000000000000..5812f34a0ffb
--- /dev/null
+++ b/dev-python/tablib/Manifest
@@ -0,0 +1,2 @@
+DIST tablib-0.10.0.tar.gz 724961 SHA256 41c2dad7f491f5557e22783a9af81bed62f7b6fb0d7afd4c2ee301f3eb428c93 SHA512 1582e574297386d20908aee00eeef415258fbcfe5387e6bbcb3a0e497662e7f107c35596624ca31b2b6ad49045a7a388ddb6f64171b9eb2a1b386324a7b29b47 WHIRLPOOL 39b3d792858a9ce08e6f0276a070575c2c3546e3377b15d98b130a288ecdc3c91ea671fa43790928aa4ee641616ee6fc1b3a7c008c0c40d243b2338e1892b0b8
+DIST tablib-0.9.11.tar.gz 571410 SHA256 05d7a1bcf5e723f1051b87bc4a699fce6f5a3fa158d91308c478ec7cd74290fd SHA512 bdc11b8d54c5d9edb7ac980859cdbb932162b1db5161c582a141b2a6a5b8f0742f3d55f248d3e4e5b4173727a5916af385b607ce807f7d2e4402b7ef62c5bad0 WHIRLPOOL 61a5bf5e26d9b2999857597dd4574f76b3fdc0762f86588e539bd6a70109ea464a7ff0f07145592e3ddcf1712df13fd6defbc9fb9a9c5a1ae558c870df0da82a
diff --git a/dev-python/tablib/metadata.xml b/dev-python/tablib/metadata.xml
new file mode 100644
index 000000000000..f253786e7cac
--- /dev/null
+++ b/dev-python/tablib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="pypi">tablib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tablib/tablib-0.10.0.ebuild b/dev-python/tablib/tablib-0.10.0.ebuild
new file mode 100644
index 000000000000..e2b109b0dd3d
--- /dev/null
+++ b/dev-python/tablib/tablib-0.10.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A format-agnostic tabular dataset library written in Python"
+HOMEPAGE="http://python-tablib.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/tablib/tablib-0.9.11.ebuild b/dev-python/tablib/tablib-0.9.11.ebuild
new file mode 100644
index 000000000000..b0b029efe612
--- /dev/null
+++ b/dev-python/tablib/tablib-0.9.11.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A format-agnostic tabular dataset library written in Python"
+HOMEPAGE="http://python-tablib.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"