summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/vertex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/vertex')
-rw-r--r--dev-python/vertex/Manifest2
-rw-r--r--dev-python/vertex/metadata.xml16
-rw-r--r--dev-python/vertex/vertex-0.3.0-r1.ebuild27
-rw-r--r--dev-python/vertex/vertex-0.3.1.ebuild27
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/vertex/Manifest b/dev-python/vertex/Manifest
new file mode 100644
index 000000000000..3f61cece6eba
--- /dev/null
+++ b/dev-python/vertex/Manifest
@@ -0,0 +1,2 @@
+DIST Vertex-0.3.0.tar.gz 84997 SHA256 f397b48c76289f658dc042f6978fcc1c5e7a059ec507df39b91aec2da6753ea5 SHA512 206d142cc72b2d77ed8c8fe222770eabc1a8c179238f46554abc5d833669f27bd286565e20ccaf5594d456b23b54455b23ab0eca5b8b4f72a7961924e7167676 WHIRLPOOL a0bca99a89d40d34c2afef3a1b361e07fe54b6c47663bc79c41a790d2c16be017be3ff02540eb481d554cffb7aaf196ca20f8a792c5a89f188a83a653d8598d4
+DIST Vertex-0.3.1.tar.gz 89909 SHA256 2a81a33bb21392ae2c068399d6a720c6c5fef8b3591528ba7300749d1a054c43 SHA512 7e9b96a7ba493254ff58e8f75da6517c09c4502c21702a96c29525a78569ff7d988cd7278dd87983485b6da30a607820a7edb28375e37d5e059d6f0638a1b1c9 WHIRLPOOL 8827e68c7ce778bf8ece84e7002721e32ded3c9c1af699c5ab690595be0126e84f8a4d3cb280b2f358fa78e2f10f228c5cf785e76923bbd8aaf889085c7a1cc2
diff --git a/dev-python/vertex/metadata.xml b/dev-python/vertex/metadata.xml
new file mode 100644
index 000000000000..ee44d1cd0503
--- /dev/null
+++ b/dev-python/vertex/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">Vertex is an implementation of the Q2Q protocol (sort of like P2P,
+ but one better). There are a few moving parts in Vertex: PTCP is a
+ protocol which is nearly identical to TCP, but which runs over
+ UDP. This lets Q2Q penetrate most NAT configurations. JUICE
+ ([JU]ice [I]s [C]oncurrent [E]vents) is a very simple but immensely
+ flexible protocol which forms the basis of the high-level aspects of
+ Q2Q. vertex is a command line tool which exposes a few features
+ useful in many situations (such as registration and authentication).</longdescription>
+ <upstream>
+ <remote-id type="pypi">Vertex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/vertex/vertex-0.3.0-r1.ebuild b/dev-python/vertex/vertex-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..b836da595d8e
--- /dev/null
+++ b/dev-python/vertex/vertex-0.3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex http://pypi.python.org/pypi/Vertex"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc NAME.txt
+}
diff --git a/dev-python/vertex/vertex-0.3.1.ebuild b/dev-python/vertex/vertex-0.3.1.ebuild
new file mode 100644
index 000000000000..748f789d56c4
--- /dev/null
+++ b/dev-python/vertex/vertex-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex http://pypi.python.org/pypi/Vertex"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc NAME.txt
+}