summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/astrolabe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/astrolabe')
-rw-r--r--dev-ruby/astrolabe/Manifest2
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.0.ebuild29
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.1.ebuild29
-rw-r--r--dev-ruby/astrolabe/metadata.xml8
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/astrolabe/Manifest b/dev-ruby/astrolabe/Manifest
new file mode 100644
index 000000000000..90e825601eae
--- /dev/null
+++ b/dev-ruby/astrolabe/Manifest
@@ -0,0 +1,2 @@
+DIST astrolabe-1.3.0.gem 16384 SHA256 23f774f5fa164e293bbf3977e42fe0258f49f06a5fd62080fae27d7248fddea1 SHA512 8acc0cd432b2aadff81ae6599a26e1778680d7e8cdd9af0644156e08151e27eabaf6e8bc4afffa0e51930b477823fc6c903f4fe88029989f5096df265df8504e WHIRLPOOL c0a2a55ec4df6cd986e322a8b07dbf9aee629cfb09b991e6ec4f1c1cf342bda8877b7b49f3f1c5298a2707540606bbd9475f0a86675f8a72f8b5dc4840f767ed
+DIST astrolabe-1.3.1.gem 16384 SHA256 879e2edf7b04b4f03cf7bff9cf1e1cee20772569c81399e1de4914a7baac6b79 SHA512 db29d26559e4adb82e4a25a3b7d3df94fcb9847dbd65abdb25abd0181b60af2e0fe0021bb8193c5f94d58e074da06de3d1f7170cb341ac675e3c3ab39ba95bef WHIRLPOOL 6604073a319f322bd65d5e4ee3ff23534ab7cfa72cebdbbbc8ed1ace1360884ee7b149af36dd6553ad931490240983ed6ea849592e01876ac4f2c6c09481f112
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild
new file mode 100644
index 000000000000..a03dd8eb175c
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
new file mode 100644
index 000000000000..a03dd8eb175c
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}
diff --git a/dev-ruby/astrolabe/metadata.xml b/dev-ruby/astrolabe/metadata.xml
new file mode 100644
index 000000000000..65d9054e3ab4
--- /dev/null
+++ b/dev-ruby/astrolabe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">yujinakayama/astrolabe</remote-id>
+ </upstream>
+</pkgmetadata>