summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/coolio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/coolio')
-rw-r--r--dev-ruby/coolio/Manifest2
-rw-r--r--dev-ruby/coolio/coolio-1.2.1.ebuild55
-rw-r--r--dev-ruby/coolio/coolio-1.3.0.ebuild55
-rw-r--r--dev-ruby/coolio/files/coolio-1.1.0-libev.patch24
-rw-r--r--dev-ruby/coolio/files/coolio-1.1.0-rubyio.patch32
-rw-r--r--dev-ruby/coolio/metadata.xml6
6 files changed, 174 insertions, 0 deletions
diff --git a/dev-ruby/coolio/Manifest b/dev-ruby/coolio/Manifest
new file mode 100644
index 000000000000..4758da002b7d
--- /dev/null
+++ b/dev-ruby/coolio/Manifest
@@ -0,0 +1,2 @@
+DIST cool.io-1.2.1.gem 112128 SHA256 2ed7857bb7ec5c53e683a05db07798f0adbaaef35a960d9e0addfacc1fe6b684 SHA512 778605986fb33b1370d780cc986921b09dea2a4e54464753042b83c18d5a18d61f83920050bcc1f2452354d3965bbd0be26f56fafc4ec4700772e8350da33ccb WHIRLPOOL 57dfd569f7a4786e546a67a0b89a1335358f3f1621f265f554647636406218e6d95f0c4d85e498f38c9827c186d524487002d0a57fc8444caf931bd18691d01f
+DIST cool.io-1.3.0.gem 105984 SHA256 f053b308cca450efa2d6e5195f8111e42302732cd38345c9d326af2786027de8 SHA512 0c7c3fa132b603a44e02eecc13c4ca0fdf11d4ddc90bcc7b3bda0c40c198116b1b9c5724a835e0734875a1a58c3c79974c2add7c6e5ec2036598f8a221cadbe8 WHIRLPOOL 640bff16aab808fbc879ca971d19de482338c944e9ac2febaefc4fdbceda45cc91075e668387b90188bbf71da08a3d8e08e366990c18f505b5a03d731c5eb622
diff --git a/dev-ruby/coolio/coolio-1.2.1.ebuild b/dev-ruby/coolio/coolio-1.2.1.ebuild
new file mode 100644
index 000000000000..b653e642d366
--- /dev/null
+++ b/dev-ruby/coolio/coolio-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# iobuffer: -jruby -rbx
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_NAME="cool.io"
+
+RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
+HOMEPAGE="http://coolio.github.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libev"
+RDEPEND="${DEPEND}"
+
+RUBY_PATCHES=( "${PN}-1.1.0-libev.patch" "${PN}-1.1.0-rubyio.patch" )
+
+ruby_add_rdepend ">=dev-ruby/iobuffer-1"
+
+all_ruby_prepare() {
+ rm -r Gemfile* ext/libev ext/cool.io/libev.c lib/.gitignore || die
+
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove specs that require network connectivity
+ rm spec/dns_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cool.io extconf.rb || die
+ ${RUBY} -Cext/http11_client extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cool.io
+ cp ext/cool.io/cool.io_ext$(get_modname) lib/ || die
+
+ emake V=1 -Cext/http11_client
+ cp ext/http11_client/http11_client$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/coolio/coolio-1.3.0.ebuild b/dev-ruby/coolio/coolio-1.3.0.ebuild
new file mode 100644
index 000000000000..c95af551b1eb
--- /dev/null
+++ b/dev-ruby/coolio/coolio-1.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# iobuffer: -rbx
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_NAME="cool.io"
+
+RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
+HOMEPAGE="http://coolio.github.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND+=" >=dev-libs/libev-4.19"
+RDEPEND+=" >=dev-libs/libev-4.19"
+
+RUBY_PATCHES=( "${PN}-1.1.0-libev.patch" "${PN}-1.1.0-rubyio.patch" )
+
+ruby_add_rdepend ">=dev-ruby/iobuffer-1"
+
+all_ruby_prepare() {
+ rm -r Gemfile* ext/libev ext/cool.io/libev.c lib/.gitignore || die
+
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove specs that require network connectivity
+ rm spec/dns_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cool.io extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cool.io
+ cp ext/cool.io/cool.io_ext$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/coolio/files/coolio-1.1.0-libev.patch b/dev-ruby/coolio/files/coolio-1.1.0-libev.patch
new file mode 100644
index 000000000000..e559667ef7c5
--- /dev/null
+++ b/dev-ruby/coolio/files/coolio-1.1.0-libev.patch
@@ -0,0 +1,24 @@
+diff -Naur coolio-1.1.0.orig/ext/cool.io/ev_wrap.h coolio-1.1.0/ext/cool.io/ev_wrap.h
+--- coolio-1.1.0.orig/ext/cool.io/ev_wrap.h 2012-03-15 03:30:08.755266522 +0900
++++ coolio-1.1.0/ext/cool.io/ev_wrap.h 2012-03-15 03:31:50.839378421 +0900
+@@ -4,5 +4,5 @@
+ # define FD_SETSIZE 2048 /* wishful thinking, as msvcrt6 [?] seems to only allow 512 fd's and 256 sockets max */
+ #endif
+
+-#include "../libev/ev.h"
++#include "ev.h"
+
+diff -Naur coolio-1.1.0.orig/ext/cool.io/extconf.rb coolio-1.1.0/ext/cool.io/extconf.rb
+--- coolio-1.1.0.orig/ext/cool.io/extconf.rb 2012-03-15 03:30:08.755266522 +0900
++++ coolio-1.1.0/ext/cool.io/extconf.rb 2012-03-15 03:31:04.114327009 +0900
+@@ -20,6 +20,10 @@
+ libs << "-lrt"
+ end
+
++if have_library('ev', 'ev_loop_new')
++ libs << "-lev"
++end
++
+ if have_header('sys/select.h')
+ $defs << '-DEV_USE_SELECT'
+ end
diff --git a/dev-ruby/coolio/files/coolio-1.1.0-rubyio.patch b/dev-ruby/coolio/files/coolio-1.1.0-rubyio.patch
new file mode 100644
index 000000000000..a47e607702ca
--- /dev/null
+++ b/dev-ruby/coolio/files/coolio-1.1.0-rubyio.patch
@@ -0,0 +1,32 @@
+diff --git a/ext/cool.io/cool.io.h b/ext/cool.io/cool.io.h
+index 364d4ae..05ce5bc 100644
+--- a/ext/cool.io/cool.io.h
++++ b/ext/cool.io/cool.io.h
+@@ -8,7 +8,11 @@
+ #define COOLIO_H
+
+ #include "ruby.h"
++#ifdef HAVE_RUBY_IO_H
++#include "ruby/io.h"
++#else
+ #include "rubyio.h"
++#endif
+
+ #ifdef GetReadFile
+ #define FPTR_TO_FD(fptr) (fileno(GetReadFile(fptr)))
+diff --git a/ext/cool.io/iowatcher.c b/ext/cool.io/iowatcher.c
+index 09ff87b..ccf6a3f 100644
+--- a/ext/cool.io/iowatcher.c
++++ b/ext/cool.io/iowatcher.c
+@@ -5,7 +5,11 @@
+ */
+
+ #include "ruby.h"
++#ifdef HAVE_RUBY_IO_H
++#include "ruby/io.h"
++#else
+ #include "rubyio.h"
++#endif
+
+ #include "ev_wrap.h"
+
diff --git a/dev-ruby/coolio/metadata.xml b/dev-ruby/coolio/metadata.xml
new file mode 100644
index 000000000000..fbf4d3550bc3
--- /dev/null
+++ b/dev-ruby/coolio/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
+