summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-13 08:44:18 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-13 08:44:18 +0200
commitd9361b1475d60f4567db8e0f557d9778e5da8a4a (patch)
tree4aff0e2f975895bb391f3713a4b9b870ff808d4e /dev-ruby/date_validator
parentdev-ruby/bundler: add 2.2.17 (diff)
downloadgentoo-d9361b1475d60f4567db8e0f557d9778e5da8a4a.tar.gz
gentoo-d9361b1475d60f4567db8e0f557d9778e5da8a4a.tar.bz2
gentoo-d9361b1475d60f4567db8e0f557d9778e5da8a4a.zip
dev-ruby/date_validator: add 0.11.0
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/Manifest1
-rw-r--r--dev-ruby/date_validator/date_validator-0.11.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/date_validator/Manifest b/dev-ruby/date_validator/Manifest
index 39e685331cc4..da30ccf91b7d 100644
--- a/dev-ruby/date_validator/Manifest
+++ b/dev-ruby/date_validator/Manifest
@@ -1 +1,2 @@
DIST date_validator-0.10.0.gem 12800 BLAKE2B 0cbb11e70cb72a1203c2ec33581d4ed48be346af6998faa89e4323c8c6bf70b5c979b55bc79630153a940697c89ce140eb511538cd55adb0f12566f2f1a317a9 SHA512 4348835898ebfe311a8ea456adc10f7bbfd1dc21daf2678e32b1615ba3eef3d36671f67f533109882f40516c836f23d7e0a4072c9ecaa55a1b0eade0b6aa75b7
+DIST date_validator-0.11.0.gem 12800 BLAKE2B ce45caa57bd1e29900ed0732bdbfbf81c68836de71efbf099bdc595a9b586872175960af40129af6d793ed5ce49ba222a3ca7d0172ef764ee02c88f4eae04e9e SHA512 269f3e234c8157a667c81d725497eafd21621cd35811f35707590242a3dc78065bd6dbe7b772a38761fdb8c95ae40f99976919444dac061f7bd2150fc9178afa
diff --git a/dev-ruby/date_validator/date_validator-0.11.0.ebuild b/dev-ruby/date_validator/date_validator-0.11.0.ebuild
new file mode 100644
index 000000000000..8d4f4549e483
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails"
+HOMEPAGE="https://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i \
+ -e '/[Bb]undler/s/^/#/' Rakefile || die
+ # Fix tests
+ sed -i -e "1irequire 'active_support'; require 'active_support/core_ext/time/zones'" test/test_helper.rb || die
+}