summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-15 08:15:31 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-15 08:15:31 +0100
commitd9ab28be9bd7ff4e291c2420dc133094ce9b19d1 (patch)
tree124ba15aca598e4006f7d12956242db0f288da3d /dev-ruby/pkg-config
parentdev-perl/Template-DBI: EAPI6, fix for .-in-@INC failing test bug #623120 (diff)
downloadgentoo-d9ab28be9bd7ff4e291c2420dc133094ce9b19d1.tar.gz
gentoo-d9ab28be9bd7ff4e291c2420dc133094ce9b19d1.tar.bz2
gentoo-d9ab28be9bd7ff4e291c2420dc133094ce9b19d1.zip
dev-ruby/pkg-config: add 1.2.9
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/Manifest1
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.2.9.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
index ad7d74a335f5..7fe0ff3dfbaf 100644
--- a/dev-ruby/pkg-config/Manifest
+++ b/dev-ruby/pkg-config/Manifest
@@ -1,2 +1,3 @@
DIST pkg-config-1.1.7.gem 19456 BLAKE2B ae6f3641181a60aa46a2da63a5343f23c4a41a9499ff5e00b1115ddfb328a4db33db2890d234f5cbc9a45af28aa537e886c776f0a8f24e54e307f637e5a2c8ae SHA512 9f515874d3edabdfff5f4c8d624bbc91e9c5032e79c241412cd073f0a049e35a2e2a660d5503eaae9640286d74cb98510bbbb34f757c702e220f728fba1c2337
DIST pkg-config-1.2.8.gem 20480 BLAKE2B cc11b5eff30f0f5e1a91e64902931ed540da108fd326fe731b71527c9c4310f55e9002617e1baae4f71a4b705b20cf10f6fa112f8ef56971e82868145d372a47 SHA512 d83a599a48c7d404946054c6846b6cfd9fce2a264c288519a6eccd9787f05d45397dd46300bf97c80700921456318154ea6d44ba32cd159803471073c2a2b065
+DIST pkg-config-1.2.9.gem 20480 BLAKE2B 8a77d1b00082635ff622940cf313e18e9639e22d7cc0cc170ef62b65c69a3f2d98409339de3d8de2c765699734c6177dfa77ca8357090c4f8d805b9cff453f40 SHA512 6b16b741f8efce51623a98a1979b3bc8af18ce6d74bd35f46baafa9eb19bdab50372921f8548a958bc4428f5e9ff0015ca9ec1700065d70bb9fb9d2a98c311c7
diff --git a/dev-ruby/pkg-config/pkg-config-1.2.9.ebuild b/dev-ruby/pkg-config/pkg-config-1.2.9.ebuild
new file mode 100644
index 000000000000..961b61c5e574
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}