summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tablelist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tablelist')
-rw-r--r--dev-tcltk/tablelist/Manifest1
-rw-r--r--dev-tcltk/tablelist/metadata.xml8
-rw-r--r--dev-tcltk/tablelist/tablelist-5.8.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-tcltk/tablelist/Manifest b/dev-tcltk/tablelist/Manifest
new file mode 100644
index 000000000000..f3bcf9744b67
--- /dev/null
+++ b/dev-tcltk/tablelist/Manifest
@@ -0,0 +1 @@
+DIST tablelist5.8.tar.gz 416416 SHA256 4e24d2e2eae368d1a80d063c0682ff936aef1ffb03afc2f4ef221aacb2b06dd8 SHA512 9c8e3577ae0e89291450c7ecccbbb042417d9a24255489e9257eae2b48454cbef4ec759949ddfc8d73123260da3fc506e01acf6c15e113e5112ed15c014d6833 WHIRLPOOL 002b22975e9667b061e8a84b9cb55ab9d73f1317d517749dbb5c7496b3bf406fe49d218ac7ace5fa3de57f10a580f5db9f46a3fd9d48fef3311d575c6ea40c43
diff --git a/dev-tcltk/tablelist/metadata.xml b/dev-tcltk/tablelist/metadata.xml
new file mode 100644
index 000000000000..5ef07a39e7e1
--- /dev/null
+++ b/dev-tcltk/tablelist/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-tcltk/tablelist/tablelist-5.8.ebuild b/dev-tcltk/tablelist/tablelist-5.8.ebuild
new file mode 100644
index 000000000000..1cce0d16f105
--- /dev/null
+++ b/dev-tcltk/tablelist/tablelist-5.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Multi-Column Listbox Package"
+HOMEPAGE="http://www.nemethi.de/tablelist/index.html"
+SRC_URI="http://www.nemethi.de/tablelist/${MY_P}.tar.gz"
+
+LICENSE="tablelist"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE="examples doc"
+
+RDEPEND="dev-lang/tcl:0"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/${MY_P}
+ doins -r ${PN}* pkgIndex.tcl scripts
+ use doc && dohtml doc/*
+ use examples && insinto /usr/share/${PN} && doins -r demos
+ dodoc README.txt
+}