summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-05 14:47:05 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-05 14:48:13 -0500
commit000209220ccfe972e3ecad734c9fdf9ff3adde07 (patch)
treeb1365ffc39cd2088313778657486da63d1b7a876 /games-action
parentapp-arch/libarchive: Add src_prepare w/ eautoreconf, fix OSX acl #587890 (diff)
downloadgentoo-000209220ccfe972e3ecad734c9fdf9ff3adde07.tar.gz
gentoo-000209220ccfe972e3ecad734c9fdf9ff3adde07.tar.bz2
gentoo-000209220ccfe972e3ecad734c9fdf9ff3adde07.zip
games-action/barrage: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-action')
-rw-r--r--games-action/barrage/barrage-1.0.4-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-action/barrage/barrage-1.0.4-r1.ebuild b/games-action/barrage/barrage-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..9790b9f8e4eb
--- /dev/null
+++ b/games-action/barrage/barrage-1.0.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A violent point-and-click shooting game"
+HOMEPAGE="http://lgames.sourceforge.net"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2.4"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ newicon barrage48.png ${PN}.png
+ make_desktop_entry ${PN} Barrage
+ rm "${D}"/usr/share/applications/${PN}.desktop
+}