summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/pioneers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/pioneers')
-rw-r--r--games-board/pioneers/Manifest1
-rw-r--r--games-board/pioneers/metadata.xml14
-rw-r--r--games-board/pioneers/pioneers-15.3.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/games-board/pioneers/Manifest b/games-board/pioneers/Manifest
new file mode 100644
index 000000000000..f894de727f31
--- /dev/null
+++ b/games-board/pioneers/Manifest
@@ -0,0 +1 @@
+DIST pioneers-15.3.tar.gz 4154470 SHA256 69afa51b71646565536b571b0f89786d3a7616965265f196fd51656b51381a89 SHA512 57aa8bc48019c87a683a4728d28d56f6bd755a0566922dddb4de825904820d1204f893e73fd13465fcec63cecb4a5735a90338f6ff915b7f17113dc0f1e834c1 WHIRLPOOL d9f313bde1b8e1042031784905f3dd3ad133da5b3e9096e147b74d75196875615a0b52053fdd73c615c006ed40f3019b30b030e1882e193fc2335fdc3914e8b1
diff --git a/games-board/pioneers/metadata.xml b/games-board/pioneers/metadata.xml
new file mode 100644
index 000000000000..fd23dc88c4b9
--- /dev/null
+++ b/games-board/pioneers/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+ Pio (Pioneers) is a clone of the board game The Settlers of Catan.
+</longdescription>
+ <use>
+ <flag name="help">Enable gnome ingame help via scrollkeeper</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/pioneers/pioneers-15.3.ebuild b/games-board/pioneers/pioneers-15.3.ebuild
new file mode 100644
index 000000000000..7641839e26ad
--- /dev/null
+++ b/games-board/pioneers/pioneers-15.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome-games
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="dedicated help nls"
+
+# dev-util/gob only for autoreconf
+RDEPEND=">=dev-libs/glib-2.26:2
+ !dedicated? (
+ >=x11-libs/gtk+-3.4:3
+ >=x11-libs/libnotify-0.7.4
+ help? (
+ app-text/rarian
+ >=gnome-base/libgnome-2.10
+ )
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/gob:2
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome-games_src_configure \
+ $(use_enable nls) \
+ $(use_enable help) \
+ --includedir=/usr/include \
+ $(use_with !dedicated gtk)
+}
+
+src_install() {
+ DOCS='AUTHORS ChangeLog README TODO NEWS' \
+ gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
+ prepgamesdirs
+}