summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-06 17:06:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-06 17:09:11 -0400
commita113790fc37885c36d3de067fe736c74d248e706 (patch)
treeba8c6f2a28c8045f2db2b2c4a4ce2ba52e6c6c29 /games-board
parentdev-util/android-udev-rules: Stabilize 20240221 ALLARCHES, #928846 (diff)
downloadgentoo-a113790fc37885c36d3de067fe736c74d248e706.tar.gz
gentoo-a113790fc37885c36d3de067fe736c74d248e706.tar.bz2
gentoo-a113790fc37885c36d3de067fe736c74d248e706.zip
games-board/pysolfc: add 3.0.0, enable py3.12
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pysolfc/Manifest3
-rw-r--r--games-board/pysolfc/pysolfc-3.0.0.ebuild69
2 files changed, 72 insertions, 0 deletions
diff --git a/games-board/pysolfc/Manifest b/games-board/pysolfc/Manifest
index 8dbe78a6cdb0..67bdcc2a039f 100644
--- a/games-board/pysolfc/Manifest
+++ b/games-board/pysolfc/Manifest
@@ -1,3 +1,6 @@
DIST PySolFC-2.21.0.tar.xz 20021468 BLAKE2B afb73675ab57ffbad96b3a6113733494343c481d18651c0932a2da28d58649a67031d280b49ee31b672abe2ca840d0ce1bb92f7e498f5fc567524eb7bdb26792 SHA512 7e2f4d45810288880a8b0d866110be00805c27d20dc94a4393079b94579253ee6bc1ed7355752842faf092d7a1bfe03ec4c3d6e1e61f2ddb39b959b3a830448d
+DIST PySolFC-3.0.0.tar.xz 33364860 BLAKE2B 964e0c7642d713f97c0655597ca893a6396d6c4968fcc9dc0c7487948bb5f94e349f70a7cb5b006760653719d6a51775f5e2944b48f84d45b5b3dda22be1b1e9 SHA512 f7c9bc6dff71047516979a6d9fb559c616d5d76c0b0a476564114f8b302788145599cc89cabbfbdc110a5a4eab6148bddb57a4847f40077ccbbe972f36b811b0
DIST PySolFC-Cardsets--Minimal-2.2.0.tar.xz 23145612 BLAKE2B f98e51c9609bda850cf39ffcd255c7d5c729bc01c35475b1f99a4a4d4ec6a436d44d7e5ecdcce3726616aeaff19617dba6735861f6c5677d2c197882d631a475 SHA512 d5eb0753d14e0758f410d843f553ca6c03acc6d4283b447016e959c889c9dada29fa3facead44354782010b52ec51e0d095858d3b78243ad5280068ec6cd3e31
+DIST PySolFC-Cardsets--Minimal-3.0.0.tar.xz 25188212 BLAKE2B a047a151b5c4256cfb0300c6bc75713db9aab63e4e76ba99233a59f39a9a7017406320a0e3b874b72084b3bccd14ca303f7af9666652efee85cf39803ad8c43c SHA512 9d4bacd072b450b29b9f1bec4557121a3647c2f837aeb6e249f452cb886467c5e7ca36dd36a78ea69a5c9df6f30d5245e12681d9d02fc9da2ece09c25d77e787
DIST PySolFC-Cardsets-2.2.tar.bz2 65408375 BLAKE2B 7c0f4bb245d628222e0c8e3b56739c52d77aa6f62088b547c077368591ac3632300a9a35145ddbc33bfdf3accd91d261d103be6777db8c3cbb5576683358b0de SHA512 5562e572909eba96399c79487127b3d98c8f0e1ad145469e48fd6c3803334ba11c41e403d7dcaab5cd01324219426f7afdba9459d97b03071dd67b6dd73ce304
+DIST PySolFC-Cardsets-3.0.tar.bz2 87075654 BLAKE2B 527463ba2abe22c553753f7cb8f6608867a3da01532461cd29b5cf007a49c242cbdbe82f50751283d17a46ecb15b263e324fbc1288b5c5eb3cc9bdc1cfc9b257 SHA512 4544bc8b890d0cd41d66bd513faf86c21455f4d0f154e567fd689917f2f3ca56fadf3ca9372bc80c5b1d5387aa4abfab7952e73024a3e41101112e716f80b762
diff --git a/games-board/pysolfc/pysolfc-3.0.0.ebuild b/games-board/pysolfc/pysolfc-3.0.0.ebuild
new file mode 100644
index 000000000000..3b11c67b9268
--- /dev/null
+++ b/games-board/pysolfc/pysolfc-3.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 xdg
+
+MY_PN="PySolFC"
+MY_P="${MY_PN}-${PV}"
+PS_CARD_P="${MY_PN}-Cardsets-3.0"
+PS_CARD_MIN_P="${MY_PN}-Cardsets--Minimal-3.0.0"
+
+DESCRIPTION="Exciting collection of more than 1000 solitaire card games"
+HOMEPAGE="https://pysolfc.sourceforge.io/"
+SRC_URI="
+ mirror://sourceforge/pysolfc/${MY_P}.tar.xz
+ extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_P}.tar.bz2 )
+ !extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_MIN_P}.tar.xz )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="extra-cardsets minimal +sound"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pysol-cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ !minimal? ( dev-python/pillow[jpeg,tk,${PYTHON_USEDEP}] )
+ ')
+ !minimal? ( dev-tcltk/tktable )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ if use extra-cardsets; then
+ find ../${PS_CARD_P} -type d -name .thumbnails -exec rm -r {} + || die
+ fi
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.md NEWS.asciidoc README.md )
+ distutils-r1_python_install_all
+
+ doman docs/pysol{,fc}.6
+
+ insinto /usr/share/${MY_PN}
+ doins -r ../$(usex extra-cardsets ${PS_CARD_P} ${PS_CARD_MIN_P})/.
+
+ # html files are used at runtime, keep at default location
+ dosym -r /usr/share/{${MY_PN},doc/${PF}}/html
+
+ # russian translation is not currently displaying right
+ # https://forums.gentoo.org/viewtopic-t-1142910.html
+ rm -- "${ED}"/usr/share/locale/ru/LC_MESSAGES/pysol.mo || die
+}