summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-09 13:50:56 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-09 13:50:58 -0500
commit30b84d03e116543ed1df04a5e1165cc7ab8f0dd9 (patch)
tree1a78a13b40915283eb9580dd09dd8306d4dd0e18 /games-emulation/nestopia
parentgames-emulation/nestopia: update metadata.xml remote-id (diff)
downloadgentoo-30b84d03e116543ed1df04a5e1165cc7ab8f0dd9.tar.gz
gentoo-30b84d03e116543ed1df04a5e1165cc7ab8f0dd9.tar.bz2
gentoo-30b84d03e116543ed1df04a5e1165cc7ab8f0dd9.zip
games-emulation/nestopia: add 1.51.1
This version switches from GTK to FLTK, removes the switch for optional gui and the support for libao/jack (most USE are gone). Dropped [video] from libsdl2, it's only used for input+audio and fltk[opengl] handles the display. Closes: https://bugs.gentoo.org/832960 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/nestopia')
-rw-r--r--games-emulation/nestopia/Manifest1
-rw-r--r--games-emulation/nestopia/nestopia-1.51.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-emulation/nestopia/Manifest b/games-emulation/nestopia/Manifest
index a891a84a0cce..38f8e069f410 100644
--- a/games-emulation/nestopia/Manifest
+++ b/games-emulation/nestopia/Manifest
@@ -1 +1,2 @@
DIST nestopia-1.50.tar.gz 1529804 BLAKE2B ef2fdf6ffb6ff9bb5f222730869d6deadb892c0a3996e97750afee692ec1d3b997e2bfe353a4fe26b9771781f659de83dda5e4676e221f4b9beaa512d6873ca4 SHA512 6ea389d4891c7cfa36517495735ea0f34ba9427e51757113d0fe2b72d5ce5b11d7e6b7c02fd1e4e347a13bba06823e334800ff15036872e09b8561c10c7cb568
+DIST nestopia-1.51.1.tar.gz 1578970 BLAKE2B 5db7a380239c207843d5edadf5a174059d4566cd7b68aca01515db4940be3a6f6d02421f1499df28d4ac026ec435650452eb43306d1e49487063a06bce16b961 SHA512 68da5e9ab7b848d895a8893a18ef50d90758258fbf7f86ca5df0fe95e74bad761aa436dca79b402439a12fd4dd1430b22e45ee202168be3f9f751190a7ae6131
diff --git a/games-emulation/nestopia/nestopia-1.51.1.ebuild b/games-emulation/nestopia/nestopia-1.51.1.ebuild
new file mode 100644
index 000000000000..c6bdbe0d6fb8
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.51.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/0ldsk00l/nestopia.git"
+else
+ SRC_URI="https://github.com/0ldsk00l/nestopia/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ app-arch/libarchive:=
+ media-libs/libglvnd
+ media-libs/libsdl2[joystick,sound]
+ sys-libs/zlib:=
+ x11-libs/fltk:1[opengl]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}