summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-02-09 20:15:54 +0100
committerDavid Seifert <soap@gentoo.org>2022-02-09 20:15:54 +0100
commit7756de4318427c9b5810f62730b1bef9f87ea9e4 (patch)
tree7c832ae1a8521e259387b697367784e4cc93a1fe /games-emulation
parentnet-libs/webkit-gtk: Version bump to 2.34.5 (diff)
downloadgentoo-7756de4318427c9b5810f62730b1bef9f87ea9e4.tar.gz
gentoo-7756de4318427c9b5810f62730b1bef9f87ea9e4.tar.bz2
gentoo-7756de4318427c9b5810f62730b1bef9f87ea9e4.zip
games-emulation/nestopia: silence -Wc++11-narrowing on clang
Closes: https://bugs.gentoo.org/830469 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestopia/nestopia-1.51.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-emulation/nestopia/nestopia-1.51.1.ebuild b/games-emulation/nestopia/nestopia-1.51.1.ebuild
index c6bdbe0d6fb8..ebab0b9b149b 100644
--- a/games-emulation/nestopia/nestopia-1.51.1.ebuild
+++ b/games-emulation/nestopia/nestopia-1.51.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools xdg
+inherit autotools flag-o-matic xdg
DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"
@@ -38,5 +38,8 @@ src_prepare() {
}
src_configure() {
+ # silence the narrowing warnings on clang (#830469)
+ append-cxxflags -Wno-narrowing
+
econf $(use_enable doc)
}