summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-06 10:45:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-06 10:47:40 -0400
commitef95b8d7d6e3f6bd16348d4f2fc31a083859fb87 (patch)
tree3b47b559bfa74f573650cc7d24bd45ca8c7fb48d /games-emulation
parentapp-misc/fastfetch: drop 2.11.3 (diff)
downloadgentoo-ef95b8d7d6e3f6bd16348d4f2fc31a083859fb87.tar.gz
gentoo-ef95b8d7d6e3f6bd16348d4f2fc31a083859fb87.tar.bz2
gentoo-ef95b8d7d6e3f6bd16348d4f2fc31a083859fb87.zip
games-emulation/mgba: fix bundled rapidjson with gcc14
(only used with USE=discord) Closes: https://bugs.gentoo.org/924019 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mgba/files/mgba-0.10.3-rapidjson-gcc14-const.patch17
-rw-r--r--games-emulation/mgba/mgba-0.10.3.ebuild1
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild1
3 files changed, 19 insertions, 0 deletions
diff --git a/games-emulation/mgba/files/mgba-0.10.3-rapidjson-gcc14-const.patch b/games-emulation/mgba/files/mgba-0.10.3-rapidjson-gcc14-const.patch
new file mode 100644
index 000000000000..516c81199bda
--- /dev/null
+++ b/games-emulation/mgba/files/mgba-0.10.3-rapidjson-gcc14-const.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/924019
+(same as https://bugs.gentoo.org/914583 given rapidjson is bundled)
+
+https://github.com/Tencent/rapidjson/issues/718
+https://github.com/Tencent/rapidjson/commit/3b2441b87f99ab65f37b141a7b548ebadb607b96
+From: Janusz Chorko <janusz.chorko@apdu.pl>
+Date: Fri, 26 Aug 2016 21:17:38 +0200
+Subject: [PATCH] Removed non-compiling assignment operator. Fixed #718
+--- a/src/third-party/discord-rpc/include/rapidjson/document.h
++++ b/src/third-party/discord-rpc/include/rapidjson/document.h
+@@ -317,6 +317,4 @@
+ GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
+
+- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
+-
+ //! implicit conversion to plain CharType pointer
+ operator const Ch *() const { return s; }
diff --git a/games-emulation/mgba/mgba-0.10.3.ebuild b/games-emulation/mgba/mgba-0.10.3.ebuild
index 1ae84af200cd..0e746e84b175 100644
--- a/games-emulation/mgba/mgba-0.10.3.ebuild
+++ b/games-emulation/mgba/mgba-0.10.3.ebuild
@@ -60,6 +60,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.10.0-optional-updater.patch
+ "${FILESDIR}"/${PN}-0.10.3-rapidjson-gcc14-const.patch
)
pkg_setup() {
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index d4ce0e18832b..97441a1c618f 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -63,6 +63,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.10.0-optional-updater.patch
+ "${FILESDIR}"/${PN}-0.10.3-rapidjson-gcc14-const.patch
)
pkg_setup() {