summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/odamex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/odamex')
-rw-r--r--games-engines/odamex/Manifest2
-rw-r--r--games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch79
-rw-r--r--games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch89
-rw-r--r--games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch77
-rw-r--r--games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch110
-rw-r--r--games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch59
-rw-r--r--games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch67
-rw-r--r--games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch51
-rw-r--r--games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch58
-rw-r--r--games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch35
-rw-r--r--games-engines/odamex/metadata.xml32
-rw-r--r--games-engines/odamex/odamex-0.6.4.ebuild103
-rw-r--r--games-engines/odamex/odamex-0.7.0.ebuild116
13 files changed, 878 insertions, 0 deletions
diff --git a/games-engines/odamex/Manifest b/games-engines/odamex/Manifest
new file mode 100644
index 000000000000..4bca1797b131
--- /dev/null
+++ b/games-engines/odamex/Manifest
@@ -0,0 +1,2 @@
+DIST odamex-src-0.6.4.tar.bz2 8449818 SHA256 7832fed1e0cca992c746fd0f7e876b090c0f244f2d1d5230ffa3df8b33ce0f6a SHA512 0a917568cfc4bd4d9921cb82185cbbc318bce493bc66e489093e45401ec4c7596148778648e5078f13c50824470a040a995aa50c7956e2446c90920254c8129f WHIRLPOOL 9d95a9422ab382ccd5f4fc7d89f0558e30c604e18a33eec3bb074ae446258f030ec67d4738e1c517d89c9a4e09aea6e3a84651d7c8b1df9a88a26077c1b319b4
+DIST odamex-src-0.7.0.tar.bz2 8435860 SHA256 d0306ddca3d5534672e6f0c547092d8f3f6f815686e4f6b21d6521afae1fd73b SHA512 410f3c2588e4d57006e5bb50eaa0f6c1a83cf197ce40daabb958667483eb6c85138206ac74b8aee64c4208c4360415ad16d1698534be5c7abec1493a0f91aa8b WHIRLPOOL 91ca8f658435f4503df8a2d5f52b1ef1cf34229373c4e1c3918b7eb919ae54e3a416618ce184d54c6ebc25bdfe6fea96f8933f98d859562b4972f89bd5c320ff
diff --git a/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch b/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch
new file mode 100644
index 000000000000..48205033d621
--- /dev/null
+++ b/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch
@@ -0,0 +1,79 @@
+commit 04fff802ee72c08d2e1730c6c5506fc2e708d5fe
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:34:29 2013 +0200
+
+ BUILD: add unix install rules
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b77096a..f49a1e8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,6 +2,8 @@
+ project(Odamex)
+ cmake_minimum_required(VERSION 2.8)
+
++# cmake modules
++include( GNUInstallDirs )
+ set(PROJECT_VERSION 0.6.4)
+ set(PROJECT_COPYRIGHT "2006-2013")
+
+@@ -64,3 +66,8 @@ add_subdirectory(odalaunch)
+ if(NOT NO_AG-ODALAUNCH_TARGET)
+ add_subdirectory(ag-odalaunch)
+ endif()
++
++# global install rules
++if(UNIX)
++ install(FILES odamex.wad DESTINATION ${CMAKE_INSTALL_DATADIR})
++endif()
+diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
+index 5dd5d43..1fde0ff 100644
+--- a/client/CMakeLists.txt
++++ b/client/CMakeLists.txt
+@@ -168,5 +168,8 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
+ " )
+ endif()
+
++ # UNIX install rules
++ elseif(UNIX)
++ install( TARGETS odamex DESTINATION ${CMAKE_INSTALL_BINDIR} )
+ endif()
+ endif()
+diff --git a/master/CMakeLists.txt b/master/CMakeLists.txt
+index c1c3853..3e94b34 100644
+--- a/master/CMakeLists.txt
++++ b/master/CMakeLists.txt
+@@ -12,3 +12,8 @@ if(WIN32)
+ elseif(SOLARIS)
+ target_link_libraries(odamast socket nsl)
+ endif()
++
++# install rules
++if(UNIX)
++ install( TARGETS odamast DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
+diff --git a/odalaunch/CMakeLists.txt b/odalaunch/CMakeLists.txt
+index ff9b6e3..d2d2171 100644
+--- a/odalaunch/CMakeLists.txt
++++ b/odalaunch/CMakeLists.txt
+@@ -61,3 +61,8 @@ if(wxWidgets_FOUND)
+ )
+ endif()
+ endif()
++
++# install rules
++if(UNIX)
++ install( TARGETS odalaunch DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
+diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
+index 2284a8a..a079434 100644
+--- a/server/CMakeLists.txt
++++ b/server/CMakeLists.txt
+@@ -61,3 +61,7 @@ if(UNIX AND NOT APPLE)
+ target_link_libraries(odasrv rt)
+ endif()
+
++# install rules
++if(UNIX)
++ install( TARGETS odasrv DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
diff --git a/games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch b/games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch
new file mode 100644
index 000000000000..618f9fd87c2c
--- /dev/null
+++ b/games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch
@@ -0,0 +1,89 @@
+From 1352b633388dd9d82b8cb7e3d11932d0b569da4e Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Thu, 27 Mar 2014 21:07:37 +0100
+Subject: [PATCH 1/4] make install destinations modifiable
+
+---
+ CMakeLists.txt | 5 +++--
+ client/CMakeLists.txt | 2 +-
+ master/CMakeLists.txt | 4 ++++
+ odalaunch/CMakeLists.txt | 2 +-
+ server/CMakeLists.txt | 2 +-
+ 5 files changed, 10 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 11e52d1..262e3db 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ include(CMakeDependentOption)
++include(GNUInstallDirs)
+
+ project(Odamex)
+ cmake_minimum_required(VERSION 2.8)
+@@ -113,10 +114,10 @@ if(NOT APPLE)
+ set(CPACK_INCLUDE_TOPLEVEL_DIRECTORY OFF)
+ else()
+ install(FILES odamex.wad LICENSE README
+- DESTINATION share/odamex
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex
+ COMPONENT common)
+ install(FILES ${CONFIG_SAMPLES}
+- DESTINATION share/odamex/config-samples
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex/config-samples
+ COMPONENT common)
+
+ option(ODAMEX_COMPONENT_PACKAGES "Create several rpm/deb packages for repository maintainers." OFF)
+diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
+index 510b820..3f73ab5 100644
+--- a/client/CMakeLists.txt
++++ b/client/CMakeLists.txt
+@@ -228,7 +228,7 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
+ COMPONENT client)
+ else()
+ install(TARGETS odamex
+- RUNTIME DESTINATION bin
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ COMPONENT client)
+ endif()
+ endif()
+diff --git a/master/CMakeLists.txt b/master/CMakeLists.txt
+index 7fc386b..5bdc048 100644
+--- a/master/CMakeLists.txt
++++ b/master/CMakeLists.txt
+@@ -14,3 +14,7 @@ if(WIN32)
+ elseif(SOLARIS)
+ target_link_libraries(odamast socket nsl)
+ endif()
++
++if(UNIX)
++ install( TARGETS odamast DESTINATION ${CMAKE_INSTALL_BINDIR} )
++endif()
+diff --git a/odalaunch/CMakeLists.txt b/odalaunch/CMakeLists.txt
+index 4ca5920..0b134ef 100644
+--- a/odalaunch/CMakeLists.txt
++++ b/odalaunch/CMakeLists.txt
+@@ -71,7 +71,7 @@ if(wxWidgets_FOUND)
+ COMPONENT odalaunch)
+ else()
+ install(TARGETS odalaunch
+- RUNTIME DESTINATION bin
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ COMPONENT odalaunch)
+ endif()
+
+diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
+index b046714..d33b974 100644
+--- a/server/CMakeLists.txt
++++ b/server/CMakeLists.txt
+@@ -73,6 +73,6 @@ elseif(WIN32)
+ COMPONENT server)
+ else()
+ install(TARGETS odasrv
+- RUNTIME DESTINATION bin
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ COMPONENT server)
+ endif()
+--
+1.9.1
+
diff --git a/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch b/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch
new file mode 100644
index 000000000000..de0f0784ca97
--- /dev/null
+++ b/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch
@@ -0,0 +1,77 @@
+commit 7abf37ed186701f0170bded26df8cbb8a99a21e1
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:35:46 2013 +0200
+
+ BUILD: add various cmake options
+
+ to control building client/server/odalaunch
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f49a1e8..ca01bba 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,7 +3,15 @@ project(Odamex)
+ cmake_minimum_required(VERSION 2.8)
+
+ # cmake modules
++include( CMakeDependentOption )
+ include( GNUInstallDirs )
++
++# options
++option(BUILD_CLIENT "Build client target" 1)
++option(BUILD_SERVER "Build server target" 1)
++option(BUILD_MASTER "Build master server target" 1)
++cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
++cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
+ set(PROJECT_VERSION 0.6.4)
+ set(PROJECT_COPYRIGHT "2006-2013")
+
+@@ -56,10 +64,22 @@ endmacro(define_platform)
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
+
+ # Subdirectories for individual projects
+-add_subdirectory(client)
+-add_subdirectory(server)
+-add_subdirectory(master)
+-add_subdirectory(odalaunch)
++if(BUILD_CLIENT)
++ add_subdirectory(client)
++endif()
++if(BUILD_SERVER)
++ add_subdirectory(server)
++endif()
++if(BUILD_MASTER)
++ add_subdirectory(master)
++endif()
++if(BUILD_ODALAUNCH)
++ add_subdirectory(odalaunch)
++endif()
++
++if(NOT BUILD_CLIENT AND NOT BUILD_SERVER AND NOT BUILD_MASTER)
++ message(FATAL_ERROR "No target chosen, doing nothing.")
++endif()
+
+ # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
+ # This is only really useful when setting up a universal build.
+diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
+index 1fde0ff..9f06fa6 100644
+--- a/client/CMakeLists.txt
++++ b/client/CMakeLists.txt
+@@ -48,7 +48,7 @@ endif()
+
+ # PortMidi configuration
+ find_package(PortMidi)
+-if(PORTMIDI_FOUND)
++if(PORTMIDI_FOUND AND ENABLE_PORTMIDI)
+ include_directories(${PORTMIDI_INCLUDE_DIR})
+ add_definitions(-DPORTMIDI)
+ else()
+@@ -95,7 +95,7 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
+ target_link_libraries(odamex ${SDL_LIBRARY})
+ target_link_libraries(odamex ${SDLMIXER_LIBRARY})
+
+- if(PORTMIDI_FOUND)
++ if(PORTMIDI_FOUND AND ENABLE_PORTMIDI)
+ target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
+ endif()
+
diff --git a/games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch b/games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch
new file mode 100644
index 000000000000..1de502711406
--- /dev/null
+++ b/games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch
@@ -0,0 +1,110 @@
+From 851bc58a74eadd89838c924167f27df1b9d3be37 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Thu, 27 Mar 2014 21:14:20 +0100
+Subject: [PATCH 2/4] add various cmake options
+
+---
+ CMakeLists.txt | 26 ++++++++++++++++++++++----
+ client/CMakeLists.txt | 34 ++++++++++++++++++++--------------
+ 2 files changed, 42 insertions(+), 18 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 262e3db..91d5c50 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,6 +1,13 @@
+ include(CMakeDependentOption)
+ include(GNUInstallDirs)
+
++# options
++option(BUILD_CLIENT "Build client target" 1)
++option(BUILD_SERVER "Build server target" 1)
++option(BUILD_MASTER "Build master server target" 1)
++cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
++cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
++
+ project(Odamex)
+ cmake_minimum_required(VERSION 2.8)
+
+@@ -73,10 +80,21 @@ if(USE_INTREE_PORTMIDI)
+ endif()
+
+ # Subdirectories for Odamex projects
+-add_subdirectory(client)
+-add_subdirectory(server)
+-add_subdirectory(master)
+-add_subdirectory(odalaunch)
++if(BUILD_CLIENT)
++ add_subdirectory(client)
++endif()
++if(BUILD_SERVER)
++ add_subdirectory(server)
++endif()
++if(BUILD_MASTER)
++ add_subdirectory(master)
++endif()
++if(BUILD_ODALAUNCH)
++ add_subdirectory(odalaunch)
++endif()
++if(NOT BUILD_CLIENT AND NOT BUILD_SERVER AND NOT BUILD_MASTER)
++ message(FATAL_ERROR "No target chosen, doing nothing.")
++endif()
+
+ # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
+ # This is only really useful when setting up a universal build.
+diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
+index 3f73ab5..7363c5a 100644
+--- a/client/CMakeLists.txt
++++ b/client/CMakeLists.txt
+@@ -107,17 +107,21 @@ include_directories(${PNG_INCLUDE_DIRS})
+ add_definitions(-DUSE_PNG)
+
+ # PortMidi configuration
+-if(USE_INTREE_PORTMIDI)
+- include_directories(../libraries/portmidi/pm_common/ ../libraries/portmidi/porttime/)
+- add_definitions(-DPORTMIDI)
++if(ENABLE_PORTMIDI)
++ if(USE_INTREE_PORTMIDI)
++ include_directories(../libraries/portmidi/pm_common/ ../libraries/portmidi/porttime/)
++ add_definitions(-DPORTMIDI)
++ else()
++ find_package(PortMidi QUIET)
++ if(PORTMIDI_FOUND)
++ include_directories(${PORTMIDI_INCLUDE_DIR})
++ add_definitions(-DPORTMIDI)
++ else()
++ message(WARNING "PortMidi not found, client will be built without PortMidi support.")
++ endif()
++ endif()
+ else()
+- find_package(PortMidi QUIET)
+- if(PORTMIDI_FOUND)
+- include_directories(${PORTMIDI_INCLUDE_DIR})
+- add_definitions(-DPORTMIDI)
+- else()
+- message(WARNING "PortMidi not found, client will be built without PortMidi support.")
+- endif()
++ message(STATUS "Portmidi disabled.")
+ endif()
+
+ # Find Mac frameworks
+@@ -147,10 +151,12 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
+ target_link_libraries(odamex ${ZLIB_LIBRARY})
+ target_link_libraries(odamex ${PNG_LIBRARY} ${ZLIB_LIBRARY})
+
+- if(USE_INTREE_PORTMIDI)
+- target_link_libraries(odamex portmidi-static)
+- elseif(PORTMIDI_FOUND)
+- target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
++ if(ENABLE_PORTMIDI)
++ if(USE_INTREE_PORTMIDI)
++ target_link_libraries(odamex portmidi-static)
++ elseif(PORTMIDI_FOUND)
++ target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
++ endif()
+ endif()
+
+ if(WIN32)
+--
+1.9.1
+
diff --git a/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch b/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch
new file mode 100644
index 000000000000..3eb6953cfe85
--- /dev/null
+++ b/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch
@@ -0,0 +1,59 @@
+commit 3a5209e2595e459a31c111f6040dbac347df1967
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:38:10 2013 +0200
+
+ add odamex.wad install destination to wad search path
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ca01bba..83a0e30 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,6 +12,16 @@ option(BUILD_SERVER "Build server target" 1)
+ option(BUILD_MASTER "Build master server target" 1)
+ cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
+ cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
++
++configure_file (
++ "${PROJECT_SOURCE_DIR}/config.h.in"
++ "${PROJECT_BINARY_DIR}/config.h"
++ )
++
++include_directories(
++ ${PROJECT_BINARY_DIR}
++)
++
+ set(PROJECT_VERSION 0.6.4)
+ set(PROJECT_COPYRIGHT "2006-2013")
+
+diff --git a/common/d_main.cpp b/common/d_main.cpp
+index 010bdcb..6dc2e5f 100644
+--- a/common/d_main.cpp
++++ b/common/d_main.cpp
+@@ -23,6 +23,7 @@
+ //-----------------------------------------------------------------------------
+
+ #include "version.h"
++#include "config.h"
+
+ #include <sstream>
+ #include <string>
+@@ -493,6 +494,7 @@ static std::string BaseFileSearch(std::string file, std::string ext = "", std::s
+ D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
+ D_AddSearchDir(dirs, getenv("HOME"), separator);
++ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
+
+ // [AM] Search additional paths based on platform
+ D_AddPlatformSearchDirs(dirs);
+diff --git a/config.h.in b/config.h.in
+new file mode 100644
+index 0000000..e91b3a6
+--- /dev/null
++++ b/config.h.in
+@@ -0,0 +1,6 @@
++#ifndef CONFIG_H
++#define CONFIG_H
++
++#define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
++
++#endif
diff --git a/games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch b/games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch
new file mode 100644
index 000000000000..77fb4e48996e
--- /dev/null
+++ b/games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch
@@ -0,0 +1,67 @@
+From 9af4e992ff9fa10816beba36478c711ac2c8542a Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Thu, 27 Mar 2014 21:17:21 +0100
+Subject: [PATCH 3/4] add odamex.wad install destination to wad search path
+
+---
+ CMakeLists.txt | 9 +++++++++
+ common/d_main.cpp | 2 ++
+ config.h.in | 6 ++++++
+ 3 files changed, 17 insertions(+)
+ create mode 100644 config.h.in
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 91d5c50..a06613e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,6 +13,15 @@
+
+ set(PROJECT_VERSION 0.7.0)
+ set(PROJECT_COPYRIGHT "2006-2014")
++
++configure_file (
++ "${PROJECT_SOURCE_DIR}/config.h.in"
++ "${PROJECT_BINARY_DIR}/config.h"
++ )
++
++include_directories(
++ ${PROJECT_BINARY_DIR}
++)
+
+ # Default build type
+ if(NOT MSVC)
+diff --git a/common/d_main.cpp b/common/d_main.cpp
+index 31d4f59..be0ffd2 100644
+--- a/common/d_main.cpp
++++ b/common/d_main.cpp
+@@ -23,6 +23,7 @@
+ //-----------------------------------------------------------------------------
+
+ #include "version.h"
++#include "config.h"
+
+ #include <sstream>
+ #include <string>
+@@ -506,6 +507,7 @@ static std::string BaseFileSearch(std::string file, std::string ext = "", std::s
+ D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+ D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
+ D_AddSearchDir(dirs, getenv("HOME"), separator);
++ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
+
+ // [AM] Search additional paths based on platform
+ D_AddPlatformSearchDirs(dirs);
+diff --git a/config.h.in b/config.h.in
+new file mode 100644
+index 0000000..e91b3a6
+--- /dev/null
++++ b/config.h.in
+@@ -0,0 +1,6 @@
++#ifndef CONFIG_H
++#define CONFIG_H
++
++#define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
++
++#endif
+--
+1.9.1
+
diff --git a/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch b/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch
new file mode 100644
index 000000000000..22244987d458
--- /dev/null
+++ b/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch
@@ -0,0 +1,51 @@
+commit a6c55c51dc251924be7eccf6637fc719a2b7ace0
+Author: hasufell <hasufell@gentoo.org>
+Date: Wed Jul 31 03:38:24 2013 +0200
+
+ use CMAKE_BINDIR as default bin patch in odalauncher
+
+diff --git a/config.h.in b/config.h.in
+index e91b3a6..7019a02 100644
+--- a/config.h.in
++++ b/config.h.in
+@@ -2,5 +2,6 @@
+ #define CONFIG_H
+
+ #define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
++#define CMAKE_BINDIR "@CMAKE_INSTALL_BINDIR@"
+
+ #endif
+diff --git a/odalaunch/src/dlg_main.cpp b/odalaunch/src/dlg_main.cpp
+index 915b527..f01224a 100644
+--- a/odalaunch/src/dlg_main.cpp
++++ b/odalaunch/src/dlg_main.cpp
+@@ -27,6 +27,7 @@
+ #include "str_utils.h"
+
+ #include "md5.h"
++#include "config.h"
+
+ #include <wx/settings.h>
+ #include <wx/menu.h>
+@@ -42,6 +43,7 @@
+ #include <wx/process.h>
+ #include <wx/toolbar.h>
+ #include <wx/xrc/xmlres.h>
++#include <wx/string.h>
+ #include <wx/cmdline.h>
+
+ #ifdef __WXMSW__
+@@ -200,10 +202,12 @@ dlgMain::dlgMain(wxWindow* parent, wxWindowID id)
+ }
+ #endif
+
++ const char *cmake_bindir_str = CMAKE_BINDIR;
++ wxString cmake_bindir = wxString::FromAscii(cmake_bindir_str);
+ launchercfg_s.get_list_on_start = 1;
+ launchercfg_s.show_blocked_servers = 0;
+ launchercfg_s.wad_paths = wxGetCwd();
+- launchercfg_s.odamex_directory = wxGetCwd();
++ launchercfg_s.odamex_directory = cmake_bindir;
+
+ m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
+ m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
diff --git a/games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch b/games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch
new file mode 100644
index 000000000000..acb2692e75fb
--- /dev/null
+++ b/games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch
@@ -0,0 +1,58 @@
+From 672b2e61f3c0347c29746a4a22fe3ab912e88d62 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Thu, 27 Mar 2014 21:19:48 +0100
+Subject: [PATCH 4/4] use CMAKE_BINDIR as default bin patch in odalauncher
+
+---
+ config.h.in | 1 +
+ odalaunch/src/dlg_main.cpp | 6 +++++-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/config.h.in b/config.h.in
+index e91b3a6..7019a02 100644
+--- a/config.h.in
++++ b/config.h.in
+@@ -2,5 +2,6 @@
+ #define CONFIG_H
+
+ #define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
++#define CMAKE_BINDIR "@CMAKE_INSTALL_BINDIR@"
+
+ #endif
+diff --git a/odalaunch/src/dlg_main.cpp b/odalaunch/src/dlg_main.cpp
+index a95a5f6..abbfc0a 100644
+--- a/odalaunch/src/dlg_main.cpp
++++ b/odalaunch/src/dlg_main.cpp
+@@ -27,6 +27,7 @@
+ #include "str_utils.h"
+
+ #include "md5.h"
++#include "config.h"
+
+ #include <wx/settings.h>
+ #include <wx/menu.h>
+@@ -42,6 +43,7 @@
+ #include <wx/process.h>
+ #include <wx/toolbar.h>
+ #include <wx/xrc/xmlres.h>
++#include <wx/string.h>
+ #include <wx/cmdline.h>
+
+ #ifdef __WXMSW__
+@@ -205,10 +207,12 @@ dlgMain::dlgMain(wxWindow* parent, wxWindowID id)
+ }
+ #endif
+
++ const char *cmake_bindir_str = CMAKE_BINDIR;
++ wxString cmake_bindir = wxString::FromAscii(cmake_bindir_str);
+ launchercfg_s.get_list_on_start = 1;
+ launchercfg_s.show_blocked_servers = 0;
+ launchercfg_s.wad_paths = wxGetCwd();
+- launchercfg_s.odamex_directory = wxGetCwd();
++ launchercfg_s.odamex_directory = cmake_bindir;
+
+ m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
+ m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
+--
+1.9.1
+
diff --git a/games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch b/games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch
new file mode 100644
index 000000000000..34896e2a4e8b
--- /dev/null
+++ b/games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch
@@ -0,0 +1,35 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Mar 27 21:16:02 UTC 2014
+Subject: unbundle miniupnpc
+
+--- a/server/CMakeLists.txt
++++ b/server/CMakeLists.txt
+@@ -29,8 +29,7 @@
+ set(JSONCPP_SOURCE ${JSONCPP_DIR}/jsoncpp.cpp)
+
+ # MiniUPnPc
+-set(MINIUPNPC_DIR ../libraries/libminiupnpc)
+-set(MINIUPNPC_STATIC_LIBRARIES upnpc-static)
++set(MINIUPNPC_DIR /usr/include/miniupnpc)
+
+ # Platform definitions
+ define_platform()
+@@ -54,7 +53,7 @@
+ ${COMMON_SOURCES} ${COMMON_HEADERS}
+ ${SERVER_SOURCES} ${SERVER_HEADERS}
+ ${SERVER_WIN32_HEADERS} ${SERVER_WIN32_RESOURCES})
+-target_link_libraries(odasrv ${MINIUPNPC_STATIC_LIBRARIES})
++target_link_libraries(odasrv -lminiupnpc)
+
+ if(WIN32)
+ target_link_libraries(odasrv winmm wsock32)
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,7 +71,6 @@
+ set(UPNPC_BUILD_TESTS OFF CACHE INTERNAL "" FORCE)
+ set(UPNPC_INSTALL OFF CACHE INTERNAL "" FORCE)
+ mark_as_advanced(FORCE UPNPC_INSTALL)
+-add_subdirectory(libraries/libminiupnpc)
+
+ # PortMidi
+ cmake_dependent_option(USE_INTREE_PORTMIDI "Compile with the version of PortMidi included in the source tree." ON "WIN32" OFF)
diff --git a/games-engines/odamex/metadata.xml b/games-engines/odamex/metadata.xml
new file mode 100644
index 000000000000..2f40288d1525
--- /dev/null
+++ b/games-engines/odamex/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>mwoodj@knology.net</email>
+ <name>Mike Wood</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <use>
+ <flag name="odalaunch">Build the wxwidgets based launcher.</flag>
+ <flag name="master">Build master server target (advertises odamex server list)</flag>
+ <flag name="portmidi">Enable portmidi support.</flag>
+ <flag name="server">Build server target.</flag>
+ </use>
+ <upstream>
+ <changelog>http://odamex.net/changelog.php</changelog>
+ <doc lang="en">http://odamex.net/wiki/Odamex</doc>
+ <bugs-to>http://odamex.net/bugs/</bugs-to>
+ <remote-id type="sourceforge">odamex</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Odamex is a free and open source port for the classic
+ first-person-shooter Doom. Odamex's goal is to emulate the feel of and
+ retain many aspects of the original Doom executables while offering a
+ broader expanse of security features, personal configuration, gameplay
+ options, and editing features. Odamex can run on a wide range of
+ operating systems and hardware, so players should be able to play
+ on almost any platform.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-engines/odamex/odamex-0.6.4.ebuild b/games-engines/odamex/odamex-0.6.4.ebuild
new file mode 100644
index 000000000000..f2e15ed1199f
--- /dev/null
+++ b/games-engines/odamex/odamex-0.6.4.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="2.8"
+inherit cmake-utils eutils gnome2-utils wxwidgets games
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="An online multiplayer, free software engine for Doom and Doom II"
+HOMEPAGE="http://odamex.net/"
+SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dedicated +odalaunch master portmidi server"
+
+RDEPEND="
+ dedicated? ( >=net-libs/miniupnpc-1.8 )
+ !dedicated? (
+ >=media-libs/libsdl-1.2.9[X,sound,joystick,video]
+ >=media-libs/sdl-mixer-1.2.6
+ odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ portmidi? ( media-libs/portmidi )
+ server? ( >=net-libs/miniupnpc-1.8 )
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1-${P}-install-rules.patch \
+ "${FILESDIR}"/2-${P}-cmake-options.patch \
+ "${FILESDIR}"/3-${P}-wad-search-path.patch \
+ "${FILESDIR}"/4-${P}-odalauncher-bin-path.patch
+
+ epatch_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_BINDIR="${GAMES_BINDIR}"
+ -DCMAKE_INSTALL_DATADIR="${GAMES_DATADIR}"/${PN}
+ $(cmake-utils_use_build master MASTER)
+ )
+
+ if use dedicated ; then
+ mycmakeargs+=(
+ -DBUILD_CLIENT=OFF
+ -DBUILD_ODALAUNCH=OFF
+ -DBUILD_SERVER=ON
+ -DENABLE_PORTMIDI=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DBUILD_CLIENT=ON
+ $(cmake-utils_use_build odalaunch ODALAUNCH)
+ $(cmake-utils_use_build server SERVER)
+ $(cmake-utils_use_enable portmidi PORTMIDI)
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if ! use dedicated ; then
+ newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
+ make_desktop_entry ${PN}
+
+ if use odalaunch ; then
+ newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
+ make_desktop_entry odalaunch "Odamex Launcher" odalaunch
+ fi
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ elog "This is just the engine, you will need doom resource files in order to play."
+ elog "Check: http://odamex.net/wiki/FAQ#What_data_files_are_required.3F"
+ einfo
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-engines/odamex/odamex-0.7.0.ebuild b/games-engines/odamex/odamex-0.7.0.ebuild
new file mode 100644
index 000000000000..48999b4b82db
--- /dev/null
+++ b/games-engines/odamex/odamex-0.7.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit cmake-utils eutils gnome2-utils wxwidgets games
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="An online multiplayer, free software engine for Doom and Doom II"
+HOMEPAGE="http://odamex.net/"
+SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated +odalaunch master portmidi server"
+
+RDEPEND="
+ dedicated? ( >=net-libs/miniupnpc-1.8 )
+ !dedicated? (
+ media-libs/libpng:0
+ >=media-libs/libsdl-1.2.9[X,sound,joystick,video]
+ >=media-libs/sdl-mixer-1.2.6
+ odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ portmidi? ( media-libs/portmidi )
+ server? ( >=net-libs/miniupnpc-1.8 )
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/src-${PV:2:3}
+
+pkg_pretend() {
+ if ! test-flag-CXX -std=c++11; then
+ die "You need at least GCC 4.7.x or Clang >= 3.0 for C++11-specific compiler flags"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1-${P}-install-rules.patch \
+ "${FILESDIR}"/2-${P}-cmake-options.patch \
+ "${FILESDIR}"/3-${P}-wad-search-path.patch \
+ "${FILESDIR}"/4-${P}-odalauncher-bin-path.patch \
+ "${FILESDIR}"/${P}-miniupnpc.patch
+
+ rm -r libraries/libminiupnpc || die
+
+ epatch_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_INTREE_PORTMIDI=OFF
+ -DCMAKE_INSTALL_BINDIR="${GAMES_BINDIR}"
+ -DCMAKE_INSTALL_DATADIR="${GAMES_DATADIR}"
+ $(cmake-utils_use_build master MASTER)
+ )
+
+ if use dedicated ; then
+ mycmakeargs+=(
+ -DBUILD_CLIENT=OFF
+ -DBUILD_ODALAUNCH=OFF
+ -DBUILD_SERVER=ON
+ -DENABLE_PORTMIDI=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DBUILD_CLIENT=ON
+ $(cmake-utils_use_build odalaunch ODALAUNCH)
+ $(cmake-utils_use_build server SERVER)
+ $(cmake-utils_use_enable portmidi PORTMIDI)
+ )
+ fi
+
+ append-cxxflags -std=c++11
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if ! use dedicated ; then
+ newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
+ make_desktop_entry ${PN}
+
+ if use odalaunch ; then
+ newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
+ make_desktop_entry odalaunch "Odamex Launcher" odalaunch
+ fi
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ elog "This is just the engine, you will need doom resource files in order to play."
+ elog "Check: http://odamex.net/wiki/FAQ#What_data_files_are_required.3F"
+ einfo
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}