summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-02-14 04:02:14 +0100
committerSam James <sam@gentoo.org>2024-02-25 06:59:12 +0000
commitebe5efa2823055dd3f8a9c6155ca0b50f66889f6 (patch)
tree5ea091a21afb6334588709af6190e613f5be2a05 /games-engines
parentdev-python/pygame_sdl2: add 8.2.0 (diff)
downloadgentoo-ebe5efa2823055dd3f8a9c6155ca0b50f66889f6.tar.gz
gentoo-ebe5efa2823055dd3f8a9c6155ca0b50f66889f6.tar.bz2
gentoo-ebe5efa2823055dd3f8a9c6155ca0b50f66889f6.zip
games-engines/renpy: add 8.2.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/35316 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/renpy/Manifest1
-rw-r--r--games-engines/renpy/renpy-8.2.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/games-engines/renpy/Manifest b/games-engines/renpy/Manifest
index c68fa9f0242a..2772c7976985 100644
--- a/games-engines/renpy/Manifest
+++ b/games-engines/renpy/Manifest
@@ -1 +1,2 @@
DIST renpy-8.1.3-source.tar.bz2 69220231 BLAKE2B fe9295da7081dda77c2a720138cdd63b744d40844ce5a0bb4164720cf34f828cbf25ac77e1aa57e95585ad6eab644cd0fff2a3a818e6b86482e589a28f40affa SHA512 22304cf8e7328c50ff897761ec0a504e8618d53484491f4196ad93015656dd08c2197c11adea83069682912a5b8d05d3223e3ad34fa68881abdad5f73e51884b
+DIST renpy-8.2.0-source.tar.bz2 70209427 BLAKE2B b776dcfd0efe66f9d6ff06007cb8abb1b4ff6bc1a4dd7563a928e5396d52c9054398bca6333434e14d1e30ecf87ba68dbb7941facf7468702c800036d93db89d SHA512 a493baa6e1df0d8bbb8c8f0634bf82879dd82265db30100892d4a13267f75f7428c7da9ab565298aa2ab6a5ddf66743907835d5d0dabbf7fb9c35a652703f511
diff --git a/games-engines/renpy/renpy-8.2.0.ebuild b/games-engines/renpy/renpy-8.2.0.ebuild
new file mode 100644
index 000000000000..a793d5e9dd49
--- /dev/null
+++ b/games-engines/renpy/renpy-8.2.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop gnome2-utils distutils-r1
+
+DESCRIPTION="Visual novel engine written in python"
+HOMEPAGE="https://www.renpy.org"
+SRC_URI="https://www.renpy.org/dl/${PV}/${P}-source.tar.bz2"
+S="${WORKDIR}/${P}-source"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="development doc examples"
+REQUIRED_USE="examples? ( development )"
+
+BDEPEND="
+ $(python_gen_cond_dep '<dev-python/cython-3[${PYTHON_USEDEP}]')
+ virtual/pkgconfig"
+DEPEND="
+ dev-libs/fribidi
+ $(python_gen_cond_dep '
+ >=dev-python/pygame_sdl2-8.2.0[${PYTHON_USEDEP}]
+ >=dev-lang/python-exec-0.3[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ media-libs/glew:0
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/freetype:2
+ sys-libs/zlib
+ media-video/ffmpeg:=
+"
+RDEPEND="${DEPEND}
+ !app-eselect/eselect-renpy"
+
+PATCHES=(
+ "${FILESDIR}/renpy-6.99.12.4-compat-style.patch"
+ "${FILESDIR}/renpy-6.99.12.4-compat-infinite-loop.patch"
+ "${FILESDIR}/renpy-8.1.0-ignore_rpyc_errors.patch"
+ "${FILESDIR}/renpy-8.1.3-system-path.patch"
+)
+
+python_prepare_all() {
+ einfo "Deleting precompiled python files"
+ find . -name '*.py[co]' -print -delete || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ cd "${S}"/module || die
+ distutils-r1_python_compile
+}
+
+python_install() {
+ cd "${S}"/module || die
+ distutils-r1_python_install
+
+ cd "${S}" || die
+ python_newscript renpy.py ${PN}
+
+ python_domodule renpy
+ if use development ; then
+ python_domodule launcher
+ fi
+ if use examples ; then
+ python_domodule the_question tutorial
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use development; then
+ newicon -s 32 launcher/game/images/logo32.png ${P}.png
+ make_desktop_entry ${PN} "Ren'Py ${PV}" ${P}
+ fi
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}/html"
+ doins -r doc/*
+ fi
+ newman "${FILESDIR}/${PN}.1" "${P}.1"
+}
+
+pkg_preinst() {
+ use development && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use development && gnome2_icon_cache_update
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ ver_test "${v}" -ge 7 && continue
+ einfo "Starting from ${PN}-7 slots are dropped."
+ einfo "RenPy natively supports compatibility with games made for older versions."
+ einfo "Report bugs upstream on such problems, usually they are easy to fix."
+ break
+ done
+}
+
+pkg_postrm() {
+ use development && gnome2_icon_cache_update
+}