summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 11:10:29 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 11:12:08 +0200
commit1129c1b0976d08d55d5c8c9c0ac0aba50d40a1bc (patch)
treed2e93d1f4a004caf6c6e3d2c51654b1d2248be8f /games-util/lutris
parentsci-misc/jupyterlab-desktop-bin: drop 3.3.4.2 (diff)
downloadgentoo-1129c1b0976d08d55d5c8c9c0ac0aba50d40a1bc.tar.gz
gentoo-1129c1b0976d08d55d5c8c9c0ac0aba50d40a1bc.tar.bz2
gentoo-1129c1b0976d08d55d5c8c9c0ac0aba50d40a1bc.zip
games-util/lutris: add 0.5.11_beta1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.11_beta1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index d112f3cf9de7..aa95f78b05c0 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1 +1,2 @@
+DIST lutris-0.5.11_beta1.tar.gz 1118646 BLAKE2B 7d414c2084d1c2c714d102d98a7f2f1d6ef004b2175b8c5c023a8c455e5753910827ee33107250162ffc0b7e352a9ce2c2c37b1efd01caa14fb324808925878d SHA512 764e8a2c2c59d094708bff3c81acdaba09aa0d9d37c304acf7ddf0fa900db0e064b19dd38933ee62b7e7f6b792518968833a11078c24421db5b2c9b77e093fb6
DIST lutris_0.5.10.1.tar.xz 1230464 BLAKE2B 5ba913f5e37956344b59c47c1315cf277ce57b1b771279c8aa4243971ea9f0c5277ad19b18655731048e989f752d957216d055ac6c26bb8731e52b4345d30847 SHA512 f6443fa86d0b38e1b5ba51054e50776eea63d9adda5738a7e69f2fe6b196f99491894d5068d6cddfd35d1baafa4188bd1935598b84266e9e23bd1b58c16dde20
diff --git a/games-util/lutris/lutris-0.5.11_beta1.ebuild b/games-util/lutris/lutris-0.5.11_beta1.ebuild
new file mode 100644
index 000000000000..8808cea2f845
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.11_beta1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 optfeature virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_beta* ]] ; then
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/libnotify[introspection]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
+
+python_test() {
+ virtx epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}/usr/share/lutris/bin/lutris-wrapper" #740048
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "running windows games through wine+DXVK/proton or other Vulkan games (plus ICD for your hardware)" media-libs/vulkan-loader
+
+ # Quote README.rst
+ elog ""
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}