summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-10-26 01:20:57 +0300
committerMart Raudsepp <leio@gentoo.org>2017-10-26 01:21:10 +0300
commit200c8a0dd05ca290abd54f78403a34eae5a2ae47 (patch)
tree611f638a13c3f21455c694781b3e84fcc412a521 /gnome-base
parentsys-libs/glibc: stable 2.25-r8 for hppa, bug #628180 (thanks to Rolf Eike Beer) (diff)
downloadgentoo-200c8a0dd05ca290abd54f78403a34eae5a2ae47.tar.gz
gentoo-200c8a0dd05ca290abd54f78403a34eae5a2ae47.tar.bz2
gentoo-200c8a0dd05ca290abd54f78403a34eae5a2ae47.zip
gnome-base/dconf: bump to 0.26.1
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf/Manifest1
-rw-r--r--gnome-base/dconf/dconf-0.26.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
index 9e1f19b31077..807e38586594 100644
--- a/gnome-base/dconf/Manifest
+++ b/gnome-base/dconf/Manifest
@@ -1 +1,2 @@
DIST dconf-0.26.0.tar.xz 219688 SHA256 8683292eb31a3fae31e561f0a4220d8569b0f6d882e9958b68373f9043d658c9 SHA512 ea225397a486815c90a113c064d943f113490dfc754e4acba049b033115aa3a6a3849a5cdc133663de09811cde41c963041bc244cfd9ed32d65399889e415d1e WHIRLPOOL 5e4e24aa6083ad5a7a50041772bb7d466eb9cee93725311516fd6070a1b31b8db137772a3c55fa7cfca1675f72f9ab35b70d6aec1b67666eeedfbdfdebd9ac7a
+DIST dconf-0.26.1.tar.xz 218516 SHA256 d583b1f7fc93b879e2956acc6a26ea05a445a0002158aeef80c8e378e1414535 SHA512 4d2b4afce189e448e3bd4e9c2f9d3d5eec6c694748aec87a9a8de047296c858772a5234dbcace8e84d99c5378d2d1ba35cafb5e5ea7efca25c10a53a55b8b6da WHIRLPOOL a790df3c838e0d7e78b4bed6e547f8627348897c9d50c2990208afcc91855b8181b19cd318f48de6ed739bb367f04b84e7f5563fe9f6f2a91a7ed9cfe8db0e59
diff --git a/gnome-base/dconf/dconf-0.26.1.ebuild b/gnome-base/dconf/dconf-0.26.1.ebuild
new file mode 100644
index 000000000000..88dcc0547e96
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.26.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/action/show/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ sys-apps/dbus
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}