summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-03 11:02:49 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-05 13:29:06 -0500
commit14b81044f3d49fdea5621ccfb9fc788d863f65d0 (patch)
treef3d29b4366695e8119b02e084e43bcd587910b07 /gui-libs
parentgui-libs/amtk: Fix DEPEND (diff)
downloadgentoo-14b81044f3d49fdea5621ccfb9fc788d863f65d0.tar.gz
gentoo-14b81044f3d49fdea5621ccfb9fc788d863f65d0.tar.bz2
gentoo-14b81044f3d49fdea5621ccfb9fc788d863f65d0.zip
gui-libs/amtk: Version bump to 5.2.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/amtk/Manifest1
-rw-r--r--gui-libs/amtk/amtk-5.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/amtk/Manifest b/gui-libs/amtk/Manifest
index 99b472d28f81..cadd7082d8dc 100644
--- a/gui-libs/amtk/Manifest
+++ b/gui-libs/amtk/Manifest
@@ -1 +1,2 @@
DIST amtk-5.0.2.tar.xz 368440 BLAKE2B d13498079714612ac775a20032c0684b77c8a2238dad055dba6b87e81c009da22b53cb93df185a10278eedab2857321ee59230488f738064a4fb305345eba345 SHA512 71876430c4e7c19c49170ef6ff8d4c5324f871fd1e02162f33a9249b87f693fa4f4f748ac73d901135d331fee662e5000851e86a00d921da6669319728526136
+DIST amtk-5.2.0.tar.xz 381328 BLAKE2B b97a4b27d33bf49a97d585ecbecad04c3f2ea4e08e378d02218be5bf4aed2fe26f260ed1fd1eaa09a5b9f0e30e49901ddf860087fc630794aaa25ecda353b118 SHA512 520c9e762bdef96907320ec8dd4d3a005f262064ee402527c1087652af91c61657868189be8aedb7c0bd17758cf6d7e976da4ce941eb8a54e2d3e10ce55dc9eb
diff --git a/gui-libs/amtk/amtk-5.2.0.ebuild b/gui-libs/amtk/amtk-5.2.0.ebuild
new file mode 100644
index 000000000000..5ee4dcb91314
--- /dev/null
+++ b/gui-libs/amtk/amtk-5.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Actions, Menus and Toolbars Kit for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/Amtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.6
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gtk-doc \
+ --disable-installed-tests \
+ $(use_enable introspection) \
+ --disable-valgrind
+}