summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-07-08 17:31:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-07-08 18:03:50 +0200
commit08fea0c4f06e7dea34de50567a87ab0a589bc95e (patch)
tree2d99e65dcb7def8b8991934186d1caa3573f0e39 /kde-frameworks/kwallet
parentkde-frameworks/ktextwidgets: 5.108.0 version bump (diff)
downloadgentoo-08fea0c4f06e7dea34de50567a87ab0a589bc95e.tar.gz
gentoo-08fea0c4f06e7dea34de50567a87ab0a589bc95e.tar.bz2
gentoo-08fea0c4f06e7dea34de50567a87ab0a589bc95e.zip
kde-frameworks/kwallet: 5.108.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.108.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index c7c68c0c0edf..aaaf5da2eb01 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.106.0.tar.xz 347904 BLAKE2B a65c5acc479921db9d4306ea051c32892ac86d0ded089cbbd0ce54f9d2cfcac4cbd522050895740a899b6305202fa9d41e770eff2cd907356aba81994d898f50 SHA512 a67def95bd11df3fa0a5941f34ccc2fafca0e7ea2e526408295265b3f45b37a0192bcc3717d34f4f88de051d35ee16749fc6280fdfe5710c9ce6a5101ee294ef
DIST kwallet-5.107.0.tar.xz 349488 BLAKE2B 10a06ab530e9f209ce49524accddf3bd8a25cdb9fdd03fa107b20b8f2d8f66b1f9be0f70a4c26f236a7fa87091ed01c77dd6d40981e01564e26718fcb708b421 SHA512 e30f1f33af3856e1cfb462037b94d74d425e785aa7b81d0110c64f773ee8428135d69698d7a9165862f5b1a3f15b64df81f586a5cef647dc46e45dad2e1e04ec
+DIST kwallet-5.108.0.tar.xz 349548 BLAKE2B 67312e5887f897a9664308bd89c15871a9ef56df1196b59633a3c691764c111e657e403c9e5e0b9cab1c6b070c137095d0552f391bee7fca150cb3cc6274dd71 SHA512 ba129b8f20d1fc853075735127394629daafefd9c1c42d0a657a82ffc1634bcfa36ceddea98ac1e21fda1a4db842ae9e681cc87153571fedb3a596638d62fed7
diff --git a/kde-frameworks/kwallet/kwallet-5.108.0.ebuild b/kde-frameworks/kwallet/kwallet-5.108.0.ebuild
new file mode 100644
index 000000000000..e832641a95c2
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.108.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt5(+)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
+ gpg? ( >=app-crypt/gpgme-1.7.1:=[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}