summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-21 20:11:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-21 21:05:13 +0200
commit96827a2e12dc85baf412551a48eeef23e695fc53 (patch)
treeebb3e2a08b60d529d00d8f3a4da774f236e0b512 /kde-plasma/kwayland-integration
parentkde-plasma/kwayland: 6.0.5 version bump (diff)
downloadgentoo-96827a2e12dc85baf412551a48eeef23e695fc53.tar.gz
gentoo-96827a2e12dc85baf412551a48eeef23e695fc53.tar.bz2
gentoo-96827a2e12dc85baf412551a48eeef23e695fc53.zip
kde-plasma/kwayland-integration: 6.0.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-6.0.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 441d6c2f0473..add01d328b99 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.27.11.tar.xz 25708 BLAKE2B 67fe2d113955b2cdec1c3d621efbe84b2565aa3f22e0d15eb95f1a2bce1a6c7fe87da9c2974d93fb2f1939d92d64d2ab2a2a1db609df5973ded5ac4a02f214cf SHA512 c5f19a03e8161b346dbd89fb0d1b72d7906c19a7d55535878d9d75b7d96025d61808161f6b0ccaf9b5fef1d112f8e0ba1033ce149e42aec2cd261351d5ffb1c9
DIST kwayland-integration-6.0.4.tar.xz 26392 BLAKE2B 774a60343555fc480b98700886abc0769bcd25f996070603cdfd2735ff0dabb1e913e2901ee93eaad0dd4de31b48d871b2da59d15805bce920eec9af79f63179 SHA512 2fac1bf44212a0c70f89625bdf7169551e26d252299e740a3c0ee4c87a3172ed69549856c7cc0f2cb27b09c5b72fe4de14a186e2d513436708d839e95503157a
+DIST kwayland-integration-6.0.5.tar.xz 26416 BLAKE2B ce036d41d79d889941aaff8590fc2f72f62f55a41d2a7e877e8bccac046b7dd91664b3af7e4825c602285a50ce324a45fe59edb86669f13288c40386bffaae6e SHA512 394043d5efaa8b3f417145918f2fe297478ebcf3cc4fd44f1993ffb9e713df7ece7a69dffd2fb51925e301ba751dd08ea12d2fabe9e8d2af0b3cd40c5bceba7f
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-6.0.5.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-6.0.5.ebuild
new file mode 100644
index 000000000000..2ce54ec08c7a
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-6.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.115.0
+QTMIN=5.15.12
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ filter-lto # bug 921430
+ ecm_src_configure
+}