summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-01-08 14:03:04 +0200
committerMart Raudsepp <leio@gentoo.org>2018-01-08 14:57:07 +0200
commit08dbc54232da55b967d06e2d3bd19e6782b4ff6a (patch)
treeb5d2fe1de4e0cce2bd305f33a92160837ac59115 /mail-client/evolution
parentgnome-extra/evolution-data-server: bump to 3.24.7, fresh install fix, libical... (diff)
downloadgentoo-08dbc54232da55b967d06e2d3bd19e6782b4ff6a.tar.gz
gentoo-08dbc54232da55b967d06e2d3bd19e6782b4ff6a.tar.bz2
gentoo-08dbc54232da55b967d06e2d3bd19e6782b4ff6a.zip
mail-client/evolution: bump to 3.24.6, fix fresh install sandbox violation, libical3 compat
Bump, patch to honor DESTDIR and not update caches when set (might cause sandbox violation for us and be generally wrong), patches for libical:0/3 compatibility. As one more instance of libical3 problematic direct is_utc usage would have remained with just cherry-picked compat patch, the libical compat patch contains a different change as well, which removes that code, as is done in 3.26 (details in patch headers). Closes: https://bugs.gentoo.org/628460 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'mail-client/evolution')
-rw-r--r--mail-client/evolution/Manifest1
-rw-r--r--mail-client/evolution/evolution-3.24.6.ebuild161
-rw-r--r--mail-client/evolution/files/3.24.6-DESTDIR-honoring.patch53
-rw-r--r--mail-client/evolution/files/3.24.6-libical3-compat.patch265
4 files changed, 480 insertions, 0 deletions
diff --git a/mail-client/evolution/Manifest b/mail-client/evolution/Manifest
index 3c1e30d0af26..0e26ac097764 100644
--- a/mail-client/evolution/Manifest
+++ b/mail-client/evolution/Manifest
@@ -1,3 +1,4 @@
DIST evolution-3.22.4.tar.xz 12272488 BLAKE2B 7740d1d6e734fb7212d2b36f0a64dca03360ab059f0ca716522312c490f2b071a8fc6b383c98b429a6cb22ea5afec0e7e6c05dcb63b3908053ee891aa4129cdb SHA512 dd73a11d4d7903be6a99bf0d937f5a217a26f0dffb9dc0cea2ca81142d5783c42f889a8b913d565678e9f55b7f2f2a1d42f06c30e3cb004926c19f44dae3b70f
DIST evolution-3.22.6.tar.xz 12288232 BLAKE2B d9412ee86621fd87bbfdb5799de64a148c766642e62b6781a7a9111819ea9b3cd1aa94d95f71df2e46fdb347aedc8b28488a7ca6f7940f08644b00cdfc9f190d SHA512 c699adae640d05558b583b05eda5c5ad3de99aa1d1bbfa24af6110be41251f715ff4b16ff0efb96c8de7faa8c895d82460b504c2704974d4c9731f1bc3e7739f
DIST evolution-3.24.5.tar.xz 12140736 BLAKE2B e144307693f6ae1824aafd3444b38e435414aa1e7900b3622b5f36098d1c8d073ff565896bea07ad9eca076482d98c3bcea70e7d08d37c5fdcd68226d8bc4588 SHA512 daba1ebd9407219b3abe959b27adb32eb0038a9c1653c360a19cf28f8849004a8cd4a652562d696045311c13d19030f93d3578e09d06fff01534ada28f883f2c
+DIST evolution-3.24.6.tar.xz 12153692 BLAKE2B ced20d9e08f6b9aac65be6f5ecd5beb861feec40dddc4411b1bdc6519e249de8db8b3319450808d7a31b80386f9830f351b7edacb3c6fcd28fe5fdfe343329f7 SHA512 da5c9062791996735e52575894763597cc957cb17bc0abe46a966f0e3e6706550ce534ae03b2c444d142547119f3a59aec6ee17e0302a002d8437da166ef7178
diff --git a/mail-client/evolution/evolution-3.24.6.ebuild b/mail-client/evolution/evolution-3.24.6.ebuild
new file mode 100644
index 000000000000..26b43321586d
--- /dev/null
+++ b/mail-client/evolution/evolution-3.24.6.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit cmake-utils gnome2 flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
+SLOT="2.0"
+
+IUSE="archive +bogofilter crypt geolocation highlight ldap spamassassin spell ssl +weather"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+# We need a graphical pinentry frontend to be able to ask for the GPG
+# password from inside evolution, bug 160302
+PINENTRY_DEPEND="|| ( app-crypt/pinentry[gnome-keyring] app-crypt/pinentry[gtk] app-crypt/pinentry[qt4] app-crypt/pinentry[qt5] )"
+
+# glade-3 support is for maintainers only per configure.ac
+# pst is not mature enough and changes API/ABI frequently
+# dconf explicitely needed for backup plugin
+# gnome-desktop support is optional with --enable-gnome-desktop
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.4:=[gtk]
+ >=app-text/enchant-1.1.7
+ >=dev-libs/glib-2.46:2[dbus]
+ >=dev-libs/libxml2-2.7.3:2
+ >=gnome-base/gnome-desktop-2.91.3:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=gnome-extra/evolution-data-server-${PV}:=[gtk,weather?]
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/libsoup-2.42:2.4
+ >=net-libs/webkit-gtk-2.13.90:4
+ >=x11-libs/cairo-1.9.15:=[glib]
+ >=x11-libs/gdk-pixbuf-2.24:2
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/libnotify-0.7:=
+ >=x11-misc/shared-mime-info-0.22
+
+ >=app-text/iso-codes-0.49
+ dev-libs/atk
+ gnome-base/dconf
+ dev-libs/libical:=
+ x11-libs/libSM
+ x11-libs/libICE
+
+ archive? ( >=app-arch/gnome-autoar-0.1.1[gtk] )
+ crypt? (
+ >=app-crypt/gnupg-1.4
+ ${PINENTRY_DEPEND}
+ x11-libs/libcryptui )
+ geolocation? (
+ >=media-libs/libchamplain-0.12:0.12[gtk]
+ >=media-libs/clutter-1.0.0:1.0
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=sci-geosciences/geocode-glib-3.10.0
+ x11-libs/mx:1.0 )
+ ldap? ( >=net-nds/openldap-2:= )
+ spell? ( app-text/gtkspell:3 )
+ ssl? (
+ >=dev-libs/nspr-4.6.1:=
+ >=dev-libs/nss-3.11:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ bogofilter? ( mail-filter/bogofilter )
+ highlight? ( app-text/highlight )
+ spamassassin? ( mail-filter/spamassassin )
+ !gnome-extra/evolution-exchange
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
+~/.local/share/applications/mimeapps.list so it includes the
+following content:
+
+[Default Applications]
+x-scheme-handler/http=firefox.desktop
+x-scheme-handler/https=firefox.desktop
+
+(replace firefox.desktop with the name of the appropriate .desktop
+file from /usr/share/applications if you use a different browser)."
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-DESTDIR-honoring.patch
+ "${FILESDIR}"/${PV}-libical3-compat.patch
+)
+
+src_prepare() {
+ # Leave post-install actions to eclass
+ sed -e "s;\(find_program(GTK_UPDATE_ICON_CACHE\).*;\1 $(type -P true));" \
+ -i "${S}"/cmake/modules/IconCache.cmake || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ local mycmakeargs=(
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_GTK_DOC=OFF
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DENABLE_SMIME=$(usex ssl)
+ -DENABLE_GNOME_DESKTOP=ON
+ -DENABLE_CANBERRA=ON
+ -DENABLE_AUTOAR=$(usex archive)
+ -DWITH_HELP=ON
+ -DENABLE_LIBCRYPTUI=$(usex crypt)
+ -DENABLE_YTNEF=OFF
+ -DWITH_BOGOFILTER=$(usex bogofilter)
+ -DWITH_SPAMASSASSIN=$(usex spamassassin)
+ -DENABLE_GTKSPELL=$(usex spell)
+ -DENABLE_TEXT_HIGHLIGHT=$(usex highlight)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_CONTACT_MAPS=$(usex geolocation)
+ -DENABLE_PST_IMPORT=OFF
+ -DWITH_GLADE_CATALOG=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Problems with prelink:
+ # https://bugzilla.gnome.org/show_bug.cgi?id=731680
+ # https://bugzilla.gnome.org/show_bug.cgi?id=732148
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1114538
+ echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN}
+ doenvd "${T}"/99${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/mail-client/evolution/files/3.24.6-DESTDIR-honoring.patch b/mail-client/evolution/files/3.24.6-DESTDIR-honoring.patch
new file mode 100644
index 000000000000..7e024c937e7c
--- /dev/null
+++ b/mail-client/evolution/files/3.24.6-DESTDIR-honoring.patch
@@ -0,0 +1,53 @@
+From cb845f462072d1d1e4045eac5f16b4db1f552309 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Mon, 2 Oct 2017 19:22:41 +0200
+Subject: [PATCH] Bug 781645 - Skip GSettings schema compile and icon cache
+ update when DESTDIR is set
+
+(cherry picked from commit b40001cac702a74f818afb3f38acf9521e9d7b62)
+---
+ cmake/modules/GLibTools.cmake | 8 +++++---
+ cmake/modules/IconCache.cmake | 8 +++++---
+ 2 files changed, 10 insertions(+), 6 deletions(-)
+
+diff --git a/cmake/modules/GLibTools.cmake b/cmake/modules/GLibTools.cmake
+index fc8eb827c8..f0be5586db 100644
+--- a/cmake/modules/GLibTools.cmake
++++ b/cmake/modules/GLibTools.cmake
+@@ -238,9 +238,11 @@ macro(add_gsettings_schemas _target _schema0)
+ if(_install_code)
+ # Compile gsettings schemas and ensure that all of them are in the place.
+ install(CODE
+- "execute_process(${_install_code}
+- COMMAND ${CMAKE_COMMAND} -E chdir . \"${GLIB_COMPILE_SCHEMAS}\" \"${GSETTINGS_SCHEMAS_DIR}\"
+- )")
++ "if(\"\$ENV{DESTDIR}\" STREQUAL \"\")
++ execute_process(${_install_code}
++ COMMAND ${CMAKE_COMMAND} -E chdir . \"${GLIB_COMPILE_SCHEMAS}\" \"${GSETTINGS_SCHEMAS_DIR}\"
++ )
++ endif(\"\$ENV{DESTDIR}\" STREQUAL \"\")")
+ endif(_install_code)
+ endmacro(add_gsettings_schemas)
+
+diff --git a/cmake/modules/IconCache.cmake b/cmake/modules/IconCache.cmake
+index 6f7f5f0f24..145b843f1d 100644
+--- a/cmake/modules/IconCache.cmake
++++ b/cmake/modules/IconCache.cmake
+@@ -60,9 +60,11 @@ macro(add_icon_cache_files _destdir _fileslistvar)
+
+ if(GTK_UPDATE_ICON_CACHE)
+ install(CODE
+- "execute_process(${_install_code}
+- COMMAND ${CMAKE_COMMAND} -E chdir . ${_update_icon_cache_cmd}
+- )")
++ "if(\"\$ENV{DESTDIR}\" STREQUAL \"\")
++ execute_process(${_install_code}
++ COMMAND ${CMAKE_COMMAND} -E chdir . ${_update_icon_cache_cmd}
++ )
++ endif(\"\$ENV{DESTDIR}\" STREQUAL \"\")")
+ endif(GTK_UPDATE_ICON_CACHE)
+ endmacro(add_icon_cache_files)
+
+--
+2.15.1
+
diff --git a/mail-client/evolution/files/3.24.6-libical3-compat.patch b/mail-client/evolution/files/3.24.6-libical3-compat.patch
new file mode 100644
index 000000000000..a7e5da268ee4
--- /dev/null
+++ b/mail-client/evolution/files/3.24.6-libical3-compat.patch
@@ -0,0 +1,265 @@
+From a1bfd863de7732d138a6cdd4c08c763f81560c34 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Wed, 23 Aug 2017 14:11:12 +0200
+Subject: [PATCH 1/2] Bug 786163 - [ECalModel] Do not convert UTC times to
+ local time zone
+
+(cherry picked from commit 7a3abddc2f0b12916a607da27cbd6817f28de737)
+---
+ src/calendar/gui/e-cal-model.c | 27 ---------------------------
+ 1 file changed, 27 deletions(-)
+
+diff --git a/src/calendar/gui/e-cal-model.c b/src/calendar/gui/e-cal-model.c
+index 582fd7f3ea..75bf60fb2f 100644
+--- a/src/calendar/gui/e-cal-model.c
++++ b/src/calendar/gui/e-cal-model.c
+@@ -1943,32 +1943,6 @@ e_cal_model_get_component_index (ECalModel *model,
+ return -1;
+ }
+
+-/* We do this check since the calendar items are downloaded from the server
+- * in the open_method, since the default timezone might not be set there. */
+-static void
+-ensure_dates_are_in_default_zone (ECalModel *model,
+- icalcomponent *icalcomp)
+-{
+- icaltimetype dt;
+- icaltimezone *zone;
+-
+- zone = e_cal_model_get_timezone (model);
+- if (!zone)
+- return;
+-
+- dt = icalcomponent_get_dtstart (icalcomp);
+- if (dt.is_utc) {
+- dt = icaltime_convert_to_zone (dt, zone);
+- icalcomponent_set_dtstart (icalcomp, dt);
+- }
+-
+- dt = icalcomponent_get_dtend (icalcomp);
+- if (dt.is_utc) {
+- dt = icaltime_convert_to_zone (dt, zone);
+- icalcomponent_set_dtend (icalcomp, dt);
+- }
+-}
+-
+ static void
+ cal_model_data_subscriber_component_added_or_modified (ECalDataModelSubscriber *subscriber,
+ ECalClient *client,
+@@ -1995,7 +1969,6 @@ cal_model_data_subscriber_component_added_or_modified (ECalDataModelSubscriber *
+
+ table_model = E_TABLE_MODEL (model);
+ icalcomp = icalcomponent_new_clone (e_cal_component_get_icalcomponent (comp));
+- ensure_dates_are_in_default_zone (model, icalcomp);
+
+ if (index < 0) {
+ e_table_model_pre_change (table_model);
+--
+2.15.1
+
+
+From f9d1eb89115b62bf6fd9d986856a4f4d26fc8e49 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Wed, 4 Oct 2017 11:57:56 +0200
+Subject: [PATCH 2/2] Use icaltime_is_utc() instead of icaltimetype::is_utc
+
+The structure member is going to be removed from libical in the next release
+and the function is available for a long time, thus it's safe to replace
+the usage in the code.
+
+(cherry picked from commit ec8468efd71e8c81ebd6933646486237c32dd2b0)
+---
+ src/calendar/gui/comp-util.c | 6 +++---
+ src/calendar/gui/e-cal-component-preview.c | 2 +-
+ src/calendar/gui/e-comp-editor-event.c | 8 +++-----
+ src/calendar/gui/e-comp-editor-page-recurrence.c | 1 -
+ src/calendar/gui/e-comp-editor-property-part.c | 2 --
+ src/calendar/gui/e-comp-editor-task.c | 2 +-
+ src/calendar/gui/e-meeting-store.c | 4 ++--
+ src/calendar/gui/itip-utils.c | 2 +-
+ src/modules/itip-formatter/itip-view.c | 8 ++++----
+ 9 files changed, 15 insertions(+), 20 deletions(-)
+
+diff --git a/src/calendar/gui/comp-util.c b/src/calendar/gui/comp-util.c
+index 6de47e8057..81d7b91b96 100644
+--- a/src/calendar/gui/comp-util.c
++++ b/src/calendar/gui/comp-util.c
+@@ -123,8 +123,8 @@ cal_comp_util_compare_event_timezones (ECalComponent *comp,
+ /* If the event uses UTC for DTSTART & DTEND, return TRUE. Outlook
+ * will send single events as UTC, so we don't want to mark all of
+ * these. */
+- if ((!start_datetime.value || start_datetime.value->is_utc)
+- && (!end_datetime.value || end_datetime.value->is_utc)) {
++ if ((!start_datetime.value || icaltime_is_utc (*start_datetime.value))
++ && (!end_datetime.value || icaltime_is_utc (*end_datetime.value))) {
+ retval = TRUE;
+ goto out;
+ }
+@@ -1328,7 +1328,7 @@ cal_comp_util_update_tzid_parameter (icalproperty *prop,
+ if (tt.zone)
+ tzid = icaltimezone_get_tzid ((icaltimezone *) tt.zone);
+
+- if (tt.zone && tzid && *tzid && !tt.is_utc && !tt.is_date) {
++ if (tt.zone && tzid && *tzid && !icaltime_is_utc (tt) && !tt.is_date) {
+ if (param) {
+ icalparameter_set_tzid (param, (gchar *) tzid);
+ } else {
+diff --git a/src/calendar/gui/e-cal-component-preview.c b/src/calendar/gui/e-cal-component-preview.c
+index 67e56906e2..5801f71fc2 100644
+--- a/src/calendar/gui/e-cal-component-preview.c
++++ b/src/calendar/gui/e-cal-component-preview.c
+@@ -168,7 +168,7 @@ timet_to_str_with_zone (ECalComponentDateTime *dt,
+ if (dt->tzid != NULL) {
+ e_cal_client_get_timezone_sync (
+ client, dt->tzid, &zone, NULL, NULL);
+- } else if (dt->value->is_utc) {
++ } else if (icaltime_is_utc (*dt->value)) {
+ zone = icaltimezone_get_utc_timezone ();
+ }
+
+diff --git a/src/calendar/gui/e-comp-editor-event.c b/src/calendar/gui/e-comp-editor-event.c
+index d56c1c9e90..40546a90aa 100644
+--- a/src/calendar/gui/e-comp-editor-event.c
++++ b/src/calendar/gui/e-comp-editor-event.c
+@@ -286,7 +286,7 @@ ece_event_update_timezone (ECompEditorEvent *event_editor,
+ if (icalcomponent_get_first_property (component, ICAL_DTSTART_PROPERTY)) {
+ dtstart = icalcomponent_get_dtstart (component);
+ if (icaltime_is_valid_time (dtstart)) {
+- if (dtstart.is_utc)
++ if (icaltime_is_utc (dtstart))
+ zone = icaltimezone_get_utc_timezone ();
+ else
+ zone = ece_event_get_timezone_from_property (comp_editor,
+@@ -297,7 +297,7 @@ ece_event_update_timezone (ECompEditorEvent *event_editor,
+ if (icalcomponent_get_first_property (component, ICAL_DTEND_PROPERTY)) {
+ dtend = icalcomponent_get_dtend (component);
+ if (!zone && icaltime_is_valid_time (dtend)) {
+- if (dtend.is_utc)
++ if (icaltime_is_utc (dtend))
+ zone = icaltimezone_get_utc_timezone ();
+ else
+ zone = ece_event_get_timezone_from_property (comp_editor,
+@@ -310,7 +310,7 @@ ece_event_update_timezone (ECompEditorEvent *event_editor,
+
+ itt = icalcomponent_get_due (component);
+ if (icaltime_is_valid_time (itt)) {
+- if (itt.is_utc)
++ if (icaltime_is_utc (itt))
+ zone = icaltimezone_get_utc_timezone ();
+ else
+ zone = ece_event_get_timezone_from_property (comp_editor,
+@@ -497,10 +497,8 @@ ece_event_fill_component (ECompEditor *comp_editor,
+ dtstart.zone = e_timezone_entry_get_timezone (E_TIMEZONE_ENTRY (timezone_entry));
+ if (!dtstart.zone)
+ dtstart.zone = icaltimezone_get_utc_timezone ();
+- dtstart.is_utc = dtstart.zone == icaltimezone_get_utc_timezone ();
+
+ dtend.zone = dtstart.zone;
+- dtend.is_utc = dtstart.is_utc;
+
+ set_dtstart = TRUE;
+ set_dtend = TRUE;
+diff --git a/src/calendar/gui/e-comp-editor-page-recurrence.c b/src/calendar/gui/e-comp-editor-page-recurrence.c
+index 7f302dfc7f..139f07d1d3 100644
+--- a/src/calendar/gui/e-comp-editor-page-recurrence.c
++++ b/src/calendar/gui/e-comp-editor-page-recurrence.c
+@@ -1088,7 +1088,6 @@ ecep_recurrence_fill_ending_date (ECompEditorPageRecurrence *page_recurrence,
+ rrule->until.minute = 0;
+ rrule->until.second = 0;
+ rrule->until.is_date = TRUE;
+- rrule->until.is_utc = FALSE;
+ }
+
+ page_recurrence->priv->ending_date_tt = rrule->until;
+diff --git a/src/calendar/gui/e-comp-editor-property-part.c b/src/calendar/gui/e-comp-editor-property-part.c
+index bc42ef15c1..bb3582a6b8 100644
+--- a/src/calendar/gui/e-comp-editor-property-part.c
++++ b/src/calendar/gui/e-comp-editor-property-part.c
+@@ -872,8 +872,6 @@ e_comp_editor_property_part_datetime_get_value (ECompEditorPropertyPartDatetime
+ value.zone = e_timezone_entry_get_timezone (timezone_entry);
+ if (!value.zone)
+ value.zone = icaltimezone_get_utc_timezone ();
+-
+- value.is_utc = value.zone == icaltimezone_get_utc_timezone ();
+ }
+
+ g_clear_object (&timezone_entry);
+diff --git a/src/calendar/gui/e-comp-editor-task.c b/src/calendar/gui/e-comp-editor-task.c
+index 16f31d8d32..86c1dca9ae 100644
+--- a/src/calendar/gui/e-comp-editor-task.c
++++ b/src/calendar/gui/e-comp-editor-task.c
+@@ -120,7 +120,7 @@ ece_task_update_timezone (ECompEditorTask *task_editor,
+ if (force_allday && dt.is_date)
+ *force_allday = TRUE;
+
+- if (dt.is_utc)
++ if (icaltime_is_utc (dt))
+ zone = icaltimezone_get_utc_timezone ();
+ else
+ zone = ece_task_get_timezone_from_property (comp_editor,
+diff --git a/src/calendar/gui/e-meeting-store.c b/src/calendar/gui/e-meeting-store.c
+index 13c2e8643b..ae5b1f5c0f 100644
+--- a/src/calendar/gui/e-meeting-store.c
++++ b/src/calendar/gui/e-meeting-store.c
+@@ -1347,7 +1347,7 @@ process_free_busy_comp (EMeetingAttendee *attendee,
+ icaltimezone *ds_zone;
+
+ dtstart = icalproperty_get_dtstart (ip);
+- if (!dtstart.is_utc)
++ if (!icaltime_is_utc (dtstart))
+ ds_zone = find_zone (ip, tz_top_level);
+ else
+ ds_zone = icaltimezone_get_utc_timezone ();
+@@ -1367,7 +1367,7 @@ process_free_busy_comp (EMeetingAttendee *attendee,
+ icaltimezone *de_zone;
+
+ dtend = icalproperty_get_dtend (ip);
+- if (!dtend.is_utc)
++ if (!icaltime_is_utc (dtend))
+ de_zone = find_zone (ip, tz_top_level);
+ else
+ de_zone = icaltimezone_get_utc_timezone ();
+diff --git a/src/calendar/gui/itip-utils.c b/src/calendar/gui/itip-utils.c
+index d808a3c7fc..2b85786f37 100644
+--- a/src/calendar/gui/itip-utils.c
++++ b/src/calendar/gui/itip-utils.c
+@@ -1607,7 +1607,7 @@ comp_compliant (ESourceRegistry *registry,
+ r->until.is_date = FALSE;
+
+ icaltimezone_convert_time (&r->until, from_zone, to_zone);
+- r->until.is_utc = TRUE;
++ r->until.zone = to_zone;
+
+ e_cal_component_free_datetime (&dt);
+ e_cal_component_set_rrule_list (clone, rrule_list);
+diff --git a/src/modules/itip-formatter/itip-view.c b/src/modules/itip-formatter/itip-view.c
+index 62303b9b35..5be43ad091 100644
+--- a/src/modules/itip-formatter/itip-view.c
++++ b/src/modules/itip-formatter/itip-view.c
+@@ -6167,9 +6167,9 @@ itip_view_init_view (ItipView *view)
+
+ /* If the timezone is not in the component, guess the local time */
+ /* Should we guess if the timezone is an olsen name somehow? */
+- if (datetime.value->is_utc)
++ if (icaltime_is_utc (*datetime.value))
+ from_zone = icaltimezone_get_utc_timezone ();
+- else if (!datetime.value->is_utc && datetime.tzid) {
++ else if (!icaltime_is_utc (*datetime.value) && datetime.tzid) {
+ from_zone = icalcomponent_get_timezone (view->priv->top_level, datetime.tzid);
+
+ if (!from_zone)
+@@ -6206,9 +6206,9 @@ itip_view_init_view (ItipView *view)
+
+ /* If the timezone is not in the component, guess the local time */
+ /* Should we guess if the timezone is an olsen name somehow? */
+- if (datetime.value->is_utc)
++ if (icaltime_is_utc (*datetime.value))
+ from_zone = icaltimezone_get_utc_timezone ();
+- else if (!datetime.value->is_utc && datetime.tzid) {
++ else if (!icaltime_is_utc (*datetime.value) && datetime.tzid) {
+ from_zone = icalcomponent_get_timezone (view->priv->top_level, datetime.tzid);
+
+ if (!from_zone)
+--
+2.15.1
+