summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-29 21:40:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-29 22:07:06 +0200
commitb40dfc26904023df04f4fa2f09400f5866d03b64 (patch)
treed706a6408fc713864cf2116c730f5f83c24848a5 /mail-client/kube
parentdev-libs/sink: 0.8.0 version bump (diff)
downloadgentoo-b40dfc26904023df04f4fa2f09400f5866d03b64.tar.gz
gentoo-b40dfc26904023df04f4fa2f09400f5866d03b64.tar.bz2
gentoo-b40dfc26904023df04f4fa2f09400f5866d03b64.zip
mail-client/kube: Accept kde-frameworks/kcalendarcore
Add missing dev-qt/qtconcurrent:5 Update DESCRIPTION Use patch and switch to KDE_TEST="forceoptional" Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'mail-client/kube')
-rw-r--r--mail-client/kube/files/kube-0.7.0-tests-optional.patch64
-rw-r--r--mail-client/kube/kube-0.7.0.ebuild12
2 files changed, 73 insertions, 3 deletions
diff --git a/mail-client/kube/files/kube-0.7.0-tests-optional.patch b/mail-client/kube/files/kube-0.7.0-tests-optional.patch
new file mode 100644
index 000000000000..efdf09c775b9
--- /dev/null
+++ b/mail-client/kube/files/kube-0.7.0-tests-optional.patch
@@ -0,0 +1,64 @@
+--- a/CMakeLists.txt 2019-09-29 21:36:28.419106801 +0200
++++ b/CMakeLists.txt 2019-09-29 21:36:28.423106839 +0200
+@@ -43,7 +43,9 @@
+ add_subdirectory(applications)
+ add_subdirectory(views)
+ add_subdirectory(accounts)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ if (${ENABLE_EXTENSION})
+ add_subdirectory(extensions)
+ endif()
+--- a/framework/CMakeLists.txt 2019-09-29 21:36:28.428106886 +0200
++++ b/framework/CMakeLists.txt 2019-09-29 21:36:28.433106934 +0200
+@@ -4,4 +4,6 @@
+ install(FILES qmldir DESTINATION ${FRAMEWORK_INSTALL_DIR})
+
+ add_subdirectory(src)
++if(BUILD_TESTING)
+ add_subdirectory(qml/tests)
++endif()
+--- a/framework/src/CMakeLists.txt 2019-09-29 21:36:28.437106972 +0200
++++ b/framework/src/CMakeLists.txt 2019-09-29 21:36:28.450107095 +0200
+@@ -86,10 +86,16 @@
+
+ set(BUILD_TESTING ON)
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(domain/mime)
++if(BUILD_TESTING)
+ add_subdirectory(domain/mime/tests)
++endif()
+ add_subdirectory(domain/mime/mimetreeparser)
++if(BUILD_TESTING)
+ add_subdirectory(domain/settings/tests)
++endif()
+
+ feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+--- a/framework/src/domain/mime/mimetreeparser/CMakeLists.txt 2019-09-29 21:36:28.455107143 +0200
++++ b/framework/src/domain/mime/mimetreeparser/CMakeLists.txt 2019-09-29 21:36:28.458107171 +0200
+@@ -49,5 +49,9 @@
+ Gpgme::Gpgme
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory(autotests)
++endif()
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/components/CMakeLists.txt 2019-09-29 21:36:28.463107218 +0200
++++ b/components/CMakeLists.txt 2019-09-29 21:36:28.476107341 +0200
+@@ -8,7 +8,9 @@
+ endmacro(install_qml_component)
+
+ install_qml_component(kube)
++if(BUILD_TESTING)
+ add_subdirectory(kube/tests)
++endif()
+ install_qml_component(accounts)
+
+
diff --git a/mail-client/kube/kube-0.7.0.ebuild b/mail-client/kube/kube-0.7.0.ebuild
index 75753f8bb2f6..9b40730b0d69 100644
--- a/mail-client/kube/kube-0.7.0.ebuild
+++ b/mail-client/kube/kube-0.7.0.ebuild
@@ -3,10 +3,10 @@
EAPI=7
-KDE_TEST="forceoptional-recursive"
+KDE_TEST="forceoptional"
inherit kde5
-DESCRIPTION="A mail client by KDE"
+DESCRIPTION="Mail client based on KDE Frameworks"
HOMEPAGE="https://kube.kde.org/"
SRC_URI="https://github.com/KDE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
@@ -14,8 +14,12 @@ KEYWORDS="~amd64"
RDEPEND="
$(add_frameworks_dep breeze-icons)
$(add_frameworks_dep kcodecs)
- $(add_kdeapps_dep kcontacts)
+ || (
+ $(add_frameworks_dep kcontacts)
+ $(add_kdeapps_dep kcontacts)
+ )
$(add_kdeapps_dep kmime)
+ $(add_qt_dep qtconcurrent)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
@@ -34,6 +38,8 @@ DEPEND="${RDEPEND}
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-tests-optional.patch" )
+
src_prepare() {
kde5_src_prepare