summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-04-07 17:51:50 +0200
committerPacho Ramos <pacho@gentoo.org>2024-04-07 17:51:50 +0200
commit0b45281350808f1db7ef869d04f7e7be2b6c50e5 (patch)
treee69574de79f0f434e311e60123f82214959651bc /media-fonts
parentnet-libs/libproxy: add 0.5.5 (diff)
downloadgentoo-0b45281350808f1db7ef869d04f7e7be2b6c50e5.tar.gz
gentoo-0b45281350808f1db7ef869d04f7e7be2b6c50e5.tar.bz2
gentoo-0b45281350808f1db7ef869d04f7e7be2b6c50e5.zip
media-fonts/noto: add 20240325
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/noto/Manifest1
-rw-r--r--media-fonts/noto/noto-20240325.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-fonts/noto/Manifest b/media-fonts/noto/Manifest
index cd96ed691c8d..9b699dab50db 100644
--- a/media-fonts/noto/Manifest
+++ b/media-fonts/noto/Manifest
@@ -2,3 +2,4 @@ DIST noto-20230930.tar.gz 1034822159 BLAKE2B 25af396043c2639d31711357b44bbf588f2
DIST noto-20231128.tar.gz 1062692273 BLAKE2B adab3e85f0f744b1d37ea0877db14d399baff3dab3496a01181ac977a6e5b1fd04c6ab5a7ee3dfcb190583d18f585eae70cf244bfb993107b6a8e84b62f45bde SHA512 ccc54993bc9651a2e6e654270c0c67f9eeb9659b60246cae407a11fe7d87d438a91250d2d96fd3f970b11d17386133375a1c66fbedf551344998ded89acb4835
DIST noto-20240131.tar.gz 1065422681 BLAKE2B 2774fb7a3152c989ed644b57a55524d0c4a3614d4fef3022a2df5fbabace6f3bddf0ef9812f328e75338442eecb67323e029f2f94c8e62a2ad0359fe7f69e0bb SHA512 1e4a64ce11efd46278837b88e972ed02e593503276ae6ce5d5d77f042afb2f0e4f69d326597597ad9819e8d3ccfa878a115c1fb196880e06bdec0ee9fd417821
DIST noto-20240229.tar.gz 1065887601 BLAKE2B 32c4cd85a83c346bdf25cf0aa87c96500c261f501ec6e57549cefb2faf87183fb7e4a73c62fed491ab2779ee92af88474bff6829bfb5846c00585728376e2415 SHA512 5f878f0561732a8dc0efc4e7694d38254bc251660f1b8ead3a92cf7956219ffc481e36ffce40e1dff1dc25f435bfa90cc07aea53d5f2a39e0bd99e00cc2a0937
+DIST noto-20240325.tar.gz 1067006253 BLAKE2B ea65c14ef0aca4f732e5ca7eb02b79756e124524b3f1bb0a3724a75fc2d503e13d264fcdaa39451a6171ea16e4cb2396d881921fc321e759410133a1bd7498df SHA512 039911249ed18d796850fccf6d181c82850d703606e28105eefd3bffeb250ef8c1b0ad155b6fbce2d95853a713a9d3eff512b0d1ad2f680b66b01a25f508e1b9
diff --git a/media-fonts/noto/noto-20240325.ebuild b/media-fonts/noto/noto-20240325.ebuild
new file mode 100644
index 000000000000..a9a752365a91
--- /dev/null
+++ b/media-fonts/noto/noto-20240325.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://fonts.google.com/noto https://github.com/notofonts/notofonts.github.io"
+
+COMMIT="2c3d6b5b45f3683bbc6db45048df8e02963ba67b"
+SRC_URI="https://github.com/notofonts/notofonts.github.io/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://fonts.google.com/noto
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/notofonts.github.io-${COMMIT}"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-hinted || die
+ mv fonts/*/hinted/ttf/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.tt[f,c]
+}