summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-09-02 15:07:23 +0200
committerUlrich Müller <ulm@gentoo.org>2020-09-02 15:08:09 +0200
commit6a13f94165568c377f6883627e02e1e1cf3200a9 (patch)
tree992d56e0fd75fb1b7ccd38cb679b63aebe2968ec /media-gfx/word_cloud
parentgames-action/supertuxkart: fix patch line-endings (diff)
downloadgentoo-6a13f94165568c377f6883627e02e1e1cf3200a9.tar.gz
gentoo-6a13f94165568c377f6883627e02e1e1cf3200a9.tar.bz2
gentoo-6a13f94165568c377f6883627e02e1e1cf3200a9.zip
media-gfx/word_cloud: Version bump to 1.8.0.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'media-gfx/word_cloud')
-rw-r--r--media-gfx/word_cloud/Manifest1
-rw-r--r--media-gfx/word_cloud/word_cloud-1.8.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/Manifest b/media-gfx/word_cloud/Manifest
index 8eac0255ce86..d127be720efc 100644
--- a/media-gfx/word_cloud/Manifest
+++ b/media-gfx/word_cloud/Manifest
@@ -1 +1,2 @@
DIST word_cloud-1.6.0.tar.gz 27524706 BLAKE2B 751b78fca97ec6e93c6a766c5b960dbb5fd91c012637e9c905ef96eea0dc60882ef1604a9868cfb3ca91a2c9ac6f50132ad5d820e6dd52114e68112bbe6decb0 SHA512 cb67570e2f6206c92316ef398382703b4ff0f1740688cd4a9ec66a093a663e903da66daaef666d634a7fddc5ec19da859d706693940a963a3bf58c52e9054056
+DIST word_cloud-1.8.0.tar.gz 27691477 BLAKE2B 26f1a9da8382fb1865d939bf87ed91911a1d5c1f0c38294d514e9ca9917d4293a9c8c7bb304fe68889127becb01eca77c0fc5e1d3588b9a5015971afee4f8aba SHA512 25b30b88953e8aca8ec5c7ce156fd1519c3b10e7d9dd0160d22136513ae28be9eed8bcfcbca0292879c43a115b2b7eac8324640590d571aa27549973fa8b98c5
diff --git a/media-gfx/word_cloud/word_cloud-1.8.0.ebuild b/media-gfx/word_cloud/word_cloud-1.8.0.ebuild
new file mode 100644
index 000000000000..9e8a918b2496
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.0-bundled-font.patch )