summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <dracwyrm@gentoo.org>2018-08-07 13:53:26 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-07 13:53:26 +0100
commit1ddbf737efc7d93b883dcb909afdfc68011ca1c2 (patch)
tree2030214414bb72d355ab87567f6d1f2c1c5f15b7 /media-libs/opensubdiv
parentmedia-libs/opensubdiv: remove no_maya configuration option (diff)
downloadgentoo-1ddbf737efc7d93b883dcb909afdfc68011ca1c2.tar.gz
gentoo-1ddbf737efc7d93b883dcb909afdfc68011ca1c2.tar.bz2
gentoo-1ddbf737efc7d93b883dcb909afdfc68011ca1c2.zip
media-libs/opensubdiv: version bump to 3.3.3
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'media-libs/opensubdiv')
-rw-r--r--media-libs/opensubdiv/Manifest1
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/opensubdiv/Manifest b/media-libs/opensubdiv/Manifest
index 91635b621715..54d1559b5b3a 100644
--- a/media-libs/opensubdiv/Manifest
+++ b/media-libs/opensubdiv/Manifest
@@ -1 +1,2 @@
DIST opensubdiv-3.3.0.tar.gz 19263469 BLAKE2B f169b5c58877d1dd4ea45cb04d52567803da7c2d11edab072e2b65583109c7c2d52abe07f5bd2b03cba215cdb524a0468900419d8381e95c35eb2f3f4bebe02b SHA512 7c17d847187d46182d08fbee9396fd8793ac04591821084d40da475c9d25560d01575282946e1a30252bba12db9ea06cbf50ff649f91adce72f6127ad6a36418
+DIST opensubdiv-3.3.3.tar.gz 19286806 BLAKE2B 05e25f28a6f2194122d9d4e5299e6d68e236c1e78b4e8494a70191dfb37e45da30968322719bbb784a15d698206fea9e26e92d4689668592bc9ec9bccbc0201d SHA512 65cd72b4240eeb3fdb6d52497a2daa2fc68e10c25c41ffa0cf81449ebcb860e303539043c672265916267a0115f250566570b5705fd5da54f46abe7b9f7baf81
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild
new file mode 100644
index 000000000000..043b810269d4
--- /dev/null
+++ b/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs eapi7-ver
+
+MY_PV="$(ver_rs "1-3" '_')"
+DESCRIPTION="An Open-Source subdivision surface library"
+HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
+SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuda doc opencl openmp ptex tbb"
+
+RDEPEND="media-libs/glew:=
+ media-libs/glfw:=
+ cuda? ( dev-util/nvidia-cuda-toolkit:* )
+ opencl? ( virtual/opencl )
+ ptex? ( media-libs/ptex )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/docutils
+ app-doc/doxygen
+ )
+ tbb? ( dev-cpp/tbb )"
+
+S="${WORKDIR}/OpenSubdiv-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.3.0-fix-quotes.patch"
+ "${FILESDIR}/${PN}-3.3.0-use-gnuinstalldirs.patch"
+ "${FILESDIR}/${PN}-3.3.0-add-CUDA9-compatibility.patch"
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNO_CLEW=1
+ -DNO_DOC=$(usex !doc)
+ -DNO_TBB=$(usex !tbb)
+ -DNO_PTEX=$(usex !ptex)
+ -DNO_OMP=$(usex !openmp)
+ -DNO_OPENCL=$(usex !opencl)
+ -DNO_CUDA=$(usex !cuda)
+ -DNO_REGRESSION=1 # They don't work with certain settings
+ -DNO_EXAMPLES=1 # Not needed.
+ -DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
+ -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ )
+
+ cmake-utils_src_configure
+}