summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/imagination
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/imagination')
-rw-r--r--media-video/imagination/Manifest1
-rw-r--r--media-video/imagination/files/imagination-3.0-cflags.patch34
-rw-r--r--media-video/imagination/imagination-3.0-r1.ebuild44
-rw-r--r--media-video/imagination/imagination-3.0.ebuild34
-rw-r--r--media-video/imagination/metadata.xml13
5 files changed, 126 insertions, 0 deletions
diff --git a/media-video/imagination/Manifest b/media-video/imagination/Manifest
new file mode 100644
index 000000000000..ee1f6d9a4f25
--- /dev/null
+++ b/media-video/imagination/Manifest
@@ -0,0 +1 @@
+DIST imagination-3.0.tar.gz 3327784 SHA256 417d8586d9c85109b87d30b9c196d63531a637cbc2ffb3c12b48a873bfcb4b1e SHA512 0780ab572d8f4fc1e728befef79f974169438d723f67205e677c06cbe0dac06745868936e7d3eab5fc42728902f6b06eb5f9d7e836532c289df005ddab2104b8 WHIRLPOOL f091ea5d65b79cdd2b74cb330a91b9da3b707e0f775af4aa9f0d523e414705fce25e630d32f4c4b6433068a0ce61d48352fa61842b8e736233a6c3eff2a897e7
diff --git a/media-video/imagination/files/imagination-3.0-cflags.patch b/media-video/imagination/files/imagination-3.0-cflags.patch
new file mode 100644
index 000000000000..1b38a9aeff71
--- /dev/null
+++ b/media-video/imagination/files/imagination-3.0-cflags.patch
@@ -0,0 +1,34 @@
+diff --git a/configure.in b/configure.in
+index 0be7802..d19c8ec 100644
+--- a/configure.in
++++ b/configure.in
+@@ -24,7 +24,7 @@
+ AM_PROG_LIBTOOL
+ LIBTOOL="$LIBTOOL --silent"
+
+-pkg_modules="gtk+-2.0 >= 2.14.0 gthread-2.0"
++pkg_modules="gtk+-2.0 >= 2.14.0 gthread-2.0 gmodule-2.0"
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+
+ sox_modules="sox >= 14.2.0"
+@@ -33,6 +33,11 @@
+ plugins_modules="cairo >= 1.6 glib-2.0 > 2.18.0"
+ PKG_CHECK_MODULES(PLUGINS, [$plugins_modules])
+
++dnl Check for libm for sqrtf()
++AC_SEARCH_LIBS([sqrtf], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrtf() function])
++])
++
+ # get svn revision
+ REVISION="r0"
+ if test "x${REVISION}" = "xr0"
+@@ -46,7 +51,7 @@
+ if test "x${REVISION}" != "xr0"
+ then
+ # force debug mode for a SVN working copy
+- CFLAGS="-g -Wall"
++ CFLAGS +="-Wall"
+ else
+ REVISION="-1"
+ fi
diff --git a/media-video/imagination/imagination-3.0-r1.ebuild b/media-video/imagination/imagination-3.0-r1.ebuild
new file mode 100644
index 000000000000..bff3ad21d083
--- /dev/null
+++ b/media-video/imagination/imagination-3.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Simple DVD slideshow maker"
+HOMEPAGE="http://imagination.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_cs linguas_de linguas_en_GB linguas_fr linguas_it linguas_pt_BR
+linguas_sv linguas_zh_CN linguas_zh_TW"
+
+DEPEND="x11-libs/gtk+:2
+ media-sound/sox"
+RDEPEND="${DEPEND}
+ virtual/ffmpeg"
+
+LANGS="cs de en_GB fr it pt_BR sv zh_CN zh_TW"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ # enable translations. Bug #380011
+ sed -i -e "/#define PLUGINS_INSTALLED/s:0:1:" "${S}"/src/support.h || die
+ rm "${S}"/po/LINGUAS
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm "${S}"/po/${x}.po || die
+ else
+ echo -n "${x} " >> "${S}"/po/LINGUAS
+ fi
+ done
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon icons/48x48/${PN}.png
+}
diff --git a/media-video/imagination/imagination-3.0.ebuild b/media-video/imagination/imagination-3.0.ebuild
new file mode 100644
index 000000000000..333e127fc633
--- /dev/null
+++ b/media-video/imagination/imagination-3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Simple DVD slideshow maker"
+HOMEPAGE="http://imagination.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_cs linguas_de linguas_en_GB linguas_fr linguas_it linguas_pt_BR
+linguas_sv linguas_zh_CN linguas_zh_TW"
+
+DEPEND="x11-libs/gtk+:2
+ media-sound/sox"
+RDEPEND="${DEPEND}
+ virtual/ffmpeg"
+
+LANGS="cs de en_GB fr it pt_BR sv zh_CN zh_TW"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon icons/48x48/${PN}.png
+}
diff --git a/media-video/imagination/metadata.xml b/media-video/imagination/metadata.xml
new file mode 100644
index 000000000000..9f1fdd3b37f4
--- /dev/null
+++ b/media-video/imagination/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">imagination</remote-id>
+ </upstream>
+</pkgmetadata>