summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-02-03 07:38:14 -0600
committerBen Kohler <bkohler@gentoo.org>2021-02-03 07:38:14 -0600
commitb95bb9d436526ffa17b44909a659e94477e5bd31 (patch)
tree3343a7bb5848bda8f69536710f166672d8cd65a3 /media-video/ushare
parentnet-misc/remmina: bump to 1.4.11 (diff)
downloadgentoo-b95bb9d436526ffa17b44909a659e94477e5bd31.tar.gz
gentoo-b95bb9d436526ffa17b44909a659e94477e5bd31.tar.bz2
gentoo-b95bb9d436526ffa17b44909a659e94477e5bd31.zip
media-video/ushare: drop old
Closes: https://bugs.gentoo.org/761882 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-video/ushare')
-rw-r--r--media-video/ushare/Manifest1
-rw-r--r--media-video/ushare/files/04_all_ushare_upnp_build_fix.patch156
-rw-r--r--media-video/ushare/files/05_all_missing_headers.patch59
-rw-r--r--media-video/ushare/files/06_all_ushare_disable_sysconf.patch20
-rw-r--r--media-video/ushare/files/08_all_gcc5.patch45
-rw-r--r--media-video/ushare/files/ushare.init.d78
-rw-r--r--media-video/ushare/ushare-1.1a-r9.ebuild62
7 files changed, 0 insertions, 421 deletions
diff --git a/media-video/ushare/Manifest b/media-video/ushare/Manifest
index 183df7c4b520..1039352320ae 100644
--- a/media-video/ushare/Manifest
+++ b/media-video/ushare/Manifest
@@ -1,2 +1 @@
-DIST ushare-1.1a.tar.bz2 65864 BLAKE2B 2a6d6922ee46c96d89a6f9a3238a1cded04194c4e7b80432e87a1c2344dcbf36484959d4601a7da8dc599531334b15a0547fc571af72630f25562e07a4116ea9 SHA512 2144ef96e58960d4d11bcefcd857c7eb7adab8df4ff815772d3b9d668f9f9daa1312707eb00a770c461b2a316e094e6697a004723ea02e86ee872fbe60b4797c
DIST ushare-1.1a_p20200824.tar.gz 72751 BLAKE2B 3f9116eab500ad9eb959ded9b1e406100cfbbc32c27b1cc599ef301f8d72e9acb1e053722b8724fc3d350fffda6e5b932eb78cd5fc3f2b5dbe67431f5f5de5b4 SHA512 530fe718e2d52acc27af670d7e44703b34fea33d15fcda3bd1fd4c5702794647576df8a329a11439f0eeca52e75390548a5417776add7b5ab3f09bb0eb85ac11
diff --git a/media-video/ushare/files/04_all_ushare_upnp_build_fix.patch b/media-video/ushare/files/04_all_ushare_upnp_build_fix.patch
deleted file mode 100644
index c3ec37a324c5..000000000000
--- a/media-video/ushare/files/04_all_ushare_upnp_build_fix.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-diff -wbBur ushare-1.1a/src/http.c ushare-1.1a.my/src/http.c
---- ushare-1.1a/src/http.c 2007-12-09 13:03:36.000000000 +0000
-+++ ushare-1.1a.my/src/http.c 2010-10-29 11:13:07.000000000 +0000
-@@ -77,8 +77,7 @@
- info->content_type = ixmlCloneDOMString (content_type);
- }
-
--static int
--http_get_info (const char *filename, struct File_Info *info)
-+int http_get_info (const char *filename, struct File_Info *info)
- {
- extern struct ushare_t *ut;
- struct upnp_entry_t *entry = NULL;
-@@ -197,8 +196,7 @@
- return ((UpnpWebFileHandle) file);
- }
-
--static UpnpWebFileHandle
--http_open (const char *filename, enum UpnpOpenFileMode mode)
-+UpnpWebFileHandle http_open (const char *filename, enum UpnpOpenFileMode mode)
- {
- extern struct ushare_t *ut;
- struct upnp_entry_t *entry = NULL;
-@@ -251,8 +249,7 @@
- return ((UpnpWebFileHandle) file);
- }
-
--static int
--http_read (UpnpWebFileHandle fh, char *buf, size_t buflen)
-+int http_read (UpnpWebFileHandle fh, char *buf, size_t buflen)
- {
- struct web_file_t *file = (struct web_file_t *) fh;
- ssize_t len = -1;
-@@ -286,8 +283,7 @@
- return len;
- }
-
--static int
--http_write (UpnpWebFileHandle fh __attribute__((unused)),
-+int http_write (UpnpWebFileHandle fh __attribute__((unused)),
- char *buf __attribute__((unused)),
- size_t buflen __attribute__((unused)))
- {
-@@ -296,8 +292,7 @@
- return 0;
- }
-
--static int
--http_seek (UpnpWebFileHandle fh, off_t offset, int origin)
-+int http_seek (UpnpWebFileHandle fh, off_t offset, int origin)
- {
- struct web_file_t *file = (struct web_file_t *) fh;
- off_t newpos = -1;
-@@ -371,8 +366,7 @@
- return 0;
- }
-
--static int
--http_close (UpnpWebFileHandle fh)
-+int http_close (UpnpWebFileHandle fh)
- {
- struct web_file_t *file = (struct web_file_t *) fh;
-
-@@ -402,13 +396,3 @@
-
- return 0;
- }
--
--struct UpnpVirtualDirCallbacks virtual_dir_callbacks =
-- {
-- http_get_info,
-- http_open,
-- http_read,
-- http_write,
-- http_seek,
-- http_close
-- };
-diff -wbBur ushare-1.1a/src/http.h ushare-1.1a.my/src/http.h
---- ushare-1.1a/src/http.h 2007-12-09 13:03:36.000000000 +0000
-+++ ushare-1.1a.my/src/http.h 2010-10-29 11:13:11.000000000 +0000
-@@ -25,6 +25,13 @@
- #include <upnp/upnp.h>
- #include <upnp/upnptools.h>
-
--struct UpnpVirtualDirCallbacks virtual_dir_callbacks;
-+int http_close (UpnpWebFileHandle fh);
-+int http_write (UpnpWebFileHandle fh __attribute__((unused)),
-+ char *buf __attribute__((unused)),
-+ size_t buflen __attribute__((unused)));
-+int http_seek (UpnpWebFileHandle fh, off_t offset, int origin);
-+UpnpWebFileHandle http_open (const char *filename, enum UpnpOpenFileMode mode);
-+int http_read (UpnpWebFileHandle fh, char *buf, size_t buflen);
-+int http_get_info (const char *filename, struct File_Info *info);
-
- #endif /* _HTTP_H_ */
-diff -wbBur ushare-1.1a/src/ushare.c ushare-1.1a.my/src/ushare.c
---- ushare-1.1a/src/ushare.c 2007-12-09 13:03:36.000000000 +0000
-+++ ushare-1.1a.my/src/ushare.c 2010-10-29 11:17:45.000000000 +0000
-@@ -188,7 +188,7 @@
- if (strcmp (request->DevUDN + 5, ut->udn))
- return;
-
-- ip = request->CtrlPtIPAddr.s_addr;
-+ ip = (*(struct sockaddr_in*)&request->CtrlPtIPAddr).sin_addr.s_addr;
- ip = ntohl (ip);
- sprintf (val, "%d.%d.%d.%d",
- (ip >> 24) & 0xFF, (ip >> 16) & 0xFF, (ip >> 8) & 0xFF, ip & 0xFF);
-@@ -348,7 +348,47 @@
-
- UpnpEnableWebserver (TRUE);
-
-- res = UpnpSetVirtualDirCallbacks (&virtual_dir_callbacks);
-+ res = UpnpVirtualDir_set_WriteCallback(http_write);
-+ if (res != UPNP_E_SUCCESS)
-+ {
-+ log_error (_("Cannot set virtual directory callbacks\n"));
-+ free (description);
-+ return -1;
-+ }
-+
-+ res = UpnpVirtualDir_set_GetInfoCallback(http_get_info);
-+ if (res != UPNP_E_SUCCESS)
-+ {
-+ log_error (_("Cannot set virtual directory callbacks\n"));
-+ free (description);
-+ return -1;
-+ }
-+
-+ res = UpnpVirtualDir_set_ReadCallback(http_read);
-+ if (res != UPNP_E_SUCCESS)
-+ {
-+ log_error (_("Cannot set virtual directory callbacks\n"));
-+ free (description);
-+ return -1;
-+ }
-+
-+ res = UpnpVirtualDir_set_OpenCallback(http_open);
-+ if (res != UPNP_E_SUCCESS)
-+ {
-+ log_error (_("Cannot set virtual directory callbacks\n"));
-+ free (description);
-+ return -1;
-+ }
-+
-+ res = UpnpVirtualDir_set_SeekCallback(http_seek);
-+ if (res != UPNP_E_SUCCESS)
-+ {
-+ log_error (_("Cannot set virtual directory callbacks\n"));
-+ free (description);
-+ return -1;
-+ }
-+
-+ res = UpnpVirtualDir_set_CloseCallback(http_close);
- if (res != UPNP_E_SUCCESS)
- {
- log_error (_("Cannot set virtual directory callbacks\n"));
diff --git a/media-video/ushare/files/05_all_missing_headers.patch b/media-video/ushare/files/05_all_missing_headers.patch
deleted file mode 100644
index 0d2f0e8faff9..000000000000
--- a/media-video/ushare/files/05_all_missing_headers.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -uNr ushare-1.1a.a/src/cds.c ushare-1.1a.b/src/cds.c
---- ushare-1.1a.a/src/cds.c 2007-12-09 08:03:36.000000000 -0500
-+++ ushare-1.1a.b/src/cds.c 2012-05-27 11:28:42.000000000 -0400
-@@ -19,7 +19,9 @@
- * Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
- */
-
-+#include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <upnp/upnp.h>
- #include <upnp/upnptools.h>
-
-diff -uNr ushare-1.1a.a/src/cms.c ushare-1.1a.b/src/cms.c
---- ushare-1.1a.a/src/cms.c 2007-12-09 08:03:36.000000000 -0500
-+++ ushare-1.1a.b/src/cms.c 2012-05-27 11:25:03.000000000 -0400
-@@ -20,6 +20,7 @@
- */
-
- #include <stdlib.h>
-+#include <string.h>
- #include <upnp/upnp.h>
- #include <upnp/upnptools.h>
-
-diff -uNr ushare-1.1a.a/src/http.c ushare-1.1a.b/src/http.c
---- ushare-1.1a.a/src/http.c 2012-05-27 11:23:32.000000000 -0400
-+++ ushare-1.1a.b/src/http.c 2012-05-27 11:25:13.000000000 -0400
-@@ -25,6 +25,7 @@
- #include <errno.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <unistd.h>
- #include <errno.h>
-
-diff -uNr ushare-1.1a.a/src/presentation.c ushare-1.1a.b/src/presentation.c
---- ushare-1.1a.a/src/presentation.c 2007-12-09 08:03:36.000000000 -0500
-+++ ushare-1.1a.b/src/presentation.c 2012-05-27 11:30:08.000000000 -0400
-@@ -18,7 +18,9 @@
- * Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
- */
-
-+#include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
-
- #if HAVE_LANGINFO_CODESET
- # include <langinfo.h>
-diff -uNr ushare-1.1a.a/src/services.c ushare-1.1a.b/src/services.c
---- ushare-1.1a.a/src/services.c 2007-12-09 08:03:36.000000000 -0500
-+++ ushare-1.1a.b/src/services.c 2012-05-27 11:25:26.000000000 -0400
-@@ -20,6 +20,7 @@
- */
-
- #include <stdlib.h>
-+#include <string.h>
- #include <upnp/upnp.h>
- #include <upnp/upnptools.h>
-
diff --git a/media-video/ushare/files/06_all_ushare_disable_sysconf.patch b/media-video/ushare/files/06_all_ushare_disable_sysconf.patch
deleted file mode 100644
index c3adf8e54287..000000000000
--- a/media-video/ushare/files/06_all_ushare_disable_sysconf.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Do not try to parse the default configuration file as everyting
-should be handled by the /etc/conf.d/ushare file in Gentoo
-Index: ushare-1.1a/src/ushare.c
-===================================================================
---- ushare-1.1a.orig/src/ushare.c
-+++ ushare-1.1a/src/ushare.c
-@@ -813,13 +813,6 @@ main (int argc, char **argv)
- return EXIT_SUCCESS;
- }
-
-- if (parse_config_file (ut) < 0)
-- {
-- /* fprintf here, because syslog not yet ready */
-- fprintf (stderr, _("Warning: can't parse file \"%s\".\n"),
-- ut->cfg_file ? ut->cfg_file : SYSCONFDIR "/" USHARE_CONFIG_FILE);
-- }
--
- if (ut->xbox360)
- {
- char *name;
diff --git a/media-video/ushare/files/08_all_gcc5.patch b/media-video/ushare/files/08_all_gcc5.patch
deleted file mode 100644
index d76f8771f5d9..000000000000
--- a/media-video/ushare/files/08_all_gcc5.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Various gcc-5 fixes
-
-https://gcc.gnu.org/gcc-5/porting_to.html
-
-Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
-Index: ushare-1.1a/src/trace.h
-===================================================================
---- ushare-1.1a.orig/src/trace.h
-+++ ushare-1.1a/src/trace.h
-@@ -29,7 +29,7 @@ typedef enum {
-
- void print_log (log_level level, const char *format, ...)
- __attribute__ ((format (printf, 2, 3)));
--inline void start_log (void);
-+extern inline void start_log (void);
-
- /* log_info
- * Normal print, to replace printf
-Index: ushare-1.1a/src/ushare.h
-===================================================================
---- ushare-1.1a.orig/src/ushare.h
-+++ ushare-1.1a/src/ushare.h
-@@ -127,6 +127,6 @@ struct action_event_t {
- struct service_t *service;
- };
-
--inline void display_headers (void);
-+extern inline void display_headers (void);
-
- #endif /* _USHARE_H_ */
-Index: ushare-1.1a/src/ushare.c
-===================================================================
---- ushare-1.1a.orig/src/ushare.c
-+++ ushare-1.1a/src/ushare.c
-@@ -49,6 +49,10 @@
- #include <ifaddrs.h>
- #endif
-
-+#ifdef HAVE_LOCALE_H
-+#include <locale.h>
-+#endif
-+
- #if (defined(__unix__) || defined(unix)) && !defined(USG)
- #include <sys/param.h>
- #endif
diff --git a/media-video/ushare/files/ushare.init.d b/media-video/ushare/files/ushare.init.d
deleted file mode 100644
index c1d94b6a9c98..000000000000
--- a/media-video/ushare/files/ushare.init.d
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting uShare"
-
- # Sanity check to avoid ushare failling on booting with no
- # shared dirs
- if [[ -z "${USHARE_DIRS}" ]] ; then
- eerror "Please set shared dirs in /etc/conf.d/ushare"
- return 1
- fi
-
- if [[ -z "${USHARE_PORT}" ]] ; then
- einfo "${USHARE_NAME} runs on a dynamic port"
- local ushare_port=
- else
- local ushare_port="--port ${USHARE_PORT}"
- einfo "${USHARE_NAME} using port ${USHARE_PORT}"
- fi
-
- if [[ "${USHARE_TELNET}" == "yes" ]] ; then
- local ushare_telnet=
- else
- local ushare_telnet="--no-telnet"
- fi
-
- if [[ -z "${ushare_telnet}" ]] ; then
- if [[ -z "${USHARE_TELNET_PORT}" ]] ; then
- local ushare_telnet_port=
- einfo "${USHARE_NAME} runs telnet on the default port"
- else
- local ushare_telnet_port="--telnet-port ${USHARE_TELNET_PORT}"
- einfo "${USHARE_NAME} runs telnet on port ${USHARE_TELNET_PORT}"
- fi
- else
- local ushare_telnet_port=
- fi
-
- if [[ "${USHARE_WEB}" == "yes" ]] ; then
- local ushare_web=
- else
- local ushare_web="--no-web"
- fi
-
- if [[ "${USHARE_XBOX}" == "yes" ]] ; then
- local ushare_xbox="--xbox"
- else
- local ushare_xbox=
- fi
-
- if [[ "${USHARE_DLNA}" == "yes" ]] ; then
- local ushare_dlna="--dlna"
- else
- local ushare_dlna=
- fi
-
- start-stop-daemon --start --quiet -u ${USHARE_USER:-root} \
- --exec /usr/bin/ushare -- -D -i ${USHARE_IFACE} \
- -n ${USHARE_NAME} ${USHARE_OPTS} ${USHARE_DIRS} \
- ${ushare_port} \
- ${ushare_telnet} ${ushare_telnet_port} \
- ${ushare_web} \
- ${ushare_xbox} \
- ${ushare_dlna}
- eend $?
-}
-
-stop() {
- ebegin "Stopping uShare"
- start-stop-daemon --stop --quiet --exec /usr/bin/ushare
- eend $?
-}
diff --git a/media-video/ushare/ushare-1.1a-r9.ebuild b/media-video/ushare/ushare-1.1a-r9.ebuild
deleted file mode 100644
index 263068d6c15f..000000000000
--- a/media-video/ushare/ushare-1.1a-r9.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib readme.gentoo toolchain-funcs user systemd
-
-DESCRIPTION="uShare is a UPnP (TM) A/V & DLNA Media Server"
-HOMEPAGE="https://ushare.geexbox.org/"
-SRC_URI="https://ushare.geexbox.org/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="nls"
-
-RDEPEND="=net-libs/libupnp-1.6*:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- EPATCH_EXCLUDE="06_all_ushare_disable_sysconf.patch"
- EPATCH_SOURCE="${FILESDIR}" EPATCH_SUFFIX="patch" \
- EPATCH_OPTS="-p1" epatch
-
- DOC_CONTENTS="Please edit /etc/ushare.conf to set the shared directories
- and other important settings. Check system log if ushare is
- not booting."
-}
-
-src_configure() {
- local myconf
- myconf="--prefix=/usr --sysconfdir=/etc --disable-strip --disable-dlna"
- # nls can only be disabled, on by default.
- use nls || myconf="${myconf} --disable-nls"
-
- # I can't use econf
- # --host is not implemented in ./configure file
- tc-export CC CXX
-
- ./configure ${myconf} || die "./configure failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- doman src/ushare.1
- newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
- newinitd "${FILESDIR}"/${PN}.init.d.ng ${PN}
- dodoc NEWS README TODO THANKS AUTHORS
- systemd_dounit "${FILESDIR}"/${PN}.service
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- enewuser ushare
- readme.gentoo_print_elog
- elog
- elog "The config file has been moved to /etc/ushare.conf"
- elog "Please migrate your settings from /etc/conf.d/ushare"
- elog "to /etc/ushare.conf in order to use the ushare init script"
- elog "and systemd unit service."
- elog
-}