summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-03-11 16:13:37 +0800
committerIan Delaney <idella4@gentoo.org>2016-03-11 16:38:16 +0800
commit11a636f584fb807b01741c69d7129ce61fcf76f1 (patch)
tree4724b460a5a4a87a92386905a62a451c1c002221 /media-video
parentapp-emulation/docker-swarm: version bump to 1.1.3 (diff)
downloadgentoo-11a636f584fb807b01741c69d7129ce61fcf76f1.tar.gz
gentoo-11a636f584fb807b01741c69d7129ce61fcf76f1.tar.bz2
gentoo-11a636f584fb807b01741c69d7129ce61fcf76f1.zip
media-video/vlc: update the live ebuild
Add IUSE gstreamer, rm IUSE macosx-dialog-provider, add dep media-libs/gst-plugins-base set behind IUSE gstreamer, take out call to epatch_user, patch to live ebuild submitted by attachment in the gentoo bug Gentoo bug: #Bug 571568 Package-Manager: portage-2.2.26
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/vlc-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 1ebdcad75a3a..0ad493800418 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
SCM=""
if [ "${PV%9999}" != "${PV}" ] ; then
@@ -41,10 +41,10 @@ fi
IUSE="a52 aalib alsa altivec +audioqueue +avcodec
+avformat bidi bluray cddb chromaprint chromecast dbus dc1394 debug
directfb directx dts dvb +dvbpsi dvd dxva2 elibc_glibc +encode faad fdk
- fluidsynth +ffmpeg flac fontconfig +gcrypt gme gnutls httpd
+ fluidsynth +ffmpeg flac fontconfig +gcrypt gme gnutls gstreamer httpd
ieee1394 jack jpeg kate kde libass libav libcaca libnotify
+libsamplerate libtiger linsys libtar lirc live lua
- macosx-dialog-provider macosx-eyetv macosx-notifications macosx-quartztext macosx-qtkit
+ macosx-eyetv macosx-notifications macosx-quartztext macosx-qtkit
matroska media-library cpu_flags_x86_mmx modplug mp3 mpeg mtp musepack
ncurses neon ogg omxil opencv opengl optimisememory opus
png +postproc projectm pulseaudio +qt4 qt5 rdp rtsp run-as-root samba
@@ -89,6 +89,7 @@ RDEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.2.0:0= )
gme? ( media-libs/game-music-emu:0 )
gnutls? ( >=net-libs/gnutls-3.0.20:0 )
+ gstreamer? ( >=media-libs/gst-plugins-base-1.4.5:1.0 )
ieee1394? ( >=sys-libs/libraw1394-2.0.1:0 >=sys-libs/libavc1394-0.5.3:0 )
jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1:0 )
jpeg? ( virtual/jpeg:0 )
@@ -249,6 +250,8 @@ src_prepare() {
# We are not in a real git checkout due to the absence of a .git directory.
touch src/revision.txt || die
+ default
+
# Fix build system mistake.
epatch "${FILESDIR}"/${PN}-2.1.0-fix-libtremor-libs.patch
@@ -263,8 +266,6 @@ src_prepare() {
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
fi
- epatch_user
-
eautoreconf
# Disable automatic running of tests.
@@ -343,6 +344,7 @@ src_configure() {
$(use_enable gcrypt libgcrypt) \
$(use_enable gme) \
$(use_enable gnutls) \
+ $(use_enable gstreamer gst-decode) \
$(use_enable httpd) \
$(use_enable ieee1394 dv1394) \
$(use_enable jack) \
@@ -359,7 +361,6 @@ src_configure() {
$(use_enable lirc) \
$(use_enable live live555) \
$(use_enable lua) \
- $(use_enable macosx-dialog-provider) \
$(use_enable macosx-eyetv) \
$(use_enable macosx-notifications osx-notifications) \
$(use_enable macosx-qtkit) \
@@ -422,7 +423,7 @@ src_configure() {
$(use_enable xml libxml2) \
$(use_enable xv xvideo) \
$(use_enable x265) \
- $(use_enable zeroconf bonjour) \
+ $(use_enable zeroconf avahi) \
$(use_enable zvbi) $(use_enable !zvbi telx) \
--disable-asdcp \
--disable-coverage \