summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-07-14 20:35:38 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-07-14 20:36:11 -0400
commit98090576a1567781ee72123a4fde6d4c30cbb5ef (patch)
tree581c6777745d772276a7a29363512c4af1c47dfe /media-video
parentpackage.mask: add totem 3.32.1 for testing (diff)
downloadgentoo-98090576a1567781ee72123a4fde6d4c30cbb5ef.tar.gz
gentoo-98090576a1567781ee72123a4fde6d4c30cbb5ef.tar.bz2
gentoo-98090576a1567781ee72123a4fde6d4c30cbb5ef.zip
media-video/totem: 3.30.0 → 3.32.1
update plugin patch, some of the plugins had been removed. vala has been removed too Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/totem/Manifest1
-rw-r--r--media-video/totem/files/3.32.1-control-plugins.patch124
-rw-r--r--media-video/totem/totem-3.32.1.ebuild127
3 files changed, 252 insertions, 0 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 7d1227e178cd..78d9ede9162e 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1 +1,2 @@
DIST totem-3.30.0.tar.xz 3275852 BLAKE2B 9a5f97229a8aa6f7665c6d3e79dff48cfcce3caeab69510361ef3e9e1a107f7a56c66a5ae89ba3ae0a77d4b0ae8a16ac1f61e77278c82bf768e50009420110d0 SHA512 9d2e0a9e89358eea03404afd9353d18fa23afee7a34612912411ef10d4fb0b26ee02db002e6f8e05f68a333202d419f1e1a35188da23f87189e3093dac655742
+DIST totem-3.32.1.tar.xz 2154892 BLAKE2B ff9ec2facbada0f72ae82bbb35d03e82b574be02d7c1f1d4c4dd3262e2b302d3430ba953cd9f4b4e1d1e5151f9b5987986c7ea387a7f5d6667eb931d41805659 SHA512 31a3e3ac7628b992da3cf99570d013eb8b972e28465db30a9ec68291f8e19ab498d89df6275228367a7e3e43121bcebda2654f2b0461a9d1d561cf46e0029f67
diff --git a/media-video/totem/files/3.32.1-control-plugins.patch b/media-video/totem/files/3.32.1-control-plugins.patch
new file mode 100644
index 000000000000..2abcd75bac59
--- /dev/null
+++ b/media-video/totem/files/3.32.1-control-plugins.patch
@@ -0,0 +1,124 @@
+From 4944c498633f913c07a2680563a64d47c233630d Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhan@gentoo.org>
+Date: Sun, 14 Jul 2019 20:18:45 -0400
+Subject: [PATCH] 3.32.1 control plugins
+
+update From 5bdfac8a4a34e3edec05439fa3cd5544e0515e24 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Sun, 10 Jun 2018 10:09:16 +0200
+Subject: [PATCH] Allow full control over which plugins are built
+---
+ meson_options.txt | 24 +++++++++++++++++++++++-
+ src/plugins/meson.build | 30 +++++++++++++++++++++---------
+ 2 files changed, 44 insertions(+), 10 deletions(-)
+
+diff --git a/meson_options.txt b/meson_options.txt
+index e1c5909..085380e 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,5 +1,27 @@
+ option('enable-easy-codec-installation', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto', description: 'Whether to enable easy codec installation support for GStreamer')
+ option('enable-python', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto', description: 'Enable python support')
+-option('with-plugins', type: 'combo', choices: ['all', 'none', 'auto'], value: 'auto', description: 'Which Totem plugins to compile (default: auto; "all", "none" and "auto" are valid)')
++option('with-plugins', type: 'array', choices: [
++ 'all',
++ 'auto',
++ 'apple-trailers',
++ 'autoload-subtitles',
++ 'brasero-disc-recorder',
++ 'dbusservice',
++ 'im-status',
++ 'lirc',
++ 'media-player-keys',
++ 'opensubtitles',
++ 'properties',
++ 'pythonconsole',
++ 'recent',
++ 'rotation',
++ 'samplepython',
++ 'save-file',
++ 'screensaver',
++ 'screenshot',
++ 'skipto',
++ 'variable-rate',
++ 'vimeo',
++], value: ['auto'], description: 'Which Totem plugins to compile (default: auto; "all", "none" and "auto" are valid)')
+ option('enable-gtk-doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
+ option('enable-introspection', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto', description: 'Enable GObject Introspection (depends on GObject)')
+diff --git a/src/plugins/meson.build b/src/plugins/meson.build
+index 552cc22..cddda3f 100644
+--- a/src/plugins/meson.build
++++ b/src/plugins/meson.build
+@@ -37,8 +37,8 @@ allowed_plugins = [
+ plugins = []
+
+ plugins_option = get_option('with-plugins')
+-if plugins_option != 'none'
+- plugins += [
++if plugins_option.length() > 0
++ foreach plugin: [
+ 'apple-trailers',
+ 'autoload-subtitles',
+ 'im-status',
+@@ -53,15 +53,22 @@ if plugins_option != 'none'
+ 'variable-rate',
+ 'vimeo'
+ ]
++ if plugins_option.contains('all') or plugins_option.contains('auto') or plugins_option.contains(plugin)
++ plugins += plugin
++ endif
++ endforeach
++
++ if plugins_option.contains('all') or plugins_option.contains('auto') or plugins_option.contains('lirc')
++ lirc_dep = dependency('lirc', required: false)
++ else
++ lirc_dep = disabler()
++ endif
+
+- plugin_error = (plugins_option == 'all')
+-
+- lirc_dep = dependency('lirc', required: false)
+ if lirc_dep.found() and cc.has_function('lirc_init', dependencies: lirc_dep) and cc.has_header('lirc/lirc_client.h')
+ plugins += 'lirc'
+ else
+ str = 'you need lirc_client installed for the lirc plugin'
+- if plugin_error
++ if plugins_option.contains('all') or plugins_option.contains('lirc')
+ error(str)
+ endif
+ message(str)
+@@ -70,23 +77,28 @@ if plugins_option != 'none'
+ libxml_req_version = '>= 2.6.0'
+ libxml_dep = dependency('libxml-2.0', version: libxml_req_version, required: false)
+ gtk_x11_dep = dependency('gtk+-x11-3.0', version: gtk_req_version, required: false)
+- if libxml_dep.found() and gtk_x11_dep.found()
++ if libxml_dep.found() and gtk_x11_dep.found() and (plugins_option.contains('all') or plugins_option.contains('auto') or plugins_option.contains('brasero-disc-recorder'))
+ plugins += 'brasero-disc-recorder'
+ else
+ str = 'you need libxml-2.0 ' + libxml_req_version + ' and gtk+-x11-3.0 to use the brasero-disc-recorder plugin'
+- if plugin_error
++ if plugins_option.contains('all') or plugins_option.contains('brasero-disc-recorder')
+ error(str)
+ endif
+ message(str)
+ endif
+
+ if have_python
+- plugins += [
++ foreach plugin: [
+ 'dbusservice',
+ 'opensubtitles',
+ 'pythonconsole',
+ 'samplepython'
+ ]
++ if plugins_option.contains('all') or plugins_option.contains('auto') or plugins_option.contains(plugin)
++ plugins += plugin
++ endif
++ endforeach
++
+ endif
+ endif
+
+--
+2.22.0
+
diff --git a/media-video/totem/totem-3.32.1.ebuild b/media-video/totem/totem-3.32.1.ebuild
new file mode 100644
index 000000000000..1046a2c110e9
--- /dev/null
+++ b/media-video/totem/totem-3.32.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_5,3_6} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome.org gnome2-utils meson xdg python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="cdr gtk-doc +introspection lirc nautilus +python test"
+# see bug #359379
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# FIXME:
+# Runtime dependency on gnome-session-2.91
+COMMON_DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ >=x11-libs/gtk+-3.19.4:3[X,introspection?]
+ >=media-libs/gstreamer-1.6.0:1.0
+ >=media-libs/gst-plugins-base-1.6.0:1.0[X,pango]
+ >=media-libs/gst-plugins-good-1.6.0:1.0
+ >=media-libs/grilo-0.3.0:0.3[playlist]
+ >=dev-libs/libpeas-1.1.0[gtk]
+ >=dev-libs/totem-pl-parser-3.10.1:0=[introspection?]
+ >=media-libs/clutter-1.17.3:1.0[gtk]
+ >=media-libs/clutter-gst-2.99.2:3.0
+ >=media-libs/clutter-gtk-1.8.1:1.0
+ gnome-base/gnome-desktop:3=
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/libX11
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+
+ cdr? ( >=dev-libs/libxml2-2.6:2 )
+ lirc? ( app-misc/lirc )
+ nautilus? ( >=gnome-base/nautilus-2.91.3 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/grilo-plugins:0.3
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ x11-themes/adwaita-icon-theme
+ python? (
+ >=dev-libs/libpeas-1.1.0[python,${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ app-text/docbook-xml-dtd:4.5
+ gtk-doc? ( >=dev-util/gtk-doc-1.14 )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+# perl for pod2man
+# docbook-xml-dtd is needed for user doc
+# Prevent dev-python/pylint dep, bug #482538
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-control-plugins.patch # Do not force all plugins
+ "${FILESDIR}"/3.26-gst-inspect-sandbox.patch # Allow disabling calls to gst-inspect (sandbox issue)
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+}
+
+src_configure() {
+ # Disabled: sample-python, zeitgeist-dp
+ # brasero-disc-recorder and gromit require gtk+[X], but totem itself does
+ # for now still too, so no point in optionality based on that yet.
+ local plugins="apple-trailers,autoload-subtitles"
+ plugins+=",im-status,media-player-keys"
+ plugins+=",properties,recent,screensaver,screenshot"
+ plugins+=",skipto,variable-rate,vimeo,rotation"
+ use cdr && plugins+=",brasero-disc-recorder"
+ use lirc && plugins+=",lirc"
+ use nautilus && plugins+=",save-file"
+ use python && plugins+=",dbusservice,pythonconsole,opensubtitles"
+
+ local emesonargs=(
+ -Denable-easy-codec-installation=yes
+ -Denable-python=$(usex python yes no)
+ -Dwith-plugins=${plugins}
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Denable-introspection=$(usex introspection yes no)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python ; then
+ python_optimize "${ED}"usr/$(get_libdir)/totem/plugins/
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}