summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2016-03-06 10:50:30 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2016-03-06 10:57:45 +0000
commitac4ae84779cbc73d81ac4e3a289a75ea62698f41 (patch)
treea99f7ff28db7f5b3ce4f33ebe51bf1c9c736b5ae /media-video
parentkde-base/kdelibs: x86 stable wrt bug #569742 (diff)
downloadgentoo-ac4ae84779cbc73d81ac4e3a289a75ea62698f41.tar.gz
gentoo-ac4ae84779cbc73d81ac4e3a289a75ea62698f41.tar.bz2
gentoo-ac4ae84779cbc73d81ac4e3a289a75ea62698f41.zip
media-video/ushare: Drop libdlna support. Bug #571078
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ushare/ushare-1.1a-r7.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-video/ushare/ushare-1.1a-r7.ebuild b/media-video/ushare/ushare-1.1a-r7.ebuild
new file mode 100644
index 000000000000..43b638f6b202
--- /dev/null
+++ b/media-video/ushare/ushare-1.1a-r7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib readme.gentoo toolchain-funcs user systemd
+
+DESCRIPTION="uShare is a UPnP (TM) A/V & DLNA Media Server"
+HOMEPAGE="http://ushare.geexbox.org/"
+SRC_URI="http://ushare.geexbox.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=net-libs/libupnp-1.6.14"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ EPATCH_EXCLUDE="06_all_ushare_disable_sysconf.patch"
+ EPATCH_SOURCE="${FILESDIR}" EPATCH_SUFFIX="patch" \
+ EPATCH_OPTS="-p1" epatch
+
+ DOC_CONTENTS="Please edit /etc/ushare.conf to set the shared directories
+ and other important settings. Check system log if ushare is
+ not booting."
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=/usr --sysconfdir=/etc --disable-strip"
+ # nls can only be disabled, on by default.
+ use nls || myconf="${myconf} --disable-nls"
+
+ # I can't use econf
+ # --host is not implemented in ./configure file
+ tc-export CC CXX
+
+ ./configure ${myconf} || die "./configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman src/ushare.1
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.d.ng ${PN}
+ dodoc NEWS README TODO THANKS AUTHORS
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ enewuser ushare
+ readme.gentoo_print_elog
+ elog
+ elog "The config file has been moved to /etc/ushare.conf"
+ elog "Please migrate your settings from /etc/conf.d/ushare"
+ elog "to /etc/ushare.conf in order to use the ushare init script"
+ elog "and systemd unit service."
+ elog
+}