summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-20 10:25:29 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-20 10:25:29 -0800
commitd668f0e3fcf4db6a21ee016c2c9962567043825e (patch)
tree288a4481f1db5bd9412f3f047ced6a1de09a8d5a /net-dns/dnsmasq
parentwww-apps/postfixadmin: bugfix bump to 3.3.4 (diff)
downloadgentoo-d668f0e3fcf4db6a21ee016c2c9962567043825e.tar.gz
gentoo-d668f0e3fcf4db6a21ee016c2c9962567043825e.tar.bz2
gentoo-d668f0e3fcf4db6a21ee016c2c9962567043825e.zip
net-dns/dnsmasq: Revbumps, fix USE=dnssec (bug #766264)
Closes: https://bugs.gentoo.org/766264 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.83-r1.ebuild (renamed from net-dns/dnsmasq/dnsmasq-2.83.ebuild)8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.83-r101.ebuild (renamed from net-dns/dnsmasq/dnsmasq-2.83-r100.ebuild)8
2 files changed, 10 insertions, 6 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.83.ebuild b/net-dns/dnsmasq/dnsmasq-2.83-r1.ebuild
index 374fe7bd87e8..99cb4bc13be5 100644
--- a/net-dns/dnsmasq/dnsmasq-2.83.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.83-r1.ebuild
@@ -53,8 +53,10 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="
dhcp-tools? ( dhcp )
+ dnssec? ( !nettlehash )
lua? ( script )
- libidn2? ( idn )"
+ libidn2? ( idn )
+"
use_have() {
local no_only
@@ -111,8 +113,8 @@ src_configure() {
$(use_have lua luascript)
$(use_have -n script)
$(use_have -n tftp)
- $(use_have -n dnssec)
- $(use_have -n nettlehash)
+ $(use_have dnssec)
+ $(use_have nettlehash)
$(use_have static dnssec_static)
$(use_have -n dumpfile)
)
diff --git a/net-dns/dnsmasq/dnsmasq-2.83-r100.ebuild b/net-dns/dnsmasq/dnsmasq-2.83-r101.ebuild
index 71ebbbf4e3e7..17dff7c71fc1 100644
--- a/net-dns/dnsmasq/dnsmasq-2.83-r100.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.83-r101.ebuild
@@ -55,11 +55,13 @@ RDEPEND="${COMMON_DEPEND}
REQUIRED_USE="
dhcp-tools? ( dhcp )
+ dnssec? ( !nettlehash )
lua? (
script
${LUA_REQUIRED_USE}
)
- libidn2? ( idn )"
+ libidn2? ( idn )
+"
use_have() {
local no_only
@@ -116,8 +118,8 @@ src_configure() {
$(use_have lua luascript)
$(use_have -n script)
$(use_have -n tftp)
- $(use_have -n dnssec)
- $(use_have -n nettlehash)
+ $(use_have dnssec)
+ $(use_have nettlehash)
$(use_have static dnssec_static)
$(use_have -n dumpfile)
)