summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-09-07 12:52:09 +0200
committerSam James <sam@gentoo.org>2024-09-07 16:45:11 +0100
commit39a980e781b71e9119167c6fdf0c5051da87d406 (patch)
treeb461f425c8853ffeeb396d8e6fe6f9d2f3b0c00a /net-dns
parentapp-misc/broot: Stabilize 1.41.1 amd64, #939197 (diff)
downloadgentoo-39a980e781b71e9119167c6fdf0c5051da87d406.tar.gz
gentoo-39a980e781b71e9119167c6fdf0c5051da87d406.tar.bz2
gentoo-39a980e781b71e9119167c6fdf0c5051da87d406.zip
net-dns/doggo: new ebuild, add 1.0.4
dig/host now require a full bind installation, so doggo can act as standalone replacement. It has many nice features too. Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/38496 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/doggo/Manifest2
-rw-r--r--net-dns/doggo/doggo-1.0.4.ebuild33
-rw-r--r--net-dns/doggo/metadata.xml15
3 files changed, 50 insertions, 0 deletions
diff --git a/net-dns/doggo/Manifest b/net-dns/doggo/Manifest
new file mode 100644
index 000000000000..2a8d2a5373b5
--- /dev/null
+++ b/net-dns/doggo/Manifest
@@ -0,0 +1,2 @@
+DIST doggo-1.0.4-deps.tar.xz 11780788 BLAKE2B 3a79c3d3b7a9b34a6f7d5193774674e87ce9469233b20c770d1731c126ed972e7010b9b7964afed2f7e239bf32a92322026df0c1985f72c9dc1bddc7aa011ae6 SHA512 2de9a23d69feccb7cfa427a81163e3223cd322a6d3e4cce143e5863b95d469d0f7d15ba707fc946e7ff314c03396322a8b871c71f83527966ca7a194628f83ba
+DIST doggo-1.0.4.tar.gz 2436385 BLAKE2B adeb97fbe3ae6cf280d579a8ea5bb7790c79535f4df46041bd45aa0fa2add9f5d8bb228deb374787d1ecb3a3bc02bf9ed6545c74adb1a55262c63f1db347857e SHA512 10b59b5fa735ef42dc218a0b704292e4840b29880029f870e30fad77bc0d544bdb1d24630e3d0cc8be27542268f49c24f3ff4f0b72449195a2546d83b7942d2d
diff --git a/net-dns/doggo/doggo-1.0.4.ebuild b/net-dns/doggo/doggo-1.0.4.ebuild
new file mode 100644
index 000000000000..cb4e40048fc1
--- /dev/null
+++ b/net-dns/doggo/doggo-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="Command-line DNS Client for Humans"
+HOMEPAGE="https://github.com/mr-karan/doggo"
+
+SRC_URI="https://github.com/mr-karan/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://www.applied-asynchrony.com/distfiles/${P}-deps.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake build-cli VERSION=${PV}
+}
+
+src_install() {
+ newbin bin/${PN}.bin ${PN}
+
+ local comp
+ for comp in bash fish zsh; do
+ bin/${PN}.bin completions $comp > "${WORKDIR}"/${PN}.$comp || die
+ done
+
+ newbashcomp "${WORKDIR}"/${PN}.bash ${PN}
+ newfishcomp "${WORKDIR}"/${PN}.fish ${PN}.fish
+ newzshcomp "${WORKDIR}"/${PN}.zsh _${PN}
+}
diff --git a/net-dns/doggo/metadata.xml b/net-dns/doggo/metadata.xml
new file mode 100644
index 000000000000..b4febebbbc53
--- /dev/null
+++ b/net-dns/doggo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>holger@applied-asynchrony.com</email>
+ <name>Holger Hoffstätte</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mr-karan/doggo</remote-id>
+ </upstream>
+</pkgmetadata>