summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libmm-qt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libmm-qt')
-rw-r--r--net-libs/libmm-qt/Manifest1
-rw-r--r--net-libs/libmm-qt/files/libmm-qt-1.0.1-cxxflags.patch19
-rw-r--r--net-libs/libmm-qt/libmm-qt-1.0.1-r1.ebuild32
-rw-r--r--net-libs/libmm-qt/metadata.xml5
4 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/libmm-qt/Manifest b/net-libs/libmm-qt/Manifest
new file mode 100644
index 000000000000..5301e9200b18
--- /dev/null
+++ b/net-libs/libmm-qt/Manifest
@@ -0,0 +1 @@
+DIST libmm-qt-1.0.1.tar.xz 69448 SHA256 0ad57815a904ddb2660a7327c0bda5da47a2a60ce57b2b12f4aaff99b174f74a SHA512 608f413510935639d226f59c8e5b125931077020ee8d7fd85d653add118dd98f605c33962462ba41c4702c8a254559d60dfd0b16a76be4cd7bcbf4c57b704dbe WHIRLPOOL 3c556bf8430badc8c166513111d11d1340255ba59d4c6ee4f0926cee209ca119c800b78fb7d248a29ad9cc27efb7e979c99d0e51950ee41271975ab195cd541b
diff --git a/net-libs/libmm-qt/files/libmm-qt-1.0.1-cxxflags.patch b/net-libs/libmm-qt/files/libmm-qt-1.0.1-cxxflags.patch
new file mode 100644
index 000000000000..c09af04fd258
--- /dev/null
+++ b/net-libs/libmm-qt/files/libmm-qt-1.0.1-cxxflags.patch
@@ -0,0 +1,19 @@
+commit 70697ac8327955a488d79aea1bfd6100f400377a
+Author: Lamarque V. Souza <lamarque@kde.org>
+Date: Sat May 24 14:21:30 2014 -0300
+
+ Respect external CMAKE_CXX_FLAGS values.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5bcf7e2..40ee9c0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,7 +20,7 @@ add_definitions(${QT_DEFINITIONS})
+ include(CheckCXXCompilerFlag)
+ check_cxx_compiler_flag("-Werror=return-type" HAVE_GCC_ERROR_RETURN_TYPE)
+ if (HAVE_GCC_ERROR_RETURN_TYPE)
+- set(CMAKE_CXX_FLAGS "-Werror=return-type")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=return-type")
+ endif()
+
+ include_directories(
diff --git a/net-libs/libmm-qt/libmm-qt-1.0.1-r1.ebuild b/net-libs/libmm-qt/libmm-qt-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..68425a9e3122
--- /dev/null
+++ b/net-libs/libmm-qt/libmm-qt-1.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ KEYWORDS="amd64 x86"
+ SRC_URI="mirror://kde/unstable/modemmanager-qt/${PV}/src/${P}.tar.xz"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Modemmanager bindings for Qt"
+HOMEPAGE="https://projects.kde.org/projects/extragear/libs/libmm-qt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ net-misc/mobile-broadband-provider-info
+ >=net-misc/networkmanager-0.9.8[modemmanager]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-cxxflags.patch" )
diff --git a/net-libs/libmm-qt/metadata.xml b/net-libs/libmm-qt/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/net-libs/libmm-qt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>