summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/librsync
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/librsync')
-rw-r--r--net-libs/librsync/Manifest1
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-format-security.patch20
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-getopt.patch17
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-huge-files.patch31
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch19
-rw-r--r--net-libs/librsync/librsync-0.9.7-r3.ebuild36
-rw-r--r--net-libs/librsync/metadata.xml10
7 files changed, 134 insertions, 0 deletions
diff --git a/net-libs/librsync/Manifest b/net-libs/librsync/Manifest
new file mode 100644
index 000000000000..f189840c93fb
--- /dev/null
+++ b/net-libs/librsync/Manifest
@@ -0,0 +1 @@
+DIST librsync-0.9.7.tar.gz 453802 SHA256 6633e4605662763a03bb6388529cbdfd3b11a9ec55b8845351c1bd9a92bc41d6 SHA512 339362fd01c94411849d3e4a6e95db1bef6cffa0475b1af49d73f11be0421a12d4c73ecbf1a272af01b2a21cec81b4a801c1f7d735e107d0242707fb4c45f9ef WHIRLPOOL 7cf5cc675c4bf4e041d9132f0a8311f83e827bfa7dd75180f3153cabeab41a94011e1a9b56e63a61dbe119444e2c24a39054986d97b686db99293ad9177b2bf7
diff --git a/net-libs/librsync/files/librsync-0.9.7-format-security.patch b/net-libs/librsync/files/librsync-0.9.7-format-security.patch
new file mode 100644
index 000000000000..e35980a4d7a0
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-format-security.patch
@@ -0,0 +1,20 @@
+Description: Always use a format string in printf
+ Fix the warning: buf.c:216:9: error: format not a string literal and no
+ format arguments [-Werror=format-security]
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Forwarded: no
+Last-Update: 2012-02-05
+
+diff --git a/buf.c b/buf.c
+index 7f4e7a0..3a83f2b 100644
+--- a/buf.c
++++ b/buf.c
+@@ -213,7 +213,7 @@ rs_result rs_file_copy_cb(void *arg, rs_long_t pos, size_t *len, void **buf)
+
+ got = fread(*buf, 1, *len, f);
+ if (got == -1) {
+- rs_error(strerror(errno));
++ rs_error("%s", strerror(errno));
+ return RS_IO_ERROR;
+ } else if (got == 0) {
+ rs_error("unexpected eof on fd%d", fileno(f));
diff --git a/net-libs/librsync/files/librsync-0.9.7-getopt.patch b/net-libs/librsync/files/librsync-0.9.7-getopt.patch
new file mode 100644
index 000000000000..0859089b970a
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-getopt.patch
@@ -0,0 +1,17 @@
+Patch by Daniel Baumann <daniel@debian.org> for librsync >= 0.9.7, which makes
+rdiff aware of -i and -z getopt options mentioned in --help output. For further
+information, please have a look to Debian bug ID #435894.
+
+--- librsync-0.9.7/rdiff.c 2004-09-17 23:35:50.000000000 +0200
++++ librsync-0.9.7/rdiff.c.getopt 2008-12-20 13:45:58.000000000 +0100
+@@ -97,8 +97,8 @@
+ { "sum-size", 'S', POPT_ARG_INT, &strong_len },
+ { "statistics", 's', POPT_ARG_NONE, &show_stats },
+ { "stats", 0, POPT_ARG_NONE, &show_stats },
+- { "gzip", 0, POPT_ARG_NONE, 0, OPT_GZIP },
+- { "bzip2", 0, POPT_ARG_NONE, 0, OPT_BZIP2 },
++ { "gzip", 'z', POPT_ARG_NONE, 0, OPT_GZIP },
++ { "bzip2", 'i', POPT_ARG_NONE, 0, OPT_BZIP2 },
+ { "paranoia", 0, POPT_ARG_NONE, &rs_roll_paranoia },
+ { 0 }
+ };
diff --git a/net-libs/librsync/files/librsync-0.9.7-huge-files.patch b/net-libs/librsync/files/librsync-0.9.7-huge-files.patch
new file mode 100644
index 000000000000..fef08941a44f
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-huge-files.patch
@@ -0,0 +1,31 @@
+diff -urN librsync-0.9.7/mdfour.h librsync-0.9.7dev/mdfour.h
+--- librsync-0.9.7/mdfour.h 2004-02-07 18:17:57.000000000 -0500
++++ librsync-0.9.7dev/mdfour.h 2006-03-06 03:21:46.000000000 -0500
+@@ -24,7 +24,7 @@
+ #include "types.h"
+
+ struct rs_mdfour {
+- int A, B, C, D;
++ unsigned int A, B, C, D;
+ #if HAVE_UINT64
+ uint64_t totalN;
+ #else
+diff -urN librsync-0.9.7/patch.c librsync-0.9.7dev/patch.c
+--- librsync-0.9.7/patch.c 2004-09-17 17:35:50.000000000 -0400
++++ librsync-0.9.7dev/patch.c 2006-03-06 03:21:06.000000000 -0500
+@@ -214,12 +214,12 @@
+ void *buf, *ptr;
+ rs_buffers_t *buffs = job->stream;
+
+- len = job->basis_len;
+-
+ /* copy only as much as will fit in the output buffer, so that we
+ * don't have to block or store the input. */
+- if (len > buffs->avail_out)
++ if (job->basis_len > buffs->avail_out)
+ len = buffs->avail_out;
++ else
++ len = job->basis_len;
+
+ if (!len)
+ return RS_BLOCKED;
diff --git a/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch b/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch
new file mode 100644
index 000000000000..782597c8fe2b
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch
@@ -0,0 +1,19 @@
+Description: Fix -Wimplicit-function-declaration warning in the test suite
+ Fix the warning: isprefix.driver.c:43:5: warning: implicit declaration of
+ function ‘strcmp’ [-Wimplicit-function-declaration]
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Forwarded: no
+Last-Update: 2012-02-05
+
+diff --git a/testsuite/isprefix.driver.c b/testsuite/isprefix.driver.c
+index a9fd77b..df558c2 100644
+--- a/testsuite/isprefix.driver.c
++++ b/testsuite/isprefix.driver.c
+@@ -21,6 +21,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "isprefix.h"
+
diff --git a/net-libs/librsync/librsync-0.9.7-r3.ebuild b/net-libs/librsync/librsync-0.9.7-r3.ebuild
new file mode 100644
index 000000000000..82ae42a7cd6d
--- /dev/null
+++ b/net-libs/librsync/librsync-0.9.7-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Flexible remote checksum-based differencing"
+HOMEPAGE="http://librsync.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-huge-files.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-getopt.patch
+ "${FILESDIR}"/${P}-implicit-declaration.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
+ -i configure.ac || die
+
+ autotools-utils_src_prepare
+}
diff --git a/net-libs/librsync/metadata.xml b/net-libs/librsync/metadata.xml
new file mode 100644
index 000000000000..0453ebdcc2bf
--- /dev/null
+++ b/net-libs/librsync/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">librsync</remote-id>
+ </upstream>
+</pkgmetadata>