summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-09 03:06:17 +0100
committerSam James <sam@gentoo.org>2023-10-09 03:09:19 +0100
commit1fd1b5741a7c96cd73d8f8087f0da933aa6edfe7 (patch)
tree33ac091230ad7bccd193077401dc3d7a51b47395 /net-misc/dhcpcd-ui
parentsys-auth/sssd: Stabilize 2.9.1 x86, #915399 (diff)
downloadgentoo-1fd1b5741a7c96cd73d8f8087f0da933aa6edfe7.tar.gz
gentoo-1fd1b5741a7c96cd73d8f8087f0da933aa6edfe7.tar.bz2
gentoo-1fd1b5741a7c96cd73d8f8087f0da933aa6edfe7.zip
net-misc/dhcpcd-ui: add 0.7.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/dhcpcd-ui')
-rw-r--r--net-misc/dhcpcd-ui/Manifest1
-rw-r--r--net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild84
-rw-r--r--net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch13
3 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/dhcpcd-ui/Manifest b/net-misc/dhcpcd-ui/Manifest
index e8b0b7cd46dd..833a02dd0790 100644
--- a/net-misc/dhcpcd-ui/Manifest
+++ b/net-misc/dhcpcd-ui/Manifest
@@ -1 +1,2 @@
DIST dhcpcd-ui-0.7.8.tar.xz 135028 BLAKE2B f3e79bb00708e2ce2ebb93d917506bb0fb015071b415768c47979d7f2b5e35d6f22bf71a58c43989dedc6561f0a8be738824f06627d2fa0995e335d7ef1925cd SHA512 5f0d2c32c32fc141feca0ab43a531d9b4f45e071a8a1e3ee1923d6394a3e5d6322e6f7e607b91154af4cfee93d649164c7ed3b805731dfc242c3ac367ec156c4
+DIST dhcpcd-ui-0.7.9.tar.xz 104100 BLAKE2B 7e2bbbb9ad657deccc16296a0c7191f35fa15dbc84f1f8ac4f8ac5de4c56e5948da457398409527774ffc62e58659cac2dd37aa66842179f710db04a9791ab9e SHA512 fe0c9ff2f777e7b97438eb50507fce765b8e18b1a71883d76e9b6570a18e6f13414f8e64d8034f9c3352496775c283a0540e331ec449d6fbe48ddc8d64e14691
diff --git a/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild
new file mode 100644
index 000000000000..b29581f35d00
--- /dev/null
+++ b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils systemd toolchain-funcs xdg
+
+DESCRIPTION="Desktop notification and configuration for dhcpcd"
+HOMEPAGE="https://github.com/NetworkConfiguration/dhcpcd-ui https://roy.marples.name/projects/dhcpcd-ui/"
+SRC_URI="https://github.com/NetworkConfiguration/dhcpcd-ui/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk libnotify ncurses qt5"
+
+# Qt handles notifications separately, no need for libnotify there
+REQUIRED_USE="
+ libnotify? ( gtk )
+"
+
+BDEPEND="
+ media-gfx/cairosvg
+ virtual/libintl
+"
+DEPEND="
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ )
+ libnotify? ( x11-libs/libnotify )
+ ncurses? ( sys-libs/ncurses:= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/mesa
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-misc/dhcpcd-6.4.4
+"
+
+src_configure() {
+ local myeconfargs=(
+ --without-qt
+ --without-qt5
+ $(use_enable debug)
+ $(use_enable libnotify notification)
+ $(use_with gtk gtk 'gtk+-3.0')
+ $(use_with ncurses curses)
+ )
+
+ tc-export AR CC CXX
+
+ econf "${myeconfargs[@]}"
+
+ if use qt5 ; then
+ cd src/dhcpcd-qt || die
+ eqmake5 PREFIX="${EPREFIX}/usr" SYSCONFDIR="${EPREFIX}/etc"
+ fi
+}
+
+src_compile() {
+ default
+
+ use qt5 && emake -C src/dhcpcd-qt
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ use qt5 && emake -C src/dhcpcd-qt DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch
new file mode 100644
index 000000000000..2ed516048e5d
--- /dev/null
+++ b/net-misc/dhcpcd-ui/files/dhcpcd-ui-0.7.9-respect-qmake-args.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index ec61c80..9372b38 100755
+--- a/configure
++++ b/configure
+@@ -230,7 +230,7 @@ if [ -n "$LDFLAGS" ]; then
+ echo "LDFLAGS=" >>$CONFIG_MK
+ echo "LDFLAGS+= $LDFLAGS" >>$CONFIG_MK
+ fi
+-QMAKE_CONFIG=
++#QMAKE_CONFIG
+
+ for x in $INCLUDEDIR; do
+ echo "CPPFLAGS+= -I$x" >>$CONFIG_MK