summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 16:02:10 +0100
committerSam James <sam@gentoo.org>2022-06-12 16:19:26 +0100
commitb01475efcbf9611fb85af8a66edbb5a3ffd79e18 (patch)
tree0bfa33b774e5e9a51a70bd22cce6cbd9dd50863f /net-misc/ntpsec/ntpsec-9999.ebuild
parentdev-python/pydevd: drop -r1 back to ~arch (diff)
downloadgentoo-b01475efcbf9611fb85af8a66edbb5a3ffd79e18.tar.gz
gentoo-b01475efcbf9611fb85af8a66edbb5a3ffd79e18.tar.bz2
gentoo-b01475efcbf9611fb85af8a66edbb5a3ffd79e18.zip
net-misc/ntpsec: fix distutils-r1 usage
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec/ntpsec-9999.ebuild')
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild42
1 files changed, 16 insertions, 26 deletions
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index 4d49e9065f2e..c5b75b26451e 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -54,7 +54,6 @@ BDEPEND=">=app-text/asciidoc-8.6.8
PATCHES=(
"${FILESDIR}/${PN}-1.1.9-remove-asciidoctor-from-config.patch"
- "${FILESDIR}/${PN}-py3-test-clarify.patch"
)
WAF_BINARY="${S}/waf"
@@ -87,7 +86,7 @@ src_configure() {
done
CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
- local myconf=(
+ myconf=(
--notests
--nopyc
--nopyo
@@ -103,45 +102,30 @@ src_configure() {
$(use debug && echo "--enable-debug")
)
- python_configure() {
- waf-utils_src_configure "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
+ distutils-r1_src_configure
}
-src_compile() {
- unset MAKEOPTS
- python_compile() {
- waf-utils_src_compile --notests
- }
- python_foreach_impl run_in_build_dir python_compile
+python_configure() {
+ waf-utils_src_configure "${myconf[@]}"
}
-src_test() {
- python_compile() {
- waf-utils_src_compile check
- }
- python_foreach_impl run_in_build_dir python_compile
+python_compile() {
+ unset MAKEOPTS
+ waf-utils_src_compile --notests
}
python_test() {
- # Silence QA warning as we're running tests via src_test anyway.
- :;
+ waf-utils_src_compile check
}
src_install() {
- python_install() {
- waf-utils_src_install --notests
- python_fix_shebang "${ED}"
- }
- python_foreach_impl run_in_build_dir python_install
- python_foreach_impl python_optimize
+ distutils-r1_src_install
# Install heat generating scripts
use heat && dosbin "${S}"/contrib/ntpheat{,usb}
# Install the openrc files
- newinitd "${FILESDIR}"/ntpd.rc-r2 ntp
+ newinitd "${FILESDIR}"/ntpd.rc-r3 ntp
newconfd "${FILESDIR}"/ntpd.confd ntp
# Install the systemd unit file
@@ -165,6 +149,12 @@ src_install() {
use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
}
+python_install() {
+ waf-utils_src_install --notests
+ python_fix_shebang "${ED}"
+ python_optimize
+}
+
pkg_postinst() {
einfo "If you want to serve time on your local network, then"
einfo "you should disable all the ref_clocks unless you have"