summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-03-19 03:49:53 -0500
committerBen Kohler <bkohler@gentoo.org>2021-03-19 03:50:04 -0500
commit1eada5677e603270026352a2e870d16515f39ad5 (patch)
tree71ea0e27fde719bc54e06fe1dd21002ecf13bdb3 /net-misc
parentdev-python/lark-parser: D_U_S already defined in 0.11.2 (diff)
downloadgentoo-1eada5677e603270026352a2e870d16515f39ad5.tar.gz
gentoo-1eada5677e603270026352a2e870d16515f39ad5.tar.bz2
gentoo-1eada5677e603270026352a2e870d16515f39ad5.zip
net-misc/dropbox: bump to 118.4.460
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbox/Manifest2
-rw-r--r--net-misc/dropbox/dropbox-118.4.460.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/net-misc/dropbox/Manifest b/net-misc/dropbox/Manifest
index 1611e33ce06c..d154b0a00ea5 100644
--- a/net-misc/dropbox/Manifest
+++ b/net-misc/dropbox/Manifest
@@ -1,2 +1,4 @@
DIST dropbox-lnx.x86-117.4.378.tar.gz 98240407 BLAKE2B 2a4a1f2967cc3b4fb59461d3ab94a8cb120db5ec3283d4ef0b1b13ad69e903bb87e11dbc72b1d1e2969aded63f03390af0087026864699c679276d195ec6e54f SHA512 261aad190643e02a102b70ce5418cf61f8affcf3607e6b35d91ec5713fb7ee058d2e20390fd6e8c434ae69d6f888ff390b12d2f544aa2b08a7ac98a9c545811d
+DIST dropbox-lnx.x86-118.4.460.tar.gz 98620060 BLAKE2B 3b2aa51cd93d2ccfc78efe434ba2fd2a7bf270c54e64d009ce7d82927b85805d1616525aa8433afe3c59c8b7d15b3cfd129b8f85a504210e05fd2d95024e9589 SHA512 1858c1bafcb87cf5db44549ac3b12f56402ac2ef63e959d9d22a42952ca4a620115f92021736560e350730a5f5f0da52abf2d5b5c7765f82e39fb4f9b76098e4
DIST dropbox-lnx.x86_64-117.4.378.tar.gz 101675442 BLAKE2B 42dbb52a4cb1998b1e114e5486acc0a89191c1856f1391c3f19186937faeae12ceec39e5496744f3237e457656f50d4c6af6b4f9ad5b02541e946c96f325ba92 SHA512 876314d7d56692c34c714c7aa8d03d5e9250a5a5bb72c74a16eaee68cf1cf28d4585e4b3ac457dc42d0230d222d62eeeab66672765c182d999f7200a1335a4b7
+DIST dropbox-lnx.x86_64-118.4.460.tar.gz 102012647 BLAKE2B 87ee9e246e5e4c7cd4b5fe7aacbbe028ebec3f02abf650b1d8d8f867aea0900d05ae697ec02916b59b19ad3049606bfa1c63a286f7d21a335650a4322978c345 SHA512 206bb2bc4932d0784438df8de4dfecbbc6deda4ca71f8cd5dced17066293f41f8a722d7e05516e24fcc163cdb9e475733d75d19b369a7f63b3a7f1a966f0d5f4
diff --git a/net-misc/dropbox/dropbox-118.4.460.ebuild b/net-misc/dropbox/dropbox-118.4.460.ebuild
new file mode 100644
index 000000000000..a77b20f7a3b2
--- /dev/null
+++ b/net-misc/dropbox/dropbox-118.4.460.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop pax-utils systemd xdg
+
+DESCRIPTION="Dropbox daemon (pretends to be GUI-less)"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="
+ amd64? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz )
+ x86? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86-${PV}.tar.gz )"
+
+LICENSE="BSD-2 CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="selinux X"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/.*"
+QA_EXECSTACK="opt/dropbox/dropbox"
+
+BDEPEND="dev-util/patchelf"
+
+# Be sure to have GLIBCXX_3.4.9, #393125
+RDEPEND="
+ X? (
+ x11-themes/hicolor-icon-theme
+ )
+ selinux? ( sec-policy/selinux-dropbox )
+ app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libffi-compat:6
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/wget
+ sys-libs/zlib
+ sys-libs/ncurses-compat:5
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}" || die
+ mv "${WORKDIR}"/.dropbox-dist/* "${S}" || die
+ mv "${S}"/dropbox-lnx.*-${PV}/* "${S}" || die
+ rmdir "${S}"/dropbox-lnx.*-${PV}/ || die
+ rmdir .dropbox-dist || die
+}
+
+src_prepare() {
+ default
+ # we supply all of these in RDEPEND
+ rm -vf libGL.so.1 libX11* libffi.so.6 || die
+ # some of these do not appear to be used
+ rm -vf libQt5{OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets}.so.5 \
+ PyQt5.QtPrintSupport.* PyQt5.QtQml.* PyQt5.QtQuick.* \
+ wmctrl libdrm.so.2 libpopt.so.0 || die
+ if use X ; then
+ mv images/hicolor/16x16/status "${T}" || die
+ else
+ rm -vrf images || die
+ fi
+ patchelf --set-rpath '$ORIGIN' \
+ apex._apex.*.so \
+ nucleus_python.*.so \
+ tprt.*.so \
+ || die
+ pax-mark cm dropbox
+ mv README ACKNOWLEDGEMENTS "${T}" || die
+}
+
+src_install() {
+ local targetdir="/opt/dropbox"
+
+ insinto "${targetdir}"
+ doins -r *
+ fperms a+x "${targetdir}"/{dropbox,dropboxd}
+ dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"
+
+ use X && doicon -s 16 -c status "${T}"/status
+
+ make_desktop_entry "${PN}" "Dropbox" "dropboxstatus-logo"
+
+ newinitd "${FILESDIR}"/dropbox.initd dropbox
+ newconfd "${FILESDIR}"/dropbox.conf dropbox
+ systemd_newunit "${FILESDIR}"/dropbox_at.service-r2 "dropbox@.service"
+
+ dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
+}
+
+pkg_postinst() {
+ einfo "Warning: while running, dropbox may attempt to autoupdate itself in"
+ einfo " your user's home directory. To prevent this, run the following as"
+ einfo " each user who will run dropbox:"
+ einfo ""
+ einfo "install -dm0 ~/.dropbox-dist"
+}