summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-15 10:42:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-15 10:42:56 -0700
commit9190bd1a33a5060340b9815974779574320f13d3 (patch)
treec63041b2aa05c4d8d9867a2383f463d543ddc599 /net-misc
parentnet-misc/exabgp-3.4.28: Version bump, take maintainership (diff)
downloadgentoo-9190bd1a33a5060340b9815974779574320f13d3.tar.gz
gentoo-9190bd1a33a5060340b9815974779574320f13d3.tar.bz2
gentoo-9190bd1a33a5060340b9815974779574320f13d3.zip
net-misc/exabgp-4.2.6: Version bump, add py37, py38 (bug 718442)
Closes: https://bugs.gentoo.org/718442 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/exabgp/Manifest1
-rw-r--r--net-misc/exabgp/exabgp-4.2.6.ebuild37
-rw-r--r--net-misc/exabgp/files/exabgp-4.2.6-paths.patch13
3 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/exabgp/Manifest b/net-misc/exabgp/Manifest
index c56a99f38e2c..99bf1efea034 100644
--- a/net-misc/exabgp/Manifest
+++ b/net-misc/exabgp/Manifest
@@ -2,3 +2,4 @@ DIST exabgp-3.2.17.tar.gz 596373 BLAKE2B 410b77af542160334d32e3e3ea54b25f45c990c
DIST exabgp-3.4.26.tar.gz 544456 BLAKE2B 75f62ce8a68588f711e86208f00cc6de9ae51a5c82f833b91459bc05974c8eff06fec080823adfecea7b75a43caa3310f6395bd22ab4e6a696f230787bbaae23 SHA512 6cfcc8a40e1e05dfa76df46d8b5e13ce85e73f078d6ab4d2e23dd85035c1ed52bbbaaaade81602ea7572841e6e20d7d7183a7e968599f9e8314e1b89e3a6341f
DIST exabgp-3.4.28.tar.gz 546611 BLAKE2B c4916fd903fe8853e99ba872d87dc97908546c53d34936019c809ffa18761c3044dd7a21aace9bf6e5bb6a2823d2178422b4cdc2e8f65d7be1fda6de2755ae4d SHA512 40edde5262e3033b5fcccf1e6020cce1fe856b6e31420e14166d5e0d636e5f616283827af2cd82946d94a196ef76ed7c5330ac4bebc564329852869f13018403
DIST exabgp-4.0.10.tar.gz 2907852 BLAKE2B 2fad6c853aa7a6f136da3334df4b3bdcaaacd03d3fbf849510bcd40b0639bbcc521726797a196418f0ecd47047c65356ee047d30b009ee01b9d498e354ea3bfd SHA512 a21f49e5e99e28cc848cddfd3992dc18ba57d879d0964da0b906d16dca37aa05a00892d643d6cdeea80d4e629fc55a014d9bc50764d520fda77e94145297832e
+DIST exabgp-4.2.6.tar.gz 2922492 BLAKE2B de28d6e37dd46e240a224fb327ca85d9917d1447d43317fe93bd7d69a7963ee2ae6ecca613c91ade8d55f0d820c54e0ca88ebe18225f2dcee14c434e64bc1a76 SHA512 ad29195a46d1abbf0422ed8fe8013bb9ba3690d3e3876ea09f62bdc44581fda17f0499f45172b7ccac64f6d658770d9cdb7d00df4a12c211bc24310feb5cbbc6
diff --git a/net-misc/exabgp/exabgp-4.2.6.ebuild b/net-misc/exabgp/exabgp-4.2.6.ebuild
new file mode 100644
index 000000000000..5cb7947911a4
--- /dev/null
+++ b/net-misc/exabgp/exabgp-4.2.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="The BGP swiss army knife of networking"
+HOMEPAGE="https://github.com/Exa-Networks/exabgp"
+SRC_URI="https://github.com/Exa-Networks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/exabgp-4.2.6-paths.patch"
+)
+
+python_test() {
+ ./qa/bin/parsing || die "tests fail with ${EPYTHON}"
+ nosetests -v ./qa/tests/*_test.py || die "tests fail with ${EPYTHON}"
+}
diff --git a/net-misc/exabgp/files/exabgp-4.2.6-paths.patch b/net-misc/exabgp/files/exabgp-4.2.6-paths.patch
new file mode 100644
index 000000000000..035ba12bd682
--- /dev/null
+++ b/net-misc/exabgp/files/exabgp-4.2.6-paths.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 34c28e4d..e41069bc 100644
+--- a/setup.py
++++ b/setup.py
+@@ -31,7 +31,7 @@ def filesOf(directory):
+
+
+ data_files = [
+- ('etc/exabgp/examples', filesOf('etc/exabgp')),
++ ('/etc/exabgp/examples', filesOf('etc/exabgp')),
+ ]
+
+ if platform.system() != 'NetBSD':