summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-12 11:30:51 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-12 11:30:51 +0100
commit064a0f547b24e106202481e5d08796a7b0e53868 (patch)
tree3819cf408567afc7b356be80e84ccb55d97e8eda /net-p2p
parentsys-apps/usermode-utilities: Use proper fuse slot (diff)
downloadgentoo-064a0f547b24e106202481e5d08796a7b0e53868.tar.gz
gentoo-064a0f547b24e106202481e5d08796a7b0e53868.tar.bz2
gentoo-064a0f547b24e106202481e5d08796a7b0e53868.zip
net-p2p/nicotine+: Fix deps
Closes: https://bugs.gentoo.org/673916 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/nicotine+-1.4.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/nicotine+-1.4.1-r1.ebuild b/net-p2p/nicotine+/nicotine+-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..97f31a510c6b
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/1.4.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}