summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-08-24 16:13:08 -0400
committerMike Pagano <mpagano@gentoo.org>2024-08-24 16:13:08 -0400
commit1071b341c6e786067c2fa5d66bdfa9703ea74e8c (patch)
tree8a749759f444f0d55abb4179758541ecdc490260 /net-print
parentsci-libs/ceres-solver: fix build with GCC 15 (diff)
downloadgentoo-1071b341c6e786067c2fa5d66bdfa9703ea74e8c.tar.gz
gentoo-1071b341c6e786067c2fa5d66bdfa9703ea74e8c.tar.bz2
gentoo-1071b341c6e786067c2fa5d66bdfa9703ea74e8c.zip
net-print/epson-inkjet-printer-escpr: add 1.2.14
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/epson-inkjet-printer-escpr/Manifest1
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.14.ebuild36
-rw-r--r--net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.14.patch89
3 files changed, 126 insertions, 0 deletions
diff --git a/net-print/epson-inkjet-printer-escpr/Manifest b/net-print/epson-inkjet-printer-escpr/Manifest
index b911f5172313..f789b17f35f2 100644
--- a/net-print/epson-inkjet-printer-escpr/Manifest
+++ b/net-print/epson-inkjet-printer-escpr/Manifest
@@ -1,2 +1,3 @@
DIST epson-inkjet-printer-escpr-1.8.5-1.tar.gz 5666905 BLAKE2B 549c948709993779b5615b501038fdceb6c3d6f173709b8cf99459346fff89923bdbe1babe34ee98eed4e1ebbd7a4b5962ddbc9cec9711aa15ff2056fec3d436 SHA512 4117b1efe903e4f506bbc67c45079f1d467ff6527691308734e55d32feeda3ec44b2dd85361e0243114f924eef04a91b0a5e86b5008f0a32ef323989b3d2896f
+DIST epson-inkjet-printer-escpr2-1.2.14-1.tar.gz 5517765 BLAKE2B 94c56e7f36e05ce3464ac8e4e1d12c770f9235973465f374b2dbe6cefaf43c9647594ec3c6513501d4583a97181467d83fb0eed9d8d5264f7cc07078e1038e77 SHA512 1e5595c731957a9a2d0d009f63e75ab78bfa76312ee767583c352956b39cb51e56ac0a95c9d30a57ae2c2b27cc89a9d7f02011e201c51c4bb4362505dbd5a712
DIST epson-inkjet-printer-escpr2-1.2.9-1.tar.gz 5367737 BLAKE2B 6868569a6bed622e2f50619a36ffb0a0f7e834fd8a794ae3bc906d971db26b0c86386c9545190ec384027d0b8e8f62ddda6cb24f1e3f60b9c535a1eeddff4332 SHA512 70ff744d42fac4c79d2994648763b0b3970ee5463a7a310a0721a63735d536cb9a0499c894289d946b30e6f564f9bf60aa61801580ab6635af211d50867921a1
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.14.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.14.ebuild
new file mode 100644
index 000000000000..b1bc155ddd03
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux"
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/16/04/80/9eed4e48a994b2ce7d9c83aa7fa7766f2c2d7ef3/${MY_P}-1.tar.gz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="EPSON LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~amd64"
+
+QA_FLAGS_IGNORED="/usr/lib64/libescpr2.so.1.0.0"
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/gcc-no-implicit-function-declaration-${PV}.patch"
+)
+
+src_configure() {
+ econf \
+ --with-cupsfilterdir="${EPREFIX}/usr/libexec/cups/filter"
+ --with-cupsppddir="${EPREFIX}/usr/share/ppd"
+}
+
+src_install() {
+ default
+
+ find "${ED}/usr/lib64" -name "*.la" -delete \
+ || die "Removal of libtool files (.la) has failed."
+}
diff --git a/net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.14.patch b/net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.14.patch
new file mode 100644
index 000000000000..ab244ddbe71b
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.14.patch
@@ -0,0 +1,89 @@
+From 70b13d5be6d9ca55c0a9ec0dd401c9401922b1b7 Mon Sep 17 00:00:00 2001
+From: Aleix Quintana Alsius <kinta@communia.org>
+Date: Fri, 31 May 2024 23:51:51 +0200
+Subject: [PATCH] reroll update x86-64 patch
+
+---
+ src/filter.c | 12 +++++++++---
+ src/mem.c | 1 +
+ src/wrapper.c | 1 +
+ 3 files changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/src/filter.c b/src/filter.c
+index d53e091..5bb2a5f 100644
+--- a/src/filter.c
++++ b/src/filter.c
+@@ -39,6 +39,7 @@
+ #include "epson-escpr-api.h"
+ #include "epson-escpr-services.h"
+ #include "epson-escpr-mem.h"
++#include "epson-escpr-services.h"
+
+ #include "err.h"
+ #include "mem.h"
+@@ -48,6 +49,11 @@
+ #include "optBase.h"
+ #include "linux_cmn.h"
+ #include "custompage.h"
++#include "xfifo.h"
++
++extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB*);
++extern EPS_ERR_CODE SendStartJob ();
++extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32*);
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+
+@@ -453,7 +459,7 @@ main (int argc, char *argv[])
+ }
+
+ printJob.jobStatus = EPS_STATUS_ESTABLISHED;
+- int printHeight = 0;
++ EPS_UINT32 printHeight = 0;
+ ///////////////////////////////////////////////////////////////////////////////////////////////////////////
+
+ print_area_x = printJob.printableAreaWidth;
+@@ -632,7 +638,7 @@ main (int argc, char *argv[])
+ memcpy(rever_buf + k*3, startpage + pos + (bandBmp.widthBytes - 6) - k*3, 3);
+ }
+ }
+- PrintBand (rever_buf, bandBmp.widthBytes, &printHeight);
++ PrintBand ((const EPS_UINT8 *)rever_buf, bandBmp.widthBytes, &printHeight);
+ pos -= bandBmp.widthBytes;
+ }
+
+@@ -925,7 +931,7 @@ set_pips_parameter (filter_option_t *filter_opt_p, EPS_OPT *printOpt)
+
+ /* Get number of pages */
+ char page_num;
+- read (STDIN_FILENO, &page_num, 1);
++ (void)read (STDIN_FILENO, &page_num, 1);
+ debug_msg("total pages = %d\n", page_num);
+
+ /* Others */
+diff --git a/src/mem.c b/src/mem.c
+index f53f2bc..d6c945a 100644
+--- a/src/mem.c
++++ b/src/mem.c
+@@ -23,6 +23,7 @@
+
+ #include <stdlib.h>
+ #include "mem.h"
++#include "err.h"
+
+ void *
+ mem_malloc (unsigned int size, bool_t crit)
+diff --git a/src/wrapper.c b/src/wrapper.c
+index 1fa6daa..bfd567d 100644
+--- a/src/wrapper.c
++++ b/src/wrapper.c
+@@ -33,6 +33,7 @@
+ /* added 22-04-2004 */
+ #include <signal.h>
+
++#include "custompage.h"
+ #include "libprtX.h"
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+--
+2.45.1
+