summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-15 08:09:32 +0000
committerSam James <sam@gentoo.org>2023-12-15 08:09:32 +0000
commit957095610b31869a336b66d9b6c7ddfca8db28c1 (patch)
tree3b02205e1349a9305bc8c750e1824566d3c203b7 /perl-core
parentsys-fs/static-dev: Stabilize 0.1-r3 ppc64, #919973 (diff)
downloadgentoo-957095610b31869a336b66d9b6c7ddfca8db28c1.tar.gz
gentoo-957095610b31869a336b66d9b6c7ddfca8db28c1.tar.bz2
gentoo-957095610b31869a336b66d9b6c7ddfca8db28c1.zip
perl-core/Math-BigInt: add 1.999.842
Bug: https://bugs.gentoo.org/919888 Bug: https://bugs.gentoo.org/914392 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Math-BigInt/Manifest1
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.842.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
index ff9fb3a30547..b3b599f57773 100644
--- a/perl-core/Math-BigInt/Manifest
+++ b/perl-core/Math-BigInt/Manifest
@@ -1,2 +1,3 @@
DIST Math-BigInt-1.999838.tar.gz 2870131 BLAKE2B 749e0b04175070a571dd749c99b3558ce7bce442ee800eb227d952723bfd09b588c8ce6f3ddd2d2b71e8c89dbd2be80ac1272f9725a7bc435db77fa2f4ffac15 SHA512 33beb52f3e952d78e637336e61522416256029cdd106bab1a8b7d26a0b0f6aee16b779819b6922e99ccd3d67b14766ed661b2dec39dd9b31da4608df4fbe548f
DIST Math-BigInt-1.999840.tar.gz 2910416 BLAKE2B 38b49cac8be6b9807fbb49f9bb45e4a684f8bd9dc1fc748cb134b3d33b863c8151e09773256ece13275241f3f76e20184509f2f7e7aa1a73577d11e7e4e27296 SHA512 de565d916e0f53144437f2d28c4046579ff73963241d7dafa6d36987cc7cfe9838a5cf0ff3b8697be1a5e77a0c270ced70d43a25a8dc17a664d917751755a455
+DIST Math-BigInt-1.999842.tar.gz 2874389 BLAKE2B bed8b8bc7d39caaae630ae815cc39b6cfc1366cdb35da62c8f26396f51c3f6a649e6ba43e11bf39283b3d772fc20fded90594c3bf5df9fb8f20cb3d1df2d64be SHA512 22183ff49bcb33c503601729d9147b64c5c6c2e2717cebba929e3b36fbe0a2c20ca442b49ade4d9ea15b04f1050b6f9d333a168e3a08bbcab48ce842d69f253c
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.842.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.842.ebuild
new file mode 100644
index 000000000000..69c99e4a9a3c
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.842.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999842
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.220.0
+ >=virtual/perl-Math-Complex-1.390.0
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+# TODO: where does this come from?
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.500.600
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}