summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2021-01-10 00:33:18 +0800
committerYixun Lan <dlan@gentoo.org>2021-01-11 21:51:55 +0800
commitaca9de306da677ac90b741df271709aaa50bbe0c (patch)
tree3d442589fc27a4d03b388c4b05034167dc6f1339 /sci-electronics/systemc
parentdev-util/idea-community: Version bump, remove old. (diff)
downloadgentoo-aca9de306da677ac90b741df271709aaa50bbe0c.tar.gz
gentoo-aca9de306da677ac90b741df271709aaa50bbe0c.tar.bz2
gentoo-aca9de306da677ac90b741df271709aaa50bbe0c.zip
sci-electronics/systemc: bump to 2.3.4
Also add Huang Rui as proxy-maintainer Closes: https://github.com/gentoo/gentoo/pull/19006 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Huang Rui <vowstar@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-electronics/systemc')
-rw-r--r--sci-electronics/systemc/Manifest1
-rw-r--r--sci-electronics/systemc/metadata.xml13
-rw-r--r--sci-electronics/systemc/systemc-2.3.4.ebuild52
3 files changed, 65 insertions, 1 deletions
diff --git a/sci-electronics/systemc/Manifest b/sci-electronics/systemc/Manifest
index 00af93db1ea9..48ad212d20eb 100644
--- a/sci-electronics/systemc/Manifest
+++ b/sci-electronics/systemc/Manifest
@@ -1 +1,2 @@
DIST systemc-2.3.1a.tar.gz 7050669 BLAKE2B eb080ba177ada7fcd816134e62e6461da59a186cd5d1a14627d69d425f72becd587ef7d31e9e48af76cf54f92ccf83f38a079e5598b4fe2e6b349dc4ec74f640 SHA512 cd52eb6e413c8b852e19c8387766eacbddf85e9b2f4d137f3d82d0d4025f13a44216a2e6cacf7b9e2b972584912a4a1c75cdb37a568330ce66a6bf909ca1b723
+DIST systemc-2.3.4.tar.gz 7142529 BLAKE2B 8a7e7e9f49b0131c1536d217dcc4fc420bc72ed962736a457cdaf3e40390be2a5051010317a62ba1eca17ee7ee4a171950979d2f07cb7fecc7286d028675540f SHA512 77fd1810fafeaa639cb21fcd77c7132c0ba3cf42309d3e09953c62c92f83b18e6de2e26620cee267683ca851503e5a8419523e7c9161f2ae33aea372af0be966
diff --git a/sci-electronics/systemc/metadata.xml b/sci-electronics/systemc/metadata.xml
index 69bab89b6add..dfe18456e677 100644
--- a/sci-electronics/systemc/metadata.xml
+++ b/sci-electronics/systemc/metadata.xml
@@ -1,11 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
<maintainer type="project">
<email>sci-electronics@gentoo.org</email>
<name>Gentoo Electronics Project</name>
</maintainer>
- <longdescription>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">accellera-official/systemc</remote-id>
+ </upstream>
+ <longdescription lang="en">
SystemC provides hardware-oriented constructs within the context of C++
as a class library implemented in standard C++. Its use spans design and
verification from concept to implementation in hardware and software.
diff --git a/sci-electronics/systemc/systemc-2.3.4.ebuild b/sci-electronics/systemc/systemc-2.3.4.ebuild
new file mode 100644
index 000000000000..b9efef41568a
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV}_pub_rev_20190614"
+
+inherit autotools
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="
+ https://accellera.org/community/systemc
+ https://github.com/accellera-official/systemc
+"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/accellera-official/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/accellera-official/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+
+DOCS=(AUTHORS.md CONTRIBUTING.md INSTALL.md LICENSE NOTICE README.md RELEASENOTES)
+
+src_prepare() {
+ default
+ eautoconf --force
+}
+
+src_configure() {
+ econf CXX=$(tc-getCXX) \
+ $(use_enable debug) \
+ $(use_enable static-libs static) \
+ --with-unix-layout
+}
+
+pkg_postinst() {
+ elog "If you want to run the examples, you need to :"
+ elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
+ elog " cd ${PN}-${MY_PV}"
+ elog " mkdir build && cd build"
+ elog " cmake .."
+ elog " cd examples"
+ elog " make check"
+}