summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2019-05-20 18:17:04 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2019-05-20 18:17:04 +0200
commit48d645dcf43ea91f1a543f4d42735cb805464cbb (patch)
tree7e8e6b0e01fe099133708e2f4497cf03020497c9 /sci-electronics
parentsci-electronics/geda: Drop old (diff)
downloadgentoo-48d645dcf43ea91f1a543f4d42735cb805464cbb.tar.gz
gentoo-48d645dcf43ea91f1a543f4d42735cb805464cbb.tar.bz2
gentoo-48d645dcf43ea91f1a543f4d42735cb805464cbb.zip
sci-electronics/geda: Add missing library to linker stage.
Thanks for reporting: Constantin Runge <c.runge@cssbook.de> Closes: https://bugs.gentoo.org/684870 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/geda/geda-1.9.2-r1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/sci-electronics/geda/geda-1.9.2-r1.ebuild b/sci-electronics/geda/geda-1.9.2-r1.ebuild
index 2a44a907ab44..08129958fc60 100644
--- a/sci-electronics/geda/geda-1.9.2-r1.ebuild
+++ b/sci-electronics/geda/geda-1.9.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -52,6 +52,19 @@ src_prepare() {
sed -i -e 's/\texamples$//' Makefile.in || die
fi
+ # add missing GIO_LIB Bug #684870
+ sed -i -e 's/gsymcheck_LDFLAGS =/gsymcheck_LDFLAGS = $(GIO_LIBS)/' \
+ gsymcheck/src/Makefile.am || die
+
+ sed -i -e 's/gnetlist_LDFLAGS =/gnetlist_LDFLAGS = $(GIO_LIBS)/' \
+ gnetlist/src/Makefile.am || die
+
+ sed -i -e 's/gschlas_LDFLAGS =/gschlas_LDFLAGS = $(GIO_LIBS)/' \
+ utils/gschlas/Makefile.am || die
+
+ sed -i -e 's/sarlacc_schem_LDFLAGS =/sarlacc_schem_LDFLAGS = $(GIO_LIBS)/' \
+ contrib/sarlacc_schem/Makefile.am || die
+
eautoreconf
}