summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-29 01:26:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-29 01:27:08 +0200
commit57c9698e1ddecc9a6bd97d304d9da851e4c9d158 (patch)
tree37d8b741977478f038d62733c69592b49df32644 /sci-mathematics
parentacct-user/strelaysrv: add myself as a maintainer (diff)
downloadgentoo-57c9698e1ddecc9a6bd97d304d9da851e4c9d158.tar.gz
gentoo-57c9698e1ddecc9a6bd97d304d9da851e4c9d158.tar.bz2
gentoo-57c9698e1ddecc9a6bd97d304d9da851e4c9d158.zip
sci-mathematics/stp: build tweaks
Closes: https://bugs.gentoo.org/880135 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/stp/stp-2.3.3-r3.ebuild8
-rw-r--r--sci-mathematics/stp/stp-2.3.4.ebuild10
2 files changed, 14 insertions, 4 deletions
diff --git a/sci-mathematics/stp/stp-2.3.3-r3.ebuild b/sci-mathematics/stp/stp-2.3.3-r3.ebuild
index ae62721212d2..bd4d40fd22d4 100644
--- a/sci-mathematics/stp/stp-2.3.3-r3.ebuild
+++ b/sci-mathematics/stp/stp-2.3.3-r3.ebuild
@@ -100,12 +100,18 @@ src_configure() {
fi
local -a mycmakeargs=(
- -DTEST_C_API=OFF # C API test fail
-DNOCRYPTOMINISAT=$(usex cryptominisat 'OFF' 'ON') # double negation
-DENABLE_PYTHON_INTERFACE=$(usex python)
-DENABLE_ASSERTIONS=$(usex test)
-DENABLE_TESTING=$(usex test)
)
+
+ if use test ; then
+ mycmakeargs+=(
+ -DTEST_C_API=OFF # C API test fail
+ )
+ fi
+
cmake_src_configure
}
diff --git a/sci-mathematics/stp/stp-2.3.4.ebuild b/sci-mathematics/stp/stp-2.3.4.ebuild
index ab1cbf96c2d2..ab792a8ff3cd 100644
--- a/sci-mathematics/stp/stp-2.3.4.ebuild
+++ b/sci-mathematics/stp/stp-2.3.4.ebuild
@@ -78,9 +78,6 @@ src_configure() {
fi
local -a mycmakeargs=(
- # -DGTEST_PREFIX="${BROOT}/usr/$(get_libdir)/cmake/GTest"
-
- -DTEST_C_API=OFF # C API test fail
-DUSE_RISS=OFF
# Cryptominisat switches
@@ -91,6 +88,13 @@ src_configure() {
-DENABLE_ASSERTIONS=$(usex test)
-DENABLE_TESTING=$(usex test)
)
+
+ if use test ; then
+ mycmakeargs+=(
+ -DTEST_C_API=OFF # C API test fail
+ )
+ fi
+
cmake_src_configure
}