summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-08-02 01:06:58 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-26 11:50:00 +0200
commitcb0a7488023274b9a567fbddd5d0198d7b9ec5fe (patch)
treec080dce48d2a3e1c5edefd987574f1cfd2bf773d /sci-physics
parentvirtual/dist-kernel: Stabilize 5.4.211 ppc64, #866647 (diff)
downloadgentoo-cb0a7488023274b9a567fbddd5d0198d7b9ec5fe.tar.gz
gentoo-cb0a7488023274b9a567fbddd5d0198d7b9ec5fe.tar.bz2
gentoo-cb0a7488023274b9a567fbddd5d0198d7b9ec5fe.zip
sci-physics/fastjet-contrib: Fix tc ar and ranlib
Closes: https://github.com/gentoo/gentoo/pull/26621 Closes: https://bugs.gentoo.org/860222 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet-contrib/fastjet-contrib-1.049-r1.ebuild (renamed from sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild)6
-rw-r--r--sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch247
-rw-r--r--sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch4
3 files changed, 253 insertions, 4 deletions
diff --git a/sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild b/sci-physics/fastjet-contrib/fastjet-contrib-1.049-r1.ebuild
index cf942ac11e58..5327d49c484d 100644
--- a/sci-physics/fastjet-contrib/fastjet-contrib-1.049.ebuild
+++ b/sci-physics/fastjet-contrib/fastjet-contrib-1.049-r1.ebuild
@@ -22,12 +22,14 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-soname.patch
+ "${FILESDIR}"/${P}-ar.patch
)
src_configure() {
- CXX=`tc-getCXX`
- ./configure --prefix=/usr --fastjet-config=/usr/bin/fastjet-config CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" FFLAGS="${FFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ tc-export CXX AR RANLIB
+ ./configure --prefix=/usr --fastjet-config=/usr/bin/fastjet-config RANLIB="${RANLIB}" AR="${AR}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" FFLAGS="${FFLAGS}" LDFLAGS="${LDFLAGS}" || die
}
+
src_compile() {
emake
emake fragile-shared
diff --git a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch
new file mode 100644
index 000000000000..b7578bd76738
--- /dev/null
+++ b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch
@@ -0,0 +1,247 @@
+--- a/Centauro/Makefile
++++ b/Centauro/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ClusteringVetoPlugin/Makefile
++++ b/ClusteringVetoPlugin/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ConstituentSubtractor/Makefile
++++ b/ConstituentSubtractor/Makefile
+@@ -41,8 +41,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/EnergyCorrelator/Makefile
++++ b/EnergyCorrelator/Makefile
+@@ -40,8 +40,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/FlavorCone/Makefile
++++ b/FlavorCone/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/GenericSubtractor/Makefile
++++ b/GenericSubtractor/Makefile
+@@ -38,8 +38,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/JetCleanser/Makefile
++++ b/JetCleanser/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/JetFFMoments/Makefile
++++ b/JetFFMoments/Makefile
+@@ -34,8 +34,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ examples: example
+
+--- a/JetsWithoutJets/Makefile
++++ b/JetsWithoutJets/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/LundPlane/Makefile
++++ b/LundPlane/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/Nsubjettiness/Makefile
++++ b/Nsubjettiness/Makefile
+@@ -40,8 +40,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES) $(EXAMPLES2)
+--- a/QCDAwarePlugin/Makefile
++++ b/QCDAwarePlugin/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/RecursiveTools/Makefile
++++ b/RecursiveTools/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ScJet/Makefile
++++ b/ScJet/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/scripts/internal/Template/Makefile
++++ b/scripts/internal/Template/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/SoftKiller/Makefile
++++ b/SoftKiller/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/SubjetCounting/Makefile
++++ b/SubjetCounting/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ValenciaPlugin/Makefile
++++ b/ValenciaPlugin/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/VariableR/Makefile
++++ b/VariableR/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
diff --git a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
index 5f69900cdc30..fe3794d5e0f5 100644
--- a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
+++ b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
@@ -1,5 +1,5 @@
---- fjcontrib-1.046.orig/Makefile.in 2022-03-10 13:44:33.963887464 +0100
-+++ fjcontrib-1.046/Makefile.in 2022-03-10 13:45:02.573890763 +0100
+--- a/Makefile.in
++++ b/Makefile.in
@@ -54,7 +54,7 @@
fragile_SHARED_SRC_LIST=@FRAGILE_SHARED_SRC_LIST@