summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2021-05-03 20:10:26 -0400
committerMiroslav Šulc <fordfrog@gentoo.org>2021-05-04 11:21:09 +0200
commit0b2d666c2babeded0b8ff1c380d428c5ab4607e1 (patch)
tree80ab69872703ce058f335193b4a208b986552152 /sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild
parentdev-java/json-simple: update java deps (diff)
downloadgentoo-0b2d666c2babeded0b8ff1c380d428c5ab4607e1.tar.gz
gentoo-0b2d666c2babeded0b8ff1c380d428c5ab4607e1.tar.bz2
gentoo-0b2d666c2babeded0b8ff1c380d428c5ab4607e1.zip
sci-visualization/gcalc: updated java deps
Also, update to EAPI 7. Regarding sci-mathematics/gcalc, I did some grepping and found no mention of it anywhere else in the repo. I think it's just an artifact of a realllly old re-categorization. Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20608/commits/3a217c7f3c5f31abcbcb3ae81e5dbeb80246beee Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild')
-rw-r--r--sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild b/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild
new file mode 100644
index 000000000000..f5a27970376f
--- /dev/null
+++ b/sci-visualization/gcalc/gcalc-3.1_rc1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-pkg-2 java-pkg-simple
+
+MY_P="GCalc-${PV/_/-}"
+DESCRIPTION="Java Mathematical Graphing System"
+HOMEPAGE="http://gcalc.net/"
+SRC_URI="http://gcalc.net/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ java-pkg_clean
+ default
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar src ! -name "*.html"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher gcalc --main net.gcalc.calc.GCalc
+
+ newicon src/resources/gicon.png ${PN}.png
+ make_desktop_entry ${PN} "GCalc Java Mathematical Graphing System"
+}