summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-10 23:27:14 -0400
committerSam James <sam@gentoo.org>2024-06-14 07:44:44 +0100
commitf4858b42d5c1e4aecb56182098a7aca1877abd47 (patch)
tree424e01ab5b13ce3e75ecd3711bcdbae187f64dce /sys-auth/libyubikey
parentapp-crypt/ccid: make sure elibtoolize is applied (diff)
downloadgentoo-f4858b42d5c1e4aecb56182098a7aca1877abd47.tar.gz
gentoo-f4858b42d5c1e4aecb56182098a7aca1877abd47.tar.bz2
gentoo-f4858b42d5c1e4aecb56182098a7aca1877abd47.zip
sys-auth/libyubikey: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth/libyubikey')
-rw-r--r--sys-auth/libyubikey/libyubikey-1.13.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-auth/libyubikey/libyubikey-1.13.ebuild b/sys-auth/libyubikey/libyubikey-1.13.ebuild
index ca3ecbd23b6f..e6714c24923b 100644
--- a/sys-auth/libyubikey/libyubikey-1.13.ebuild
+++ b/sys-auth/libyubikey/libyubikey-1.13.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
DESCRIPTION="Yubico C low-level library"
HOMEPAGE="https://github.com/Yubico/yubico-c"
SRC_URI="http://opensource.yubico.com/yubico-c/releases/${P}.tar.gz"
@@ -11,6 +13,11 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf --disable-static
}