summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-26 22:30:43 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-26 22:49:59 +0100
commit775908576d06ed674ea1cb8d86ef524845db90b0 (patch)
tree8494ac0fa431c9739f879754f142d59df7a2e07f /sys-auth/pam_yubico
parentdev-python/rsa: Clean up vulnerable versions. (diff)
downloadgentoo-775908576d06ed674ea1cb8d86ef524845db90b0.tar.gz
gentoo-775908576d06ed674ea1cb8d86ef524845db90b0.tar.bz2
gentoo-775908576d06ed674ea1cb8d86ef524845db90b0.zip
sys-auth/pam_yubico: Bump to version 2.24
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-auth/pam_yubico')
-rw-r--r--sys-auth/pam_yubico/Manifest1
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.24.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/Manifest b/sys-auth/pam_yubico/Manifest
index 3d0c3ad1c43c..c2c274ca6756 100644
--- a/sys-auth/pam_yubico/Manifest
+++ b/sys-auth/pam_yubico/Manifest
@@ -1,2 +1,3 @@
DIST pam_yubico-2.19.tar.gz 410136 SHA256 ed6e5841bb5104528a2155cb4b35bea18ebf3ddd8a4faf59eca3b1e2ac9c50ef SHA512 26e5246d99b5d8d5afbed4ba459f431635327512a29f6c29b547a1a0553f8d2ee79740f167c18266cf925df25df9ab962ee0180ca3a30bc553a7f9f7801a1ed7 WHIRLPOOL f6ca4678487c965d1a9c10e8e9c679b162e5ad690c1fec46a6498c2354300dc31f1c2e88faa6574f267798feb171ecb3a19801e9c1c0b866d2b57154036bc001
DIST pam_yubico-2.23.tar.gz 418567 SHA256 bc7193ed10c8fb7a2878088af859a24a7e6a456e1728a914eb5ed47cdff0ecb8 SHA512 435a5013ef7d020f8fe6d54614b22a4d3df6295adeb8e1fd26722246d105375b8d19940098b62956a18f439dad82f67e3996a7067af3357fddff380d20fa4728 WHIRLPOOL c26921a2703ebaac336a3bf9fa653020af9a55a390a1e7460c85a7b07fecba0c2192cf6663e2f77953798052957c925c65892b5da3cedc435fd704c551f28e88
+DIST pam_yubico-2.24.tar.gz 418419 SHA256 0326ff676e2b32ed1dda7fb5f1358a22d629d71caad8f8db52138bbf3e95e82d SHA512 3554b40d97ede9d02102a0661e732347a0ab2cb012fa4330cc8227289a03398a7b974ee9d170604dce53ebef1bedade5c7ab9d5657560b0ba8e4c65432c1112c WHIRLPOOL 62c5c270dbcd83d1c25d67b56ee8c39181dbdd5dee076619f071bb57f2f07a185d22d508a18581c8a8d3804889569d297c9071c0cf28e27379d20ea900c294a7
diff --git a/sys-auth/pam_yubico/pam_yubico-2.24.ebuild b/sys-auth/pam_yubico/pam_yubico-2.24.ebuild
new file mode 100644
index 000000000000..212e18af0eac
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap test"
+
+RDEPEND="
+ virtual/pam
+ sys-auth/libyubikey
+ >=sys-auth/ykclient-2.15
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? ( dev-perl/Net-LDAP-Server )"
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ #prune_libtool_files #why doesn't this work?
+ find "${D}" -name '*.la' -delete || die
+}