summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-19 22:15:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-20 10:32:51 +0200
commite11dec8a46d946cdb738a9ea1accce675bc0a511 (patch)
treeb8aacacec0b0d194647757d6a029468083468c47 /sys-auth/polkit-qt
parentdev-lang/starlark-rust: Require latest nightly rust (diff)
downloadgentoo-e11dec8a46d946cdb738a9ea1accce675bc0a511.tar.gz
gentoo-e11dec8a46d946cdb738a9ea1accce675bc0a511.tar.bz2
gentoo-e11dec8a46d946cdb738a9ea1accce675bc0a511.zip
sys-auth/polkit-qt: 0.114.0 version bump
See also: https://mail.kde.org/pipermail/kde-announce-apps/2021-June/005660.html Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-auth/polkit-qt')
-rw-r--r--sys-auth/polkit-qt/Manifest1
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.114.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/Manifest b/sys-auth/polkit-qt/Manifest
index 8b9fe5d7c40b..087cbaa35be7 100644
--- a/sys-auth/polkit-qt/Manifest
+++ b/sys-auth/polkit-qt/Manifest
@@ -1 +1,2 @@
DIST polkit-qt-1-0.113.0.tar.xz 64652 BLAKE2B 52d8c5c8009e2595c70db5b6a6349e4524d6d9cbec12c5a535f25d737da1d16e77fadf3572eebbede7a5ed583c818e878119b416d69a076e03bb37d2f7da7b41 SHA512 deea5d75f547eaa0279c664ec9608b65f464db97fd5fdea27437f8ed4ec033de2b9f91d967deacb28bf0a1e54f131f997acb862cc3e1f8dfcb1f6c337e719b38
+DIST polkit-qt-1-0.114.0.tar.xz 58384 BLAKE2B e788198e386797ba9b4c228a451dde703f83e79c81eacaf805e431a3f60c0832adc3faef4616e3008dfaa816d7dc5a7a80aaf02936ea232373e78e0d008724ca SHA512 4a16d9428d5ccc0107dcbd67c29ecba196424e555dc43d55cf2b6e0e7b72c99f894e9c994eaed85a9536010d67a19f20fe74f792c0d6b9ca0e05ce85f655f9a8
diff --git a/sys-auth/polkit-qt/polkit-qt-0.114.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.114.0.ebuild
new file mode 100644
index 000000000000..9af8b9c31a69
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.114.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake kde.org
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/polkit-qt-1/html/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}